Thinkpad T14s (Intel): Microphone is not found

Hi,

I just installed Manjaro Gnome Edition on my Thinkpad T14s (Intel CPU). Using the pre-installed kernel 5.7 there was no sound, just “Dummy output” and no input. I installed the 5.4 kernel (LTS) which made output work (both the laptop speakers and headphones) but not the microphone. On some forums I read that the 5.8 kernel makes the internal microphone work on AMD T14s but that didn’t work for me either. Any ideas what I can do now? (I’m willing to give further information but I don’t know which one you’d need to help …)

Cheers,
Malte

Hello,

This should help if you did not see it already
https://bbs.archlinux.org/viewtopic.php?id=257433

A good resource for comparison is here, even tho there is no mention about sound.
https://wiki.archlinux.org/index.php/Lenovo_Thinkpad_T14s_(AMD)_Gen_1

Thanks for the answer!
Following the last post of the first thread you linked, I tried to install pulseaudio-git from AUR using pamac GUI (I must admit that I’ve been too lazy to learn pacman’s cryptic options like -Syuu …) but that gives me the following errors:

could not satisfy dependencies:

  • removing fluidsynth breaks dependency ‘fluidsynth’ required by gst-plugins-bad,
  • if possible, remove gst-plugins-bad and retry
  • removing fluidsynth breaks dependency ‘fluidsynth=2.1.4’ required by lib32-fluidsynth,
  • if possible, remove lib32-fluidsynth and retry
  • removing fluidsynth breaks dependency ‘fluidsynth’ required by manjaro-pulse,
  • if possible, remove manjaro-pulse and retry
  • removing fluidsynth breaks dependency ‘libfluidsynth.so=2-64’ required by qsynth,
  • if possible, remove qsynth and retry

A comment at the AUR (htt ps://aur.archlinux.org/packages/pulseaudio-git/#comment-742446) says that this is a dependency problem with Gnome and suggests a fix but it looks like the PKGBUILD already contains this fix (?):

    depends=(lib{ltdl,soxr,asyncns,xtst,sndfile} "rtkit" "speexdsp" "tdb" "orc"
             "webrtc-audio-processing" jack2 "lirc" bluez{,-libs} "sbc"
             python-{pyqt5,dbus,sip} "fftw" dconf)
    makedepends=("git" lib{asyncns,xtst,tool,soxr,sndfile} "attr" "rtkit" "speexdsp"
                 "tdb" jack2 bluez{,-libs} "intltool"  "sbc" "lirc" "fftw"
                 "orc" "gtk3" "webrtc-audio-processing" "check" "autoconf-archive")
    optdepends=("alsa-plugins: ALSA support"
                "pulseaudio-alsa: ALSA configuration (recommended)"
                "lirc-utils: infra-red support")
    backup=(etc/pulse/{daemon.conf,default.pa,system.pa,client.conf})
    provides=(pulseaudio{,-{zeroconf,lirc,jack,bluetooth,equalizer}} "libpulse" libpulse{,-{simple,mainloop-glib}}.so)
    conflicts=(pulseaudio{,-{zeroconf,lirc,jack,bluetooth,equalizer}} "libpulse" libpulse{,-{simple,mainloop-glib}}.so)
    options=(!emptydirs)
    source=("git+git://anongit.freedesktop.org/pulseaudio/pulseaudio")
    sha256sums=('SKIP')

As I’m still a Manjaro/Arch/pacman/AUR newbie, I’m unsure what to do now. Thanks for any hints in advance!

Have you built the kernel modules ?

Thanks for your answer. I just tried that (installed linux-mainline via pamac GUI using the given config, edited /etc/modules-load.d/modules.conf, rebooted using the kernel 5.9.0-rc3-1-mainline) but I get only dummy output again.

I’d like to try the fix from the Arch forum bogdancovaciu mentioned above, but I would need some help building pulseaudio-git without dependency issues.

Can I help by providing some diagnostic information?

This worked for me: ht tps://forum.manjaro.org/t/fresh-manjaro-kde-install-no-sound-card-detected/21531/27

1 Like

Here is the link:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.