ThinkPad Helix docking problems

I installed manjaro gnome yesterday on my Thinkpad Helix (EDIT: 1st gen, Core-i7-3667U), it mostly works without problems, but I’ve found multiple problems:

  • The touchpad and trackpoint after un- and redocking doesn’t work, this issue is already described on the post forum[dot]manjaro[dot]org/t/thinkpad-helix-1st-generation-several-configuration-issues/27256 , but nobody has answered there yet.

  • The screen rotation lock button and Windows (super) button on the tablet part work without problems, until the tablet is undocked. These two buttons only work with the keyboard attached, and I can’t figure out why. EDIT: It appears, that all buttons, including power and volume buttons, are not functional in undocked mode.

EDIT: -> Regarding the two issues above, i checked ‘xinput list’, but the trackpad, trackpoint and extra buttons show up, also when unattached (which makes no real sense, because the trackpad and the trackpoint are disconnected at that point)

  • EDIT: Found another problem: The on-screen keyboard doesn’t work for putting in passwords for higher privileges (login from lockscreen, installing packages over pamac)

I’m new to Linux and want to learn more, so I hope someone can help me here, and point out issues (not just about my laptop, but also about this post, I’m new to this forum).

Hello, this should be a good start, since we don’t know if you have the first or second generation. Is unclear from the description with that topic you referenced.
https://wiki.archlinux.org/index.php/Lenovo_ThinkPad_Helix
https://wiki.archlinux.org/index.php/Lenovo_ThinkPad_Helix_2nd_Gen

If wiki is unhelpful with the information that has, is less of a chance that someone else here to be able to “solve” something just by reading about those devices, reason why nobody answered to that topic. If both you and the other OP can share what exactly failed from the wiki, we might spot something.

Thank you for your info, I edited the topic, didn’t even realize there was a 2nd gen of this device.

No worries. So, have you tried this part?

Is suppose to replace the magick-rotation that is no longer available in AUR, that used to respond to docking/undocking the tablet.

That means you have two approaches for the clickpad aka touchpad and trackpoint. The xf86-input-wacom is only for the Stylus.

So, if the events can be done trough the helix package, then that will trigger the functionality based on what state the tablet is docked or undocked. At least that is what i understand. Maybe that event can be used to reinitiate the detection of clickpad. Depending of what you use, as mentioned above, you have to check this:
https://wiki.archlinux.org/index.php/libinput
or, if you use the synaptics to check this:
https://wiki.archlinux.org/index.php/Touchpad_Synaptics

Synaptics is a bit outdated, and has a different way to troubleshoot than libinput. You have to see on your machine what makes it respond better. In each state, the devices can be still listed but not active, or for that particular event/state to have no defined option.

Hi, thanks again for answering, i looked at ‘libinput debug-events’, before undocking the trackpad and trackpoint events are there, when undocking there is an event that puts ‘tablet-state 1’, while undocked no device buttons work (except the power button, that’s also an extra device), when docking again, ‘tablet-state’ gets ‘0’ again, device-button events are shown again but trackpad and trackpoint events will not show up, until the computer is fully restarted.
I also found out that the wacom device gets added when pulling out the pen and removed when putting it back in. I guess that’s how it should be with docking and undocking (but obviously the other way around).

Maybe you can make use of a systemd service. See some examples from arch9ved forum


In particular look for thouchpad …

I found a workaround, I just need some help implementing it:
When restarting the mouse service responsible (psmouse) with my script

sudo rmmod psmouse -f -v
sleep 5
sudo modprobe psmouse -v

the trackpad and -point gets detected again, even when undocking and redocking again, I don’t have a clue why, but after restarting (EDIT: the script, not the PC) I get the right behaviour, until a full reboot, then the fix has to be applied again.
My only problem is, that I can’t add that script to /etc/profiles as it requires root access, and on login the screen just stays blank. Had to boot into my installer usb and revert that change for it to work again.

Regarding the other issues, the extra buttons and onscreen keyboard, I haven’t looked into these in detail yet, as the trackpad was the biggest issue for me, which I wanted to fix first.
Maybe I can make the extra buttons work with a workaround similar to the trackpad fix?
And again a big thanks to you for helping me fix the issue and I’m really enjoying manjaro linux, especially because it makes this laptop run much faster as in Windows.

@TristanKun did you get any further?
Following you post I tried executing

sudo rmmod psmouse -f -v

followed by

sudo modprobe psmouse -v

result: at first trackpad and -point still don’t work. Until I undock/dock once again, then they do start working.
(When I then undock/redock yet again, they stop working again)

Hi, I tested that method for over a week now, it’s kinda hit or miss, sometimes you have to run these commands multiple times to make it work.
I’ve used a wireless mouse (MX Anywhere 2) for two days now, so i haven’t noticed more problems with the trackpad, but sometimes the mouse randomly disconnects and I have to restart the laptop for it to work properly again.
Kinda strange…