Thinkpad e15 wifi not working on fresh install (realtek)

Hello

on a fresh install on a new Thinkpad e15 wifi is not working.
Ethernet works.

$ inxi --admin --verbosity=7 --filter --width

System:
  Kernel: 5.17.6-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.17-x86_64
    root=UUID=86fb53be-c8f5-4e7e-9dcd-1d24c1ea8dc5 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 21EES00100 v: ThinkPad E15 Gen 4
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 21EES00100 v: ThinkPad serial: <superuser required>
    UEFI: LENOVO v: R20ET26W (1.06 ) date: 02/18/2022
Battery:
  ID-1: BAT0 charge: 40.9 Wh (69.4%) condition: 58.9/57.0 Wh (103.3%)
    volts: 12.0 min: 11.5 model: SMP LNV-5B11C73244 type: Li-poly
    serial: <filter> status: discharging cycles: 1
Memory:
  RAM: total: 14.53 GiB used: 2.35 GiB (16.2%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: AMD Ryzen 7 5825U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1721 high: 1996 min/max: 400/4546 boost: enabled
    scaling: driver: amd-pstate governor: schedutil cores: 1: 1589 2: 1596
    3: 1776 4: 1597 5: 1595 6: 1595 7: 1899 8: 1773 9: 1995 10: 1755 11: 1596
    12: 1594 13: 1996 14: 1995 15: 1597 16: 1596 bogomips: 63919
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cppc cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists erms extapic
    extd_apicid f16c flushbyasid fma fpu fsgsbase fsrm fxsr fxsr_opt ht
    hw_pstate ibpb ibrs ibs invpcid irperf lahf_lm lbrv lm mba mca mce
    misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl npt
    nrip_save nx ospke osvw overflow_recov pae pat pausefilter pclmulqdq
    pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pku pni popcnt
    pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sha_ni
    skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor
    svm svm_lock syscall tce topoext tsc tsc_scale umip v_spec_ctrl
    v_vmsave_vmload vaes vgif vmcb_clean vme vmmcall vpclmulqdq wbnoinvd wdt
    xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Barcelo vendor: Lenovo driver: amdgpu v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: HDMI-A-1,eDP-1 empty: DP-1 bus-ID: 04:00.0 chip-ID: 1002:15e7
    class-ID: 0300
  Device-2: Acer Integrated RGB Camera type: USB driver: uvcvideo
    bus-ID: 1-3:2 chip-ID: 5986:2146 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x2520 s-dpi: 96 s-size: 677x666mm (26.65x26.22")
    s-diag: 950mm (37.39")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 pos: primary,top-left
    model: AOC Q3279WG5B serial: <filter> built: 2018 res: 2560x1440 hz: 60
    dpi: 90 gamma: 1.2 size: 725x428mm (28.54x16.85") diag: 842mm (33.1")
    ratio: 15:9 modes: max: 2560x1440 min: 720x400
  Monitor-2: eDP-1 mapped: eDP pos: primary,bottom-r
    model: ChiMei InnoLux 0x151e built: 2019 res: 1920x1080 hz: 60 dpi: 142
    gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5") ratio: 16:9
    modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD RENOIR (LLVM 13.0.1 DRM 3.44 5.17.6-1-MANJARO)
    v: 4.6 Mesa 22.0.3 direct render: Yes
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_sof_amd_renoir
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.6-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8168 v: 8.050.00-NAPI modules: r8169 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek vendor: Lenovo driver: N/A pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:b852 class-ID: 0280
  WAN IP: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 3-4:3 chip-ID: 0bda:4853 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 476.94 GiB used: 11.3 GiB (2.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Lenovo
    model: UMIS RPJTJ512MGE1QDQ size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 1.3Q0630 temp: 22.9 C scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%) used: 11.3 GiB (2.4%)
    fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
    uuid: 86fb53be-c8f5-4e7e-9dcd-1d24c1ea8dc5
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: NO_LABEL uuid: BF4B-0245
Swap:
  Alert: No swap data was found.
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: Acer Integrated RGB Camera type: Video
    driver: uvcvideo interfaces: 5 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 5986:2146 class-ID: fe01 serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-3:2 info: FPC Sensor Controller L:0001 FW:16.26.23.14
    type: <vendor specific> driver: N/A interfaces: 1 rev: 1.1 speed: 480 Mb/s
    power: 100mA chip-ID: 10a5:9800 class-ID: 0000
  Device-2: 3-4:3 info: Realtek Bluetooth Radio type: Bluetooth
    driver: btusb interfaces: 2 rev: 1.0 speed: 12 Mb/s power: 500mA
    chip-ID: 0bda:4853 class-ID: e001 serial: <filter>
  Hub-4: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 39.0 C mobo: N/A gpu: amdgpu temp: 38.0 C
  Fan Speeds (RPM): fan-1: 0
Info:
  Processes: 319 Uptime: 16m wakeups: 1 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1216 lib: 334
  flatpak: 0 Shell: Zsh v: 5.8.1 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.15

I was assuming below device-1 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet is also responsible for wireless.
But it might also be device-2 (or a different one?).

$ inxi -Nazy
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8168 v: 8.050.00-NAPI modules: r8169 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  Device-2: Realtek vendor: Lenovo driver: N/A pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:b852 class-ID: 0280

so far i tried, assuming device-1 needed a package, following this thread: Wifi is not working on fresh install

  • Kernel 5.15
  • trying Kernel 5.17
  • getting the respective headers each and get rtw89-dkms-git
  • use r8168 (also trying r8169)
  • blacklisting r8169

if related to device-2 chip-ID 10ec:b852, i was not able to find which package I would need.

How should I proceed?

Many thanks for your help in advance. Looking forward using Manjaro as daily driver.

Hi @oro, and welcome!

I might be wrong so someone is welcome to correct me if I am. Unfortunately, there doesn’t seem to be Linux drivers for that adapter yet. It might be that it’s simply to new. I don’t know.

  • Does it work in a Live environment?
  • Have you tried another distribution’s (Like Ubuntu) live ISO?

a search for vendor and product id of the wifi brings up:

attention: install the linux-headers and the base-devel packages as described first.

1 Like

And here I thought my Google-fu was good… shakes head

Welp, it’s in the AUR:

$ pamac search 8852
rtw89-dkms-git                                                                                                                                                                                                                        1:r148.4dc5371-3  AUR
Driver for Realtek 8852AE, an 802.11ax device

So can be installed using

pamac build rtw89-dkms-git

But make sure the headers for your kernel(s) are installed first:

pamac install $(pamac list --quiet --installed | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

This will install the kernel headers for all installed kernels.

Note:

I just remembered why I didn’t recommend it: it’s because it mentioned it was for the Realtek 8852AE, while yours is, in fact, the Realtek 8852BU from what I was able to see.

I also noticed you tried that already, so this will probably not work.

1 Like

I have the 8852AE realtek wifi & @oro’s one is different.
In any case, the rtw89 driver is already included since kernel 5.16, so there is no need to install it on 5.17.

Here is how 8852AE reports

Device-2: Realtek RTL8852AE 802.11ax PCIe Wireless Network Adapter
    vendor: Lenovo driver: rtw89_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 2000 bus-ID: 04:00.0 chip-ID: 10ec:8852 class-ID: 0280

The chip ID is the same except 1 digit: 10ec:b852 & I’m having trouble to locate that online.

Device-2: Realtek vendor: Lenovo driver: N/A pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:b852 class-ID: 0280

i would recommend to try @Mirdarthos tip first and installing the aur-package

…if my search is correct, there is no happy end yet.
Realtek Semiconductor Realtek Network controller for b852.

1 Like

Many thanks for the quick replies.

It did also not work in Manjaro’s Live environment and not in KDE Neon’s live ISO.
I might try an Ubuntu live ISO with newer kernel than Neon in the next days, but i assume that won’t make a difference.

I have installed the kernel headers and aur-package rtw89-dkms-git (in that order).

  • the Gui Systemsettings - Hardwareconfig show the device “network-r8168” with an unticked checkbox “installed”, not sure if that holds true. I see the package in pamac list --installed | grep rtw89.

So, I guess the temporary solution is: to wait.
I’m fine with Ethernet in 95 % of my use case.

  • How will I know when a fitting driver is published? Should I just check above hardware-probe’s status for the device regularly?
  • in this regard, should I stay on the newer Kernel 5.17 or move back to LTS?

thanks!

might you reply the output of the inxi --admin --verbosity=7 --filter --width with the drivers that are installed now ?

…yes, and keep both kernels, LTS and current. Good chances you can change your wifi-card to intel. In the gen3-model it’s changeable, but I don’t know from this very new model.

sure:

$ inxi --admin --verbosity=7 --filter --width                                                                               
System:
  Kernel: 5.17.6-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.17-x86_64
    root=UUID=86fb53be-c8f5-4e7e-9dcd-1d24c1ea8dc5 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 21EES00100 v: ThinkPad E15 Gen 4
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 21EES00100 v: ThinkPad serial: <superuser required>
    UEFI: LENOVO v: R20ET26W (1.06 ) date: 02/18/2022
Battery:
  ID-1: BAT0 charge: 28.4 Wh (48.4%) condition: 58.7/57.0 Wh (103.0%)
    volts: 11.4 min: 11.5 model: SMP LNV-5B11C73244 type: Li-poly
    serial: <filter> status: discharging cycles: 1
Memory:
  RAM: total: 14.53 GiB used: 1.74 GiB (12.0%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: AMD Ryzen 7 5825U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1758 high: 1995 min/max: 400/4546 boost: enabled
    scaling: driver: amd-pstate governor: schedutil cores: 1: 1630 2: 1595
    3: 1593 4: 1597 5: 1595 6: 1594 7: 1992 8: 1993 9: 1789 10: 1595 11: 1995
    12: 1994 13: 1595 14: 1597 15: 1993 16: 1995 bogomips: 63918
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cppc cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists erms extapic
    extd_apicid f16c flushbyasid fma fpu fsgsbase fsrm fxsr fxsr_opt ht
    hw_pstate ibpb ibrs ibs invpcid irperf lahf_lm lbrv lm mba mca mce
    misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl npt
    nrip_save nx ospke osvw overflow_recov pae pat pausefilter pclmulqdq
    pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pku pni popcnt
    pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sha_ni
    skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor
    svm svm_lock syscall tce topoext tsc tsc_scale umip v_spec_ctrl
    v_vmsave_vmload vaes vgif vmcb_clean vme vmmcall vpclmulqdq wbnoinvd wdt
    xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Barcelo vendor: Lenovo driver: amdgpu v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: HDMI-A-1,eDP-1 empty: DP-1 bus-ID: 04:00.0 chip-ID: 1002:15e7
    class-ID: 0300
  Device-2: Acer Integrated RGB Camera type: USB driver: uvcvideo
    bus-ID: 1-3:2 chip-ID: 5986:2146 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x2520 s-dpi: 96 s-size: 675x665mm (26.57x26.18")
    s-diag: 948mm (37.31")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 pos: primary,top-left
    model: AOC Q3279WG5B serial: <filter> built: 2018 res: 2560x1440 hz: 60
    dpi: 90 gamma: 1.2 size: 725x428mm (28.54x16.85") diag: 842mm (33.1")
    ratio: 15:9 modes: max: 2560x1440 min: 720x400
  Monitor-2: eDP-1 mapped: eDP pos: primary,bottom-r
    model: ChiMei InnoLux 0x151e built: 2019 res: 1920x1080 hz: 60 dpi: 142
    gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5") ratio: 16:9
    modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD RENOIR (LLVM 13.0.1 DRM 3.44 5.17.6-1-MANJARO)
    v: 4.6 Mesa 22.0.3 direct render: Yes
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_sof_amd_renoir
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.6-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8168 v: 8.050.00-NAPI modules: r8169 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek vendor: Lenovo driver: N/A pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:b852 class-ID: 0280
  WAN IP: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 3-4:3 chip-ID: 0bda:4853 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 476.94 GiB used: 11.72 GiB (2.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Lenovo
    model: UMIS RPJTJ512MGE1QDQ size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 1.3Q0630 temp: 15.8 C scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%)
    used: 11.72 GiB (2.5%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: 86fb53be-c8f5-4e7e-9dcd-1d24c1ea8dc5
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: NO_LABEL uuid: BF4B-0245
Swap:
  Alert: No swap data was found.
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: Acer Integrated RGB Camera type: Video
    driver: uvcvideo interfaces: 5 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 5986:2146 class-ID: fe01 serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-3:2 info: FPC Sensor Controller L:0001 FW:16.26.23.14
    type: <vendor specific> driver: N/A interfaces: 1 rev: 1.1 speed: 480 Mb/s
    power: 100mA chip-ID: 10a5:9800 class-ID: 0000
  Device-2: 3-4:3 info: Realtek Bluetooth Radio type: Bluetooth
    driver: btusb interfaces: 2 rev: 1.0 speed: 12 Mb/s power: 500mA
    chip-ID: 0bda:4853 class-ID: e001 serial: <filter>
  Hub-4: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 30.0 C mobo: N/A gpu: amdgpu temp: 29.0 C
  Fan Speeds (RPM): fan-1: 0
Info:
  Processes: 323 Uptime: 3m wakeups: 1 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1216 lib: 334
  flatpak: 0 Shell: Zsh v: 5.8.1 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.15

not much of a change compared to above, as I installed them before the post.

One other thing: from trial and error i kept AUR (en) - r8168-dkms on my machine. Should I remove it?

Keeping the 8168 is fine. In fact, I’d say it’s preferable. See:

https://askubuntu.com/questions/1279644/r8168-r8169-which-one-should-i-use

thanks! insightful resource. I should improve my google-foo too :slight_smile: