Think or Swim - No App launch Icon & could not start

I have successfully installed Think or Swim in Manjaro - Gnome and it started without any issue. But it does not have a App launch Icon and once I close the application. There is no way for me to start the application back.

Steps taken to resolve the Issue:

  1. Tried to identify the bin file, so that I could create the “Alacarte menu item” (Desktop launch icon)

Through CLI

     $ PS x | grep think or swim 
     $ file /proc/<pid>/exe
Note: I could not find the bin file for thinkorswim 
  1. Re-installed the application multiple times but no success ( even though I have check marked desktop icon, the application icon does not appear).

These approaches did not really help. Can you please suggest how I could fix this issue ?

Software version:
Manjaro - Sikaris 22.0.04
Gnome - 43.3
Think or Swim - latest one download from main website


But it does have one -
maybe the helpful and feature rich Gnome desktop does not show it to you?
I don’t know because I don’t use Gnome.
It is in the folder “Desktop” and called: thinkorswim.desktop
Read through it.

One can install the program
“only for the current user or for all users of this machine”

If you did the former then you’ll find the program in folder called thinkorswim in your $HOME directory:

This location is not in your standard $PATH - so you have to give the full PATH each time you want to start it.

Or you have it install to ~/.local/bin - then it is in your $PATH

Check your $PATH with:

echo $PATH

1 Like

Hi Nachlese,
You are right! Gnome is not showing the icon that is on the desktop. But I could find the launch icon thinkorswim.desktop in the “Desktop” folder.

I have moved the ThinkOrSwim.desktop to /usr/share/applications and it worked.

Thanks for you help !

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.