There is no default keyboard layout on the FCITX configuration screen

After installing the latest version of Manjaro-gnome.I tried to install the Chinese input method,but the FCITXconfiguration screen displayed blank without the default system keyboard layout.

I get the following error when I run fcitx from the command line interface.

块引用

** (process:2657): WARNING **: 11:00:13.450: Error loading plugin: libhspell.so.0: 无法打开共享对象文件: 没有那个文件或目录
** (process:2657): WARNING **: 11:00:13.450: Error loading plugin: libvoikko.so.1: 无法打开共享对象文件: 没有那个文件或目录
** (process:2657): WARNING **: 11:00:13.450: Error loading plugin: libnuspell.so.5: 无法打开共享对象文件: 没有那个文件或目录
** (process:2657): WARNING **: 11:00:13.450: Error loading plugin: libhunspell-1.7.so.0: 无法打开共享对象文件: 没有那个文件或目录
** (process:2657): WARNING **: 11:00:13.450: Error loading plugin: libaspell.so.15: 无法打开共享对象文件: 没有那个文件或目录
~  (ERROR-2657 ime.c:432) fcitx-keyboard-tr-otk already exists  :heavy_check_mark:
(ERROR-2657 xim.c:239) XIM启动错误。是否有另一个名为ibus的XIM守护程序正在运行?
(ERROR-2657 instance.c:443) Exiting.

Howcan Isolve this problem?Please Help me!Thank you very much!

1 Like

@Firestar @SamLukeYes Can you help with this? (I know you’re both :cn: so you might know a bit more about this than anyone else…)

:crossed_fingers:

2 Likes

命令行界面输出语言为英语

~/.bashrc 的最后添加一行:

export LANG=en_US.UTF-8

如果使用 zsh,则去掉 ~/.zshrc 中这一行的注释即可

你的keyboard layout不是安装的时候就选好了吗?应该是Chinese default

我用KDE,所以不太熟悉GNOME的错,你检查一下是不是少装了什么?

yay -S fcitx5 fcitx5-chinese-addons manjaro-asian-input-support-fcitx5 fcitx5-gtk fcitx5-qt fcitx5-configtool

yay -S fcitx-im fcitx-configtool fcitx-cloudpinyin manjaro-asian-input-support-fcitx

yay -S aspell hspell libvoikko
2 Likes

理論上裝了 manjaro-asian-input-support-fcitx5 後就會自動加上該有的環境變數,重登入後就應該能正常啟動了。

1 Like

please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

2 Likes

Hi im Chinese but I suck at it, 我会一点华文,我认为你不应该不要用 fcitxfcitx5Gnome DE. Gnome DE 已经有 IBUS IME. 如果你使用 KDEfcitxfcitx5, 如果你用 Gnome DEIBUS IME. IBUS IMEGnome DE 比较完整。

你可以看看下面这个网页=
https://wiki.archlinux.org/title/IBus

2 Likes

Want me to move it back into the :uk: section? (Sorry for assuming your :cn: was good but I moved it here because that’s where most of the :cn: experts live. :grin: )

:question:

1 Like

Im more fluent in English than in Chinese, I rarely speak Chinese because all my friends don’t speak Chinese.

1 Like

Translating what I said to English:
I think u should not use Fcitx or Fcitx5 on gnome because the integration of IBUS on gnome is very tight. If you use Fcitx or Fcitx5 on Gnome, it will look bad and might not function as well.

It is also very easy to set up IBUS on Gnome, no need to edit anything, it’s already set up. Just go to Settings → Region and Language → Input Sources (add anything you need, like the picture below)

If you can’t find Ibus intelligent pinyin you can install it with sudo pacman -S ibus-pinyin
You can refer to the table from Arch Wiki below:


I hope this solves the problem. :crossed_fingers:

1 Like

So is your problem solved? If yes, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

If no, please let us know.

Lmao, OP haven’t replied once :rofl:

1 Like