There is audio detected but no output is reaching my headphones

Today I was using my computer and playing a game when all of a sudden, the audio cut out and I couldn’t hear anything. I decided to restart my computer to see if it would help and it did for a few hours before cutting out again.

When I looked at pulsecontrol, it detects my headphones and sees applications giving audio output.

Welcome to Manjaro

Please post system information:

ìnxi -Faz

and ALSA information

sudo --upload

Use 3 backticks on terminal responses to format the text
(and to avoid problems with the forum anti-spam policy of blocking hyperlinks)

I suggest that when audio does cut out you try restarting PulseAudio
systemctl --user restart pulseaudio

and if audio is still not working, check PulseAudio service for error messages

systemctl --user -l --no-pager status pulseaudio*

Alright I ran the ALSA info command and here is the link

I ran systemctl --user restart pulseaudio and unfortunately it didn’t work. I then ran systemctl --user -l --no-pager status pulseaudio* and I encountered no errors in the log.

Though from further testing I found that the audio stops when I play a game and it seems that I can hear a brief sort of static that lasts for less than a second.

ALSA all appears to be OK

(you might want to consider updating firmware - ASRock > B550M Pro4 - BIOS
but I would not expect that to make a difference for audio)

I suggest you check the audio settings for the game and audio settings for WINE or Steam etc
If audio for the game is set to use only ALSA for playback to a specific device it may be taking exclusive control of that device and blocking audio streams from PulseAudio

The brief noise might be PulseAudio being suspended or muted

I suggest you use this command to check audio streams in PulseAudio

pacmd list-sink-inputs

If the game audio absent, audio is bypassing PulseAudio
but data will show what is happening to other audio streams