There is a problem connecting to a Uplay Services

hello everybody

i have a issue with steam or ubisoft. so i tried running assassin’s blackflag.
it ran without a problem. Then i tried ac unity and i can’t run via uplay i don’t know why it says “there is a problem connecting to a Uplay Service.” and i tried somethings like using a vpn (did with USA and Japan) but it didn’t worked. So my question is how do I make it work?
i downloaded steam via the Terminal code: flatpak install com.valvesoftware.Steam`

my kernel version is 6.1.31-2-MANJARO (64-bit) and i run manjaro linux KDE Plasma version 5.27.55

i enabled steam Play for all other titles and run them with proton experimental. There is also a guy that said disable steam client beta, but i can’t seem to find out.

specs (desktop):
cpu ==> amd ryzen 5 1600AF
gpu ==> nvidia rtx 3060 12gb from Gigabyte
ram ==> 24gb

PS: Also keep in mind I am kinda new to linux (wanted to switch it up a bit) so if you can explain in detail i will greetly appreciate it, thanks

See this comment on ProtonDB:

EDIT: Corrected link, but page still doesn’t jump to the right comment by Slyfighter.

hey thanks for helping me

i am confused what does he mean by network name? my ip adress my ssid? is it the same name as the name that i see when using wifi? i dont understand

For some reason that link isn’t loading the right comment. It’s the one by Slyfighter.

i suppose if i already tried several times to launch the game i should uninstall it and redownload it ?

edit by redownload i mean ac unity and ubisoft then

No, just follow the instructions and remove the existing folder it specifies.

1 Like

thank you it works!!!

i have another question do you know why it always reuse uplay when i restart the game? when i check the folder (gamelauncher) i still see ubisoftconnectinstaller.exe even the vdf file has the line correct (“process 1” “%INSTALLDIR%\Support\Software\GameLauncher\UbisoftConnectInstaller.exe”)

EDIT: i got it i just have to start ubisoft first then launch the game

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.