Themes with round corner windows have little "triangles"

Hi, I hope you understood the title (I didn’t know how to write it :sweat_smile:, and I don’t speak natively English). When I use KDE Plasma 5.20.4, with the look-and-feel Orchis-dark, the corners have a little triangle around them
image . I found that by selecting the compositor to XRender it fixes this, but the trasparency is annoying.

(OpenGL 3.1) (XRender)

How do I fix this?

P.S: I’m currently using Layan as look-and-feel.

EDIT: If you need the computer’s specs:
CPU: Intel i3-4005U @ 1.7GHz
HDD: 500GB with Windows 10 (20H2) and Manjaro Niba 20.2 KDE Plasma 5.20.4 KDE Framework 5.76.0 Qt Version 5.15.2 Kernel 5.8.18-1-MANJARO 64bit

Off-topic question: Is there an exention or app that simulates Windows 10 windows snap?

Well, you’ve found the thus far only known solution to the problem, which is to switch the compositor to XRender, indeed. And that does indeed preclude the use of the blur effect. It’s annoying, but it’s the only way to stop it from happening, unless you were to pick a different window decoration without the rounded corners.

I believe that the problem is known to the KDE developers, but so far I haven’t seen any fixes for it being reported in the changelogs. :man_shrugging:

I’m afraid I don’t know what you mean ─ I don’t use Microsoft Windows. But window placement and behavior can be tuned via… :arrow_down:

System Settings → Workspace → Window Management → Window Behavior → Movement

1 Like

Thank you. Maybe I’ll stick to OpenGL 3.1 and deal with it. Also, no problem for

1 Like

Plenty of info about this with a simple DDG/Google search.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.