The touchpad tap-to-click doesnt work on Wayland

Hi there,

I am using Wayland and the tap to click doesn’t work. Is there a way to make it work on Wayland? (in settings the tap to click is enabled.) It works when I log in with X11.

Here is info:

  Kernel: 6.5.13-7-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    Desktop: KDE Plasma v: 5.27.10 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82UX v: Lenovo Slim 7 16ARH7
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76530 WIN
    serial: <superuser required> UEFI: LENOVO v: KLCN19WW date: 06/08/2023
  ID-1: BAT0 charge: 52.8 Wh (80.1%) condition: 65.9/75.0 Wh (87.9%)
    volts: 16.6 min: 15.4 model: LENOVO AP16L5J status: not charging
  Info: 8-core model: AMD Ryzen 7 6800HS Creator Edition bits: 64 type: MT MCP
    arch: Zen 3+ rev: 1 cache: L1: 512 KiB L2: 4 MiB L3: 16 MiB
  Speed (MHz): avg: 1428 high: 4378 min/max: 400/4785 cores: 1: 1928 2: 400
    3: 400 4: 1928 5: 1929 6: 400 7: 1945 8: 1951 9: 400 10: 1930 11: 2130
    12: 400 13: 4378 14: 400 15: 1929 16: 400 bogomips: 102247
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA GA107BM [GeForce RTX 3050 Mobile] vendor: Lenovo
    driver: nvidia v: 545.29.06 arch: Ampere bus-ID: 01:00.0
  Device-2: AMD Rembrandt [Radeon 680M] vendor: Lenovo driver: amdgpu
    v: kernel arch: RDNA-2 bus-ID: 05:00.0 temp: 62.0 C
  Device-3: IMC Networks Integrated RGB Camera driver: uvcvideo type: USB
    bus-ID: 5-1:2
  Display: wayland server: v: with: Xwayland v: 23.2.3
    compositor: kwin_wayland driver: X: loaded: amdgpu,nvidia
    unloaded: modesetting,nouveau dri: radeonsi gpu: nvidia,amdgpu
    resolution: 2048x1280
  API: EGL v: 1.5 drivers: nvidia,radeonsi,swrast platforms:
    active: wayland,x11,surfaceless,device inactive: gbm,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (rembrandt LLVM
    16.0.6 DRM 3.54 6.5.13-7-MANJARO)
  API: Vulkan v: 1.3.274 drivers: nvidia,radv surfaces: xcb,xlib,wayland
    devices: 2
  Device-1: AMD Rembrandt Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 05:00.1
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
    driver: snd_pci_acp6x v: kernel bus-ID: 05:00.5
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 05:00.6
  API: ALSA v: k6.5.13-7-MANJARO status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 1.0.0 status: off
  Server-3: PulseAudio v: 16.1 status: active
  Device-1: Realtek RTL8852BE PCIe 802.11ax Wireless Network vendor: Lenovo
    driver: rtw89_8852be v: kernel port: 2000 bus-ID: 02:00.0
  IF: wlp2s0 state: up mac: <filter>
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB
    bus-ID: 3-3:3
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 931.51 GiB used: 205.07 GiB (22.0%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WD BLACK SN850X 1000GB
    size: 931.51 GiB temp: 61.9 C
  ID-1: / size: 577.2 GiB used: 205.01 GiB (35.5%) fs: ext4
    dev: /dev/nvme0n1p5
  ID-2: /boot/efi size: 256 MiB used: 67.5 MiB (26.4%) fs: vfat
    dev: /dev/nvme0n1p1
  Alert: No swap data was found.
  System Temperatures: cpu: 90.4 C mobo: N/A gpu: amdgpu temp: 61.0 C
  Fan Speeds (rpm): N/A
  Processes: 382 Uptime: 4m Memory: total: 16 GiB note: est.
  available: 13.34 GiB used: 3.83 GiB (28.7%) Init: systemd Compilers:
  gcc: 13.2.1 clang: 16.0.6 Packages: 1460 Shell: Zsh v: 5.9 inxi: 3.3.31

Is the system fully updated? Kernel 6.5 is EOL (End of Life) and 6.5.13 is current… Have you tried with LTS kernels, either 6.1 or 6.6?


Alert: No swap data was found.

It might be wise to create a swap file or swap partition.

Thanks for the suggestions, unfortunately it doesnt work with Kernel 6.1 too:( Also thanks for pointing out about swap

I have an (older) Lenovo Thinkpad, and the touchpad tap is fine in Wayland. But it’s Gnome.

I even fired it up, and updated and it’s still fine. When I was poking around with older commands for libinput you use with X11, seemed like the Tap-to-click property was disabled on mine. But from: libinput - ArchWiki

For Wayland, there is no libinput configuration file. The configurable options depend on the progress of your desktop environment’s support for them

I know this doesn’t solve your problem, but I have a feeling that Wayland is working as expected, and KDE is not? (I haven’t run that DE in years.)

I tried logging in with Gnome(Wayland) and the problem is still persisting.

Then I changed back to plasma wayland

i did

libinput list-devices

which gave the output

Device:           06CB0001:00 06CB:CE44 Touchpad
Kernel:           /dev/input/event7
Group:            6
Seat:             seat0, default
Size:             117x72mm
Capabilities:     pointer gesture
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    *button-areas clickfinger 
Disable-w-typing: enabled
Disable-w-trackpointing: enabled
Accel profiles:   flat *adaptive custom
Rotation:         n/a

so the tap-to-click is disabled. But I am not able to identify the touchpad interface to change the tap to click to true.

Hi, as I mentioned in my first message, the tap-to-click option is enabled from the settings, but it shows disabled in libinput list-devices

Touchpad on Wayland is completely controlled via libinput, if it doesn’t work neither on KDE nor on GNOME then file a bug on their tracker Issues · libinput / libinput · GitLab

1 Like

I played around with qdbus and libinput and it seems to be working now!! I don’t know what really happened but it solved the problem:) thank you all for replies

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.