The tones are missing in the Greek characters

After more than a month with the latest “live DVD - KDE” (6.0.1 I think) yesterday I decided to install it to my machine. As I am Greek and live in Greece the installation followed the “time zone and locality” I had choose during the first set-up of the “live media” before the installation.
At the beginning the language was “English US” and I added “GREEK” and toggle between layouts by “Alt + Shift” (left Shift) and everything was nice. The Greek letters had tones ( ; then α, ε, η, ι, ο, ω) but now with the system installed to my sda NO TONES & no “short-cut” to toggle between layouts (just a “us” or “gr” at the down-right corner). I made same seeking but I didn’t found anything useful , so if someone can help , please do it.
By the way during the last month I was receiving regularly "updates’ and when the system asks for “restart” I was killing the X-server (Ctrl+Alt+Backspace) and the system restarted with longing “manjaro”

to make it more clear:
λε;ιπουν οι τ;ονοι απ;ο τους Ελληνικο;υς χαρακτ;ηρες
instead of :
λείπουν οι τόνοι από τους Ελληνικούς χαρακτήρες

Could you please clarify:

Are you seeing this in certain applications, the terminal, or KDE in general?

Perhaps choosing a different font might improve your experience. The Noto Sans/Serif fonts supposedly support all languages compatible with Unicode. Try setting one of that font family as the default in KDE.

I also found this list of polytonic fonts online, in case they may be useful:


You might also check that your locale settings use el_GR.UTF-8 (for Unicode) and not simply el_GR.


I found Fonts in GTK application in KDE Plasma 6.0.3 just look bad on KDE Discuss, but it doesn’t seem to fit what you describe.


Otherwise, I have nothing else to suggest. :man_shrugging:

Cheers.

1 Like

Thanks.
I’m already in the first link
Elias

Are we to presume your issue is now solved?

If so, what was it that actually solved it; a change in font?

1 Like