The system stopped offering the confirmation screen before Sleep

When I click Restart in the Application Launcher, I get a confirmation screen with a 30 second countdown. I like that, because I sometimes misclick.

This used to happen upon clicking Sleep as well, until a while ago. Now the system goes straight to sleep, and there is no confirmation screen. Is there a way to get the confirmation screen to appear before Sleep again?

Probably unrelated: I made a custom Sleep keyboard shortcut (with systemctl suspend as the Action). Or is it related?

  Kernel: 5.10.79-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
  root=UUID=923b8563-bb29-43fd-b6f6-6aadb2dc852c rw quiet
  resume=UUID=3814db10-9163-49e3-a901-30923f533614 udev.log_priority=3
  Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
  Distro: Manjaro Linux base: Arch Linux

Did you do that yourself? I dont think I have ever seen such a thing on plasma.

I’m pretty sure it was there this summer, when I first installed Manjaro. It was the default, and I got used to it.

Perhaps this is a deliberate design change of KDE Plasma which happened in the meantime?

Here’s what the countdown looks like:


Ah I see now.
If you have setting ‘show shutdown menu when power button is pressed’ enabled, then if you press the power button the first selected item (shutdown) will have that countdown.
Similarly, using the actions from the kicker menu do the same … but you are correct - it does not for ‘sleep’.
I guess I just never noticed?
Anyways your description is correct. :woman_shrugging:

1 Like

In systemsetting → start and shutdown-> session, look for something like “ask shutdown” or “confirm shutdow”. It should be first checkbox.

The box is ticked, if you mean this one:


I tried ticking both of them off and then on (with saving), but it didn’t change anything.

Try removing ~/.config/ksmserverrc file and re-setting “confirm logon” in “start and shutdown”