The system doesn't seem to recognize my Plantronics Blackwire C320-M USB headset

The system doesn’t seem to recognize my Plantronics Blackwire C320-M USB headset.

I’m pretty new to all the Linux so I was definitely having the same problem when I was using Mint. I’m not sure I ever got these headphones working successfully on Linux. I did notice other people had been lucky because they had other issues which were corrected, which I figure I might run into but, I don’t really care if the volume buttons work or whatnot, I would just like sound. Thank you.

I tried using the mhwd -lh to locate devices connected to the machine. I tried it once with the device plugged in and a tried the command again without the device plugged in. I noticed a change in the results:

Multimedia controller 1-1.1:1.0 0401 047f c025 0

I tried doing an lsusb I get:

Bus 001 Device 010: ID 047f:c025 Plantronics, Inc.

I tried doing a mhwd -la --usb I get:

Warning: No USB configs found!

I’m really just sort of lost.

I have the same issue man. Before it worked well, it just suddenly cant use and dont know why.