The solution of AX210 wifi down after awake from suspend

after ton of research in the internet , there is no correct way to let the wifi work again , so I want othe share my solution to the community .

System info

➜  ~ inxi -N
  Device-1: Intel Raptor Lake-S PCH CNVi WiFi driver: iwlwifi
  Device-2: Intel Ethernet I225-V driver: igc

How to fix

sudo systemctl stop NetworkManager
sudo modprobe -rv iwlmvm
sudo modprobe iwlmvm
sudo systemctl start NetworkManager

if you share wifi network to the lan

this might crash the lan share network. which cause the loop error, which underhood using dnsmasq to serve the dhcp and dns service.


How to fix

sudo lsof -i :53
sudo kill <the pid running in 53 port>

If this solve your problem please leave comment ~ Thanks

Please see

Thanks for your answer. :smiling_face:

After I tried out your answer , but sadly that’s not work for me . my wifi connection still get stuck after awake from suspend…

Another option is to try:

echo "options iwlwifi 11n_disable=8 power_save=0" | sudo tee /etc/modprobe.d/iwlwifi.conf

This also disables power management for the adapter,

Based on: