The 'Search' function in my application launcher returns only blankness

This had been working fine until I booted my machine this morning. The rest of the application menu seems to work fine. I have searched but couldn’t find anything similar on google or in the forum.

Is there a service or something that populates the search for applications?

I went into Settings and examined the Search settings. Indexing is disabled (I disabled it ages ago because I don’t like it). There’s no other options related like cleaning a cache or anything.

I’ve tried to attach a screenshot but the forum won’t let me paste it.

Have you tried add a new menu to the panel, or a new panel, to check if it works? You can also try krunner (usually ALT+F11) and see if it works.

if your search doesn’t work, please go to a terminal (I hope you have a keyboard shortcut or favourite for that. F12 should open one unless you disabled it.)

1 Like


I have the same issue on a fresh install of 20.1 on a laptop.
krunner show app searched but not in the KDE menu!
I try the new panel, same result: nothing.

I don’t have the issue on my main desktop system.
Any idea ?


What do you mean by that exactly?

Does this also happen when you create a new user (E.G. Polymere2 and log in there?


P.S. We never got any feed-back from the OP whether any of the above worked, so we might as well have a look into your case. In the future, it’s better to open a new topic, because now only 3 people are reading this: you, mbb and me, whereas a new topic all users will read. :wink:
P.P.S. You’re lucky this time because we’re good! :grin:

Hi Fabby,

I test the idea of mbb for add an other panel.
But your idea of creating a new user work very well. It solve my issue.
Don’t understand why this fresh install failed on that :thinking:

I will continue to follow this forum for more solution.

Have a nice day.
Fred from France

1 Like

Creating a new user is just part of the solution. Please also

  • Verify that the new user has access to the same groups as your old one by executing groups and comparing the output of both users.

    groups Polymere
    groups Polymere2

    (Where obviously, Polymere is your old user and Polymere2 is your new one.)
    E.G. if Polymere is a member of Polymere and Polymere2 isn’t, execute:

    usermod --append --groups operator Polymere2
  • Copy all data files from your old profile into your new one

    cp --verbose --recursive --preserve=time-stamps /home/Polymere/Documents/* /home/Polymere2/Documents/

    If that worked and you had no errors, remove the documents from your old user:

    rm --recursive /home/Polymere/Documents/*

    repeat for:

    • Pictures
    • Videos
    • Music
    • .thunderbird
    • .mozilla/firefox/
    • Templates, and everything else that is important to you.
    • Linux games like Battle of Wesnoth have their game data stored under ~/.local/share/ E.G. ~/.local/share/wesnoth/

    After everything has been copied over, disable the old user so you cannot accidentally log on:

    usermod --lock Polymere

    If you would have theming going on, don’t do everything in one day but do this at the rate of 1 application / theme / whatever per day and if the problem crops up again, roll back your last change

  • in 1 month delete the entire home directory of your old user, but don’t delete the user itself so that in 6 months time files still owned by that user will still show up under its username.

  • If you ever migrate to a new machine, just don’t migrate the old user: only the new one.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.