The latest Kernel 6.6.6-2 Linux 66

When the above latest update became available, I tried to set up XFCE manually with EFI & sometimes it boots up and other times it just hangs. Perhaps my partition config is wrong for running boot/efi? Please see the following configuration and put me on the right road. thanks

The disadvantage of removing proprietary firmware from the kernel is that it could lead to the loss of function of certain hardware, if there is no free firmware available to replace it. This could affect sound, graphics and network cards (especially WIFI cards).

Install a Manjaro kernel. And if a re-install is not too much trouble I’d also start gparted from the live usb and delete the weird sda2 partition. You can leave the ‘unallocated space’ after deletion.

1 Like

What if I boot the live USB and go into the manual set up and delete the weird sda2 partition and and then add the free space to the formatted boot/efi partition by deleting it and reassigning it as 512 mb as it was before with no problems using earlier Kernels. Do you think this will work?(Note: I understand that it is also advisable to have a few meg at the beginning and end which would mean backing up everything in my /home directory and loosing priceless settings? Not necessary of course?) You mentioned doing this with Gparted as above and it certainly sounds simple!! will I have to reinstall Manjaro 23 or can I just get away with the sda2 edit?

By the way this worked using Gparted

That’s perfectly fine but resizing/touching the efi partition might mean reinstalling the bootloader GRUB/Restore the GRUB Bootloader - Manjaro . If you just delete sda2 you’ll just have ‘a few meg at the beginning’ which is fine.

You won’t need to reinstall but if it was me I’d:

  • have a backup anyway
  • make sure I know how to reinstall the bootloader or have a second device to follow the above tutorial
  • change to a regular manjaro kernel before I start

Using the newer Kernels Grub is no longer necessary?? Does that also mean a SWAP directory is unused? I’m still confused about the difference between Efi and Grub or do they work together?

Install a Manjaro kernel in a 6x12 timeframe. If possible, consider reinstalling and use gparted from the live USB to delete the unusual sda2 partition. The ‘unallocated space’ can be left after the deletion.

I am not using GRUB bootloader only boot/efi. This is where there is a little confusion as GRUB was used in the past until mad Bill invented or whoever did invent it boot/efi?

It is not clear from the post what kernel you have. If it is from aur than that is unsupported and may or may not work or break.

Install a normal, manjaro LTS kernel like 6.1 or 6.6

I will do as you suggested and hopefully save some time and effort Thanks! I do appreciate your help!

6.6 is what I am using and it is a Manjaro LTS Kernel, but if you look under the Kernel config it actually states 6.6.6-2

I only use LTS as it is the only stable Kernel

The efi partion is where grub ‘lives’. Grub is the bootloader, acts like a doorman. You boot, grub pops up, tells you which operating systems are installed (in your case only manjaro) and either allows you to pick the operating system of your choice or just boots the default one.

It is.

The swap partition (not directory) is used as an overflow in case you’re running out of ram. If you delete this partition and you run out of ram your machine will crash.

You better read up on these things… search ‘linux grub’ ‘linux swap’ etc and learn a little or you won’t have much fun with your manjaro. It’s worth it.

And please do back up your data first…

Thanks, so that means the boot/efi has to be flagged as a Grub bootloader?

I do understand that the Swap has to be the size of your ram and that’s how I set it up. I think the confusion is with efi as I used to use only GRUB before Billy Goats came out with efi.

Okay, Thank you all clarification is appreciated!!

If you are on a manjaro kernel maybe you should not have posted a link that is for a nonmanjaro kernel in the first post. The Gparted picture is also half informative. That weird partition may be remnants of windows, or may be simulation of MBR if your uefi is in CSM mode…or something else. I would not delete it before knowing what it is and how it got there. You lack some basic knowledge and understanding what is what, so you cannot really formulate a specific question and provide info.
You can start with trying to explain what is not working (1 Problem), like “my system does not boot” and then reading the tutorial section of the forum, esp. how to ask and how to provide system info topics.


No. The efi partition is already flagged ‘boot’, no need to change anything. Grub is a software, an ‘app’ if you want, that is already installed.
As @Teo says ‘You lack some basic knowledge’, brush up on this first before you do anything and lose your data. Sorry, but I don’t think I can help you any further for now.

Thanks!! Merry Christmas! I don’t lack basic knowledge and if you talk to people in this manner then you won’t find too many people using Linux or interested in learning about it!! I am older than most of you and have taught myself how…to use Manjaro, which is a great desktop and I simply followed the advice of 6x12 and solved the problem in 3 mins, Sincere thanks to 6x12 You guys are sometimes too nerdy to explain a few basics Teo came across in a very arrogant manner and it wasn’t called for. Hence my comment. So ban me if you like!!

1 Like

Happy Hanukka!

  • Don’t mess manually unless you know what you are doing or at least can describe what you did.
  • Don’t insult other users just because they don’t understand you.
  • Back up your data and reinstall the system. It seems too complex to describe what happened to it.
1 Like