The language client requires VS Code version ^1.51.0 but received version 1.50.1

Hello, I had issue with VS Code IntelliSense not cooperating. It says that language client requires version way ahead of the current installed vs code version from pacman (community) server. How to deal with this thing?

Is there a way to just install a language client for vs code that’s appropriate on my current version of vs code or shall I wait for new release update of vs code? Thanks!

I have built and pushed the latest code package to the unstable branch when the mirrors sync. See if it solves your issue.

I maintain it but I do not use it so I rarely think about. I need some nudging every once in a while. :slightly_frowning_face:

code 1.52.1-1


Challenge accepted :wink:

Everything working fine, but every time I open code I’ll need to sign in to GitHub for settings sync extension and it always prompts me this, though it let me signed in anyway.

Writing login information to the keychain failed with error ‘/opt/visual-studio-code/resources/app/node_modules.asar.unpacked/keytar/build/Release/keytar.node: wrong ELF class: ELFCLASS32’.

I already installed gnome-keyring as posted here.

I bet it has something to do with the file in code. I use an ubuntu aarch64 .deb which is self contained and re-package it with makepkg. When the package was building there was a warning with /resources/app/node_modules.asar.unpacked/keytar/build/Release/keytar.node. Maybe ubuntu will get it straightened out the next time around.

There is a bug report on GitHub for that… ARM64 .deb package code_1.52.0-1607640253_arm64 onwards contains 32-bit Intel 80386 keytar.node · Issue #113467 · microsoft/vscode · GitHub

According to the comments it will be solved with the current iteration to be released beginning of February.


I am keeping score :shushing_face:

Me: 1 You: 0

The latest code package has been pushed to the unstable branch when the mirrors sync.

code 1.53.0-1

1 Like

As a developer for VSCode extensions, this is good to know. I usually update the required VSCode with every version of my extension, but I didn’t realize it could break some things.

I managed to solve this by replacing the keytar.node which is 32 bit version to 64 bit.

Is it a solution to this or just dumb decision that concluded it as one?

Does the latest version I pushed a few days ago fix this.

I’m using code 1.52.1-1, though I have not tested it on v1.53.0-1.

There are some new point releases fixing bugs in the original 1.53.0 version (maybe its wise to wait for some days to see if they found some bugs early)