The language client requires VS Code version ^1.51.0 but received version 1.50.1

Hello, I had issue with VS Code IntelliSense not cooperating. It says that language client requires version way ahead of the current installed vs code version from pacman (community) server. How to deal with this thing?

Is there a way to just install a language client for vs code that’s appropriate on my current version of vs code or shall I wait for new release update of vs code? Thanks!

I have built and pushed the latest code package to the unstable branch when the mirrors sync. See if it solves your issue.

I maintain it but I do not use it so I rarely think about. I need some nudging every once in a while. :slightly_frowning_face:

code 1.52.1-1

3 Likes

Challenge accepted :wink:

Everything working fine, but every time I open code I’ll need to sign in to GitHub for settings sync extension and it always prompts me this, though it let me signed in anyway.

Writing login information to the keychain failed with error ‘/opt/visual-studio-code/resources/app/node_modules.asar.unpacked/keytar/build/Release/keytar.node: wrong ELF class: ELFCLASS32’.

I already installed gnome-keyring as posted here.

I bet it has something to do with the file in code. I use an ubuntu aarch64 .deb which is self contained and re-package it with makepkg. When the package was building there was a warning with /resources/app/node_modules.asar.unpacked/keytar/build/Release/keytar.node. Maybe ubuntu will get it straightened out the next time around.

There is a bug report on GitHub for that… ARM64 .deb package code_1.52.0-1607640253_arm64 onwards contains 32-bit Intel 80386 keytar.node · Issue #113467 · microsoft/vscode · GitHub

According to the comments it will be solved with the current iteration to be released beginning of February.

1 Like