The key sequence is ambiguous


I’m new in KDE, been using GTK DEs for decades. I got this error:

I was running yuzu (nintendo switch emulator) installed as flatpak, which uses F11 to toggle full screen. After I press “Accept”, if I press F11 again it will go to full screen or vice versa

I’ve been searching where all the key are defined in KDE but nothing. There’s nothing set up for F11 searching using the settings (gui). Also nothing in .kde4/share/config/kdeglobals

I really don’t know what logs should I put here nor where else to find

Thanks in advance

plasmashell --version

plasmashell 5.22.5

kf5-config --version

Qt: 5.15.2
KDE Frameworks: 5.87.0
kf5-config: 1.0

inxi -zSb

System:    Kernel: 5.14.10-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.22.5 Distro: Manjaro Linux
Machine:   Type: Laptop System: LENOVO product: 82B1 v: Lenovo Legion 5 15ARH05H serial: <filter>
           Mobo: LENOVO model: LNVNB161216 v: SDK0R33126 WIN serial: <filter> UEFI: LENOVO v: FSCN14WW date: 08/26/2020
Battery:   ID-1: BAT0 charge: 48.3 Wh (59.0%) condition: 81.8/80.0 Wh (102.2%) volts: 15.3 min: 15.4
CPU:       Info: 8-Core AMD Ryzen 7 4800H with Radeon Graphics [MT MCP] speed: 1397 MHz min/max: 1400/2900 MHz
Graphics:  Device-1: NVIDIA TU106M [GeForce RTX 2060 Mobile] driver: nvidia v: 470.63.01
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir driver: amdgpu v: kernel
           Device-3: Chicony Integrated Camera type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.13 driver: loaded: amdgpu,ati,nvidia unloaded: modesetting,nouveau s-res: 1920x1080
           OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.14.10-1-MANJARO LLVM 12.0.1) v: 4.6 Mesa 21.2.3
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi
Drives:    Local Storage: total: 476.94 GiB used: 167 GiB (35.0%)
Info:      Processes: 349 Uptime: 3h 43m Memory: 15.01 GiB used: 3.34 GiB (22.2%) Shell: Bash inxi: 3.3.08

Have you checked… :arrow_down:

System Settings → Workspace → Shortcuts → KWin → “Make window fullscreen:”


1 Like

yes I did… there’s nothing

the screenshot is in Spanish (pantalla completa = full screen)

(as you can see I enabled “highlight changed settings”)

Check the shortcuts in yuzu itself.

nothing (default)

and you can see in yuzu

I looked for every one of them in setting for F11 and no other has it defined

If I use F11 with another app it works without the warning, even with other flatpak apps. In dolphin F11 is used to show/hide a side panel without any issue. I really don’t understand whats the problem here. And most important, where I can check this ambiguity. Is there a log in KDE I can read and monitor?

Did you uncheck the box alongside Pantalla completa?

If I check that box it will enable (and go) full screen, to be able to take the screenshot I started it and kept it as it was (windowed mode)

also there’s a place where yuzu’s shortcuts are defined, tried commenting the line but the file was recreated after open/close it

$ cat .var/app/org.yuzu_emu.yuzu/config/yuzu/qt-config.ini | grep F11

the only way to disable that key in yuzu’s ini was to change the lines




but when I did that I didn’t have a key to go full screen

of course I could set a different key, but that key should be used to do that



I will try the AppImage version of yuzu, just in case

well, it looks like it was the flatpak implementation because running using the AppImage I didn’t have any warning when I pressed F11

Thanks for all your help, I’ll report this to the person in charge of building the flatpak

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.