The installer fails to use the selected EFI partition

I have downloaded manjaro-gnome-21.1.0-210817-linux513.iso
This is the latest stable Majaro with Gnome 40.
During the installation from a bootable usb stick I chose the EFI partition (FAT32) and marked it as “boot” with “/boot/efi” mount point. Surprisingly, I got a warning saying “No EFI system partition configured” even though I have configured everything in the way that this dialog suggests.

Ubuntu 20.04.3 LTS didn’t have problems with my EFI.
“Legacy boot” is Off in BIOS, while “Secure boot” is also Off.
My laptop is: HP Pavilion 15-cw1007nv

Hi, welcome to the forum!

First, the last available ISO is 21.1.1 released two days ago.

Then, the problem. I think you do it right. I haven’t tried myself yet, but from a comment from other user in other topic I think it’s going to give you that warning/error message if the EFI partition is less than 512MiB. If the partition has FAT32 format and it’s marked as “boot” you should just continue (if possible)

Edit: I finally tested the installer. The limit is set at 300MiB. Under it it will show the warning message. But user can continue and the EFI partition is fully functional anyway

1 Like

boot and esp flags ?
for info, exists install guide

There is not anymore a separate “esp” flag. It’s actually the same flag as boot. You can’t even found it in the installer.

The guide needs an update.

Thanks for your reply! My EFI partition (/dev/sdb1) is only 260 MiB. So maybe I need to extend it.

It depends. Manjaro’s boot loader needs only like 150KiB from EFI partion. Windows needs like 30MiB. And some distros (like Ubuntu) store the kernels in the EFI partition. You can check how much space is used and decide for yourself is it necessary to expand it.

For example I have dual boot with Windows and my EFI partition is only 100MiB (over half of it is empty).

As I said in my message if you define the mount point and the boot flag, you should continue (if the installer lets you)

Thank you very much, I have followed your advice and ignored the message - and it worked!
The Manjaro team should replace the text of the dialog, because it is misleading.

It might be better to point Calamares devs to it, we’re not in charge of installer internals. Create a new issue on it’s GitHub if it’s needed.

It seems that it already has been addressed: :slight_smile:

1 Like