The graphics card on the laptop does not switch (nvidia)

I tried that but optimus still tells me that the active card is integrated instead of nvidia.

so uninstall optimus manager + optimus manager plasma, remove the config from:
find /etc/X11/ -name "*.conf"
reboot; then install this:
pamac build envycontrol
switch to nvidia:

sudo envycontrol -s nvidia

it will prompt you for reboot so do it, and then check if you are using nvidia with:

all the settings worked without error, but after the reboot the login screen didn’t even appear, so I reinstalled optimus-manager.

so you cant switch via optimus, you also cant switch via envycontrol, so there must be something wrong with your nvidia, either with the hardware or with the drivers… i checked again the pacman -qs nvidia output above and find there something suspicious:

do you still have it installed?:
pacman -Qs opencl-nvidia-390xx
if yes remove again optimus and its config (dont reboot), remove the nvidia drivers:
sudo mhwd -r pci video-hybrid-intel-nvidia-prime
and check if the 390xx package was removed. if it was not, remove it:
sudo pacman -R opencl-nvidia-390xx
then install again the nvidia drivers:
sudo mhwd -a pci nonfree 0300
and check if the proper version of opencl was installed:
pacman -Qs opencl-nvidia
if not, install the proper version:
sudo pacman -S opencl-nvidia
install optimus again, reboot and test

still not changing. Sorry, but I’m new to graphics cards, I was wondering if I had done something with the config before when I tried to fix it before I posted on this forum. Is there any option to restore?

I also tried to run startx, during which optimus-manager showed me that I was in nvidia mode, but after rebooting I had the same problem again.

we reinstalled optimus several times + removed its config, we also reinstalled the video drivers, so its not related to any config from optimus or video drivers…
switch via optimus tray to nvidia, and post output from:
pacman -Qs nvidia
find /etc/X11/ -name "*.conf"
pacman -Qm


 $ pacman -Qs nvidia
local/egl-wayland 2:1.1.11-3
    EGLStream-based Wayland external platform
local/lib32-nvidia-utils 525.89.02-1
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.5-1
    Nvidia VDPAU library
local/libxnvctrl 525.89.02-1
    NVIDIA NV-CONTROL X extension
local/linux515-nvidia 525.89.02-2 (linux515-extramodules)
    NVIDIA drivers for linux
local/mhwd-nvidia 525.89.02-1
    MHWD module-ids for nvidia 525.89.02
local/mhwd-nvidia-390xx 390.157-1
    MHWD module-ids for nvidia 390.157
local/mhwd-nvidia-470xx 470.161.03-2
    MHWD module-ids for nvidia 470.161.03
local/nvidia-prime 1.0-4
    NVIDIA Prime Render Offload configuration and utilities
local/nvidia-utils 525.89.02-1
    NVIDIA drivers utilities
local/opencl-nvidia 525.89.02-1
    OpenCL implemention for NVIDIA
local/prime 1.0-14
    Nvidia:PRIME Render Offload Launcher
 $ find /etc/X11/ -name "*.conf"
$ nvidia-smi
Sun Feb 19 21:37:06 2023       
| NVIDIA-SMI 525.89.02    Driver Version: 525.89.02    CUDA Version: 12.0     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0  On |                  N/A |
| N/A   45C    P5    14W /  80W |    100MiB /  6144MiB |     41%      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A      2257      G   /usr/lib/Xorg                      91MiB |
|    0   N/A  N/A      6099    C+G   ...x86_64/qemu-system-x86_64        4MiB |
$  pacman -Qm
adduser 1.17-3
android-apktool 2.7.0-1
android-sdk 26.1.1-2
android-studio 2022.1.1.20-1
apg 2.2.3-5
betterdiscord-installer 1.2.0-1
blender-plugin-gcode-reader 0.1_r29.74a9fbf-3
cpupower-gui 1.0.0-5
dddvb-dkms 0.9.37-1
electron18 18.3.15-4
f2c 20200916-3
fiddler 4.6.20171.26113-1
figma-linux 0.9.6-0
flutter 3.3.10-1
fvm-bin 2.4.1-1
gnome-icon-theme 3.12.0-7
gnome-icon-theme-symbolic 3.12.0-6
google-chrome 110.0.5481.100-1
gotop 4.2.0-1
grapejuice-git 7.5.1-1
grub-editor 1.12-1
hollywood 1.21-7
httptoolkit 1:1.12.2-1
ida-free 8.2.230124-1
jdk 19.0.2-1
jre 19.0.2-1
levmar 2.6-3
lib3ds 1.3.0-1
libax25 0.0.12_rc5-2
libkipi 22.04.0-1
libkipi-debug 22.04.0-1
manjaro-documentation-en 20181009-1
manjaro-firmware 20160419-1
meshlab 2022.02-1
minecraft-launcher 1:1.0.1221-1
mpir 3.0.0-3
myman 0.7.0-7
node 0.3.2-3
nodejs-nativefier 50.0.1-1
note 1.3.22-1
noto-fonts-compat 20151217-1
oneko 1.2.5-4
openctm-tools 2:1.0.3-1
openssl-1.0 1.0.2.u-5
packettracer 8.2.0-1
prime 1.0-14
protontricks 1.10.1-1
protonvpn-cli 3.13.0-2
protonvpn-gui 1.12.0-1
python-pep517 0.13.0-1
python-proton-client 0.7.1-2
python-protonvpn-nm-lib 3.14.0-1
python-vdf 3.4-2
qed-git r192.d52b1f0-1
qt5-webkit 5.212.0alpha4-18
rollup 3.0.0-1
rtl8188gu-dkms-git r14.23b04ff-1
rtl8812au-dkms-git 5.13.6.r143.g07ac856-1
ruby-iostruct 0.0.4-1
ruby-zpng 0.4.3-1
sdkmanager 0.6.0-2
slack-desktop 4.29.149-1
speedometer 2.9-1
spotify 1:
steghide 0.5.1-9
timeset-gui 2.5-1
toilet 0.3.r155.3eb9d58-1
tor-browser 12.0.2-1
xli 1.17.0+20061110-7
xminesweeper 2.1.1-3
zsteg 0.2.11-1

the only thing im seeing thats suspicious is this:

so remove it:
sudo pacman -R prime
reboot and test

1 Like

Oh my god it is working now, thank you so much man!
Can I ask why did prime cause the problem?

i should pay more attention to the outputs, first i missed the opencl-nvidia-390xx, then i missed that you have 2 prime packages, this from manjaro and official repos:

and this from aur:

which was the one causing the problem, it was conflicting with optimus …

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.