The fprintd service will no longer start


Since 2 updates ago my fingerprint reader is no longer working. After the second to last stable update when it broke I figured and wait till the next stable update. The update came last week but the fingerprint is still not working. Today I decided to look into it.

The problem is that the fprintd service will not start, looking at the service status it shows this problem:

sudo systemctl start fprintd
fprintd.service: Main process exited, code=killed, status=11/SEGV

Looking at coredumpctl I see this line:

Wed 2022-03-02 20:41:02 CET   76177     0     0 SIGSEGV inaccessible /usr/lib/fprintd

This is the file in question:

-rwxr-xr-x 1 root root 108456 nov  6 01:47 /usr/lib/fprintd
pamac info fprintd                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                          
Name                  : fprintd
Version               : 1.94.1-1
Description           : D-Bus service to access fingerprint readers
URL                   :
Licenses              : GPL
Repository            : extra
Installed Size        : 863,3 kB
Groups                : fprint
Depends On            : glib2 libfprint polkit dbus dbus-glib systemd
Optional Dependencies : --
Required By           : --
Optional For          : --
Provides              : --
Replaces              : --
Conflicts With        : --
Packager              : Jan Alexander Steffens (heftig) <>
Build Date            : za 06 nov 2021 01:47:05 CET
Install Date          : wo 02 mrt 2022 20:24:18 CET
Install Reason        : Explicitly installed
Validated By          : Signature
Backup files          : --

I was running version 1.90.6 because a newer version had other issues but the version doesn’t seem to matter as both give the same error.

This is the journalctl -x --since "20 min ago" | grep fprint output

mrt 02 20:41:02 roland-xps kernel: usb 1-1: usbfs: process 76177 (fprintd) did not claim interface 0 before use
mrt 02 20:41:02 roland-xps audit[76177]: ANOM_ABEND auid=4294967295 uid=0 gid=0 ses=4294967295 subj==unconfined pid=76177 comm="fprintd" exe="/usr/lib/fprintd" sig=11 res=1
mrt 02 20:41:02 roland-xps kernel: fprintd[76182]: segfault at 40 ip 00007f68bf5d1646 sp 00007f68bcb73b60 error 4 in[7f68bf5c8000+e000]
mrt 02 20:41:02 roland-xps kernel: audit: type=1701 audit(1646250062.052:1147): auid=4294967295 uid=0 gid=0 ses=4294967295 subj==unconfined pid=76177 comm="fprintd" exe="/usr/lib/fprintd" sig=11 res=1
mrt 02 20:41:02 roland-xps systemd-coredump[76184]: Process 76177 (fprintd) of user 0 dumped core.
                                                    Module with build-id 01536b45d70789d9158ab7d2c834dd64b029c7b1
                                                    Module with build-id 598f4a40b805dd4e225b20486cc553512c8c45a7
                                                    Module with build-id b1aaf1e2933150bb019cd2b512cd3cca92023128
                                                    Module fprintd with build-id 42bb807837a2b1f18da7adcc9f939c68b0643cb7
                                                    #3  0x00007f68bde1460c n/a ( + 0x5060c)
                                                    #7  0x00007f68bde1511c n/a ( + 0x5111c)
                                                    #8  0x00007f68bddd8c3a n/a ( + 0x14c3a)
                                                    #9  0x00007f68bdddc97c n/a ( + 0x1897c)
                                                    #10 0x00007f68bdde2d4a n/a ( + 0x1ed4a)
                                                    #11 0x00007f68bddd8eb9 n/a ( + 0x14eb9)
                                                    #12 0x00007f68bddd9fee n/a ( + 0x15fee)
                                                    #13 0x00007f68bddda08b n/a ( + 0x1608b)
                                                    #14 0x00007f68bddddf8a n/a ( + 0x19f8a)
                                                    #15 0x00007f68bdde158e n/a ( + 0x1d58e)
                                                    #16 0x00007f68bddee23d n/a ( + 0x2a23d)
                                                    #17 0x00007f68bde16f4b n/a ( + 0x52f4b)
                                                    #18 0x00007f68bde1a4aa n/a ( + 0x564aa)
                                                    #19 0x00007f68bfd671d5 n/a ( + 0x421d5)
                                                    #23 0x00007f68bfd39580 fp_context_enumerate ( + 0x14580)
                                                    #24 0x000055bc7b727353 n/a (fprintd + 0xd353)
                                                    #28 0x000055bc7b7223ee n/a (fprintd + 0x83ee)
                                                    #31 0x000055bc7b7226ce _start (fprintd + 0x86ce)
░░ Subject: Process 76177 (fprintd) dumped core
░░ Process 76177 (fprintd) crashed and dumped core.
mrt 02 20:41:02 roland-xps systemd[1]: fprintd.service: Main process exited, code=killed, status=11/SEGV
░░ An ExecStart= process belonging to unit fprintd.service has exited.
mrt 02 20:41:02 roland-xps audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=fprintd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
mrt 02 20:41:02 roland-xps systemd[1]: fprintd.service: Failed with result 'signal'.
░░ The unit fprintd.service has entered the 'failed' state with result 'signal'.
░░ Subject: A start job for unit fprintd.service has failed
░░ A start job for unit fprintd.service has finished with a failure.

inxi -Fazy

  Kernel: 5.16.11-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-x86_64
    root=UUID=61563fba-524b-4fad-8d9e-d8b4c4bfde08 ro quiet apparmor=1
    security=apparmor udev.log_priority=3
  Console: pty pts/1 wm: kwin_x11 DM: SDDM Distro: Manjaro Linux
    base: Arch Linux
  Type: Laptop System: Dell product: XPS 17 9700 v: N/A serial: <filter>
    Chassis: type: 10 serial: <filter>
  Mobo: Dell model: 03CPGC v: A00 serial: <filter> UEFI: Dell v: 1.12.0
    date: 12/08/2021
  ID-1: BAT0 charge: 70.3 Wh (100.0%) condition: 70.3/95.1 Wh (74.0%)
    volts: 12.6 min: 11.4 model: BYD DELL F8CPG0B type: Li-poly serial: <filter>
    status: Full
  Device-1: hid-4c:74:bf:f2:51:de-battery model: Magic Trackpad 2
    serial: N/A charge: N/A status: Discharging
  Info: model: Intel Core i9-10885H bits: 64 type: MT MCP arch: Comet Lake
    family: 6 model-id: 0xA5 (165) stepping: 2 microcode: 0xEC
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1602 high: 3200 min/max: 800/5300 base/boost: 2673/2400
    scaling: driver: intel_pstate governor: powersave volts: 0.8 V
    ext-clock: 100 MHz cores: 1: 2822 2: 2274 3: 2535 4: 800 5: 800 6: 1697
    7: 3200 8: 1968 9: 823 10: 850 11: 900 12: 865 13: 881 14: 807 15: 1547
    16: 2867 bogomips: 76816
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Dell driver: i915
    v: kernel ports: active: DP-6,eDP-1 empty: DP-1, DP-2, DP-3, DP-4, DP-5
    bus-ID: 00:02.0 chip-ID: 8086:9bc4 class-ID: 0300
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Max-Q] vendor: Dell
    driver: nvidia v: 510.54 alternate: nouveau,nvidia_drm pcie: gen: 1
    speed: 2.5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1f12 class-ID: 0300
  Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-5:3 chip-ID: 0bda:5510 class-ID: fe01 serial: <filter>
  Device-4: Chicony USB2.0 FHD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 9-2.1.4:8 chip-ID: 04f2:b612 class-ID: 0e02 serial: <filter>
  Display: server: X.Org v: compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 7680x1440 s-dpi: 96 s-size: 2032x381mm (80.0x15.0")
    s-diag: 2067mm (81.4")
  Monitor-1: DP-2-3 pos: primary,right res: 5120x1440 hz: 70 dpi: 109
    size: 1190x340mm (46.9x13.4") diag: 1238mm (48.7")
  Monitor-2: eDP-1 pos: primary,left model: Sharp built: 2020 res: 2560x1440
    hz: 60 dpi: 178 gamma: 1.2 size: 366x229mm (14.4x9.0") diag: 432mm (17")
    ratio: 16:10 modes: 3840x2400
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.3.7
    direct render: Yes
  Device-1: Intel Comet Lake PCH cAVS vendor: Dell
    driver: sof-audio-pci-intel-cnl
    alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:06c8 class-ID: 0401
  Device-2: Realtek USB Audio type: USB driver: snd-usb-audio
    bus-ID: 9-2.1.3:5 chip-ID: 0bda:48a5 class-ID: 0102 serial: <filter>
  Device-3: Realtek USB Audio type: USB driver: snd-usb-audio
    bus-ID: 9-2.3.4:7 chip-ID: 0bda:402e class-ID: 0102 serial: <filter>
  Sound Server-1: ALSA v: k5.16.11-2-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.47 running: yes
  Device-1: Qualcomm QCA6390 Wireless Network Adapter [AX500-DBS ]
    vendor: Rivet Networks driver: ath11k_pci v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 link-max: gen: 3 speed: 8 GT/s bus-ID: 04:00.0
    chip-ID: 17cb:1101 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
    bus-ID: 10-2.4:4 chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
  IF: enp168s0u2u4 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
    bus-ID: 9- chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
  IF: eth1 state: down mac: <filter>
  IF-ID-1: br-18e56cd16eda state: down mac: <filter>
  IF-ID-2: br-1bdc3ca4dbbb state: down mac: <filter>
  IF-ID-3: br-d57b148c034a state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IF-ID-4: docker0 state: down mac: <filter>
  IF-ID-5: veth5d0218e state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-6: veth7c68f41 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-7: vethcabf193 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-8: vethe0dbc24 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  Local Storage: total: 3.68 TiB used: 1.41 TiB (38.3%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: KIOXIA
    model: KXG60PNV2T04 NVMe 2048GB size: 1.86 TiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 10704104 temp: 30.9 C scheme: GPT
  SMART: yes health: PASSED on: 208d 20h cycles: 697
    read-units: 26,715,193 [13.6 TB] written-units: 153,696,668 [78.6 TB]
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Seagate model: Expansion
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B type: N/A
    serial: <filter> rev: 0707 scheme: GPT
  SMART Message: A mandatory SMART command failed. Various possible causes.
  ID-1: / raw-size: 1.43 TiB size: 1.41 TiB (98.36%) used: 591.51 GiB (41.1%)
    fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p7 maj-min: 259:7
  ID-2: /boot/efi raw-size: 150 MiB size: 146 MiB (97.33%)
    used: 92.5 MiB (63.3%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 47.0 C pch: 57.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 1680 fan-2: 1684
  Processes: 460 Uptime: 10h 13m wakeups: 11 Memory: 62.55 GiB
  used: 18.48 GiB (29.5%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1574 lib: 456 flatpak: 0
  Shell: Zsh (sudo) v: 5.8.1 default: Bash v: 5.1.16 running-in: yakuake
  inxi: 3.3.13

So my primary question I guess is why is fprintd being reported as inaccessible and how to resolve that?

Thank you for any help.

your fprints is not running the latest version and was build in nov 2021. Chances are that one of the two updates you’ve mentioned may have caused some trouble.
I’d suggest you remove your current AUR version and install libfprint with pacman. (Version 1.94.3-1)
I hope this version can fix your issue!

fprintd is not in the AUR, it’s an Arch extra package in the Manjaro extra repo.

fprintd 1.94.2-1 was just updated a few days ago and is only in the Manjaro unstable branch. 1.94.1-1 is in the stable and testing branches.


Ah ok, that’s unfortunate. My bad

fprintd and libfprint are two different packages.

Your profile says you’re using the Manjaro stable branch. Somehow I doubt that–or you didn’t bother seraching before answering.

I don’t mean to pick on you specifically, this has been a trend lately. Bad advice is being given without bothering to search.

I figured that you were actually able to start the fprintd daemon, but it immediately crashed.

Looking at your coredumpctl and relevant journalctl logs, there’s a memory-related bug in fprintd. You can see this is the issue because the kernel signaled a SIGSEGV.

My advice will be one of the following: