The default shell is switched after updating the system and can not changed


I have been using fish as my default shell. After this update (Manjaro 21.2rc Qonos), my default shell has become zsh. I tried chsh and shut down and power off and power on, but it never took effect.

So I uninstalled all zsh-related packages, and then the default shell did switch to fish, but every time I start the terminal, I get a warning.

When I run chsh:

~ chsh                                                                                         09:39:43
正在更改 myuan 的 shell。# myuan is my username
密码: # password
新 shell [/bin/fish]:  # new shell [/bin/fish]

When I start a new terminal:

# means: Warning: "/bin/zsh" could not be found, "/bin/fish" has been started instead. Please check the configuration plan.

Welcome to fish, the friendly interactive shell
Type help for instructions on how to use fish

But chsh -l shows:

~ chsh -l                                                                                      09:40:33

How should I eliminate this warning? Thanks!

Which terminal emulator do you use? E.g. Konsole doesn’t respect your setting and has its own shell settings. Maybe others do too.

Have you seen this? I use bash by default so I changed it from zsh to bash.

1 Like

Thank you, I did use Konsole, I eliminated the warning!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.