The current theme cannot be loaded after update

Yesterday I installed the updates and saw error after reboot. I tried to roll back to 2021/06/25 (archive archlinux) with overwriting, reinstalled all kf5, changed themes via kde_settings.conf, but to no avail. For a day I tried to solve the problem using existing forum threads, but I could not find a solution. Now I don’t know what to do

Text from error photo:

file:///usr/share/sddm/themes/breath2/Main.qml:26:1: plugin cannot be loaded for module "org.kde.plasma.core": Cannot load library /usr/lib/qt/qml/org/kde/plasma/core/ (/usr/lib/ undefined symbol: _ZN15KToolInvocation11qt_metacastEPKc)


From TTY please run:

sudo pacman-mirrors -f5 && pamac upgrade --force-refresh && pamac install kservice

It seems that I have already done the same, only through pacman.

I ran the your commands and rebooted the system. The error persisted :unamused::pensive:

I tried reinstalling kio (sudo pacman -S --overwrite "*" kio) and changing theme again (oxygen). Now this error has disappeared, but after entering the password, the loading animation occurs, but the “desktop environment” does not load. Applications that were in autostart are automatically started. Hotkeys work and applications are launched via al+,space. Mouse cursor does not move and background is black.

sudo pacman -S --overwrite "*" plasma-desktop kpmcore

After rebooting, wallpaper and environment appeared. But the cursor still doesn’t work


I had the same issue and it turns out I still had two of those community packages (the -git ones) installed. I used a live USB system and Timeshift to get back to the state before the update, replaced the two packages attica-git and solid-git with attica and solid respectively (sudo pacman -S attica solid) and did the update again. Everything went well after that. Maybe you can replace these packages from tty. I used pamac list --installed | grep git to find any remaining community packages, although I’m not sure if you can use pamac in the tty thing without logging in; I never had to use that.

I thought this was the problem, but I didn’t have the “-git” packages :pensive:

remove home cache ~/.cache ?

I removed this directory and rebooted my laptop. Nothing changed. Mouse, trackpad and usb keyboard are not working now :crying_cat_face:

you use plasma-desktop-primex ? if yes replace it by plasma-desktop

No, i use plasma-desktop

view logs…

 systemctl -b0 -p3

I don’t understand well what this log is telling me

only this error ?
you can stop baloo

balooctl disable

Yep, after reboot, only the first five lines are left :point_right::point_left: