The calendar freezes when subscribing to a network calendar via CALDAV

Since last big Update of Thunderbird the calendars are freezing when subscribing to a network calendar via CALDAV, sometimes just by incident, sometimes if I want to add a new date the calendar/thunderbird freezes. I am using networt calendars with CALDAV.

It is interesting that quite no other Linux distribution except Manjaro has integrated the big (unmature) update of Thunderbird.

The thunderbird package in the Manjaro Extra repository comes straight from Arch, without any modifications. So if it’s problematic in Manjaro, then it’ll also be problematic in Arch, and in other Arch derivatives like Garuda, EndeavourOS, et al.

1 Like

Same issue here!

Makes sense that all archlinux based systems are affected but what can be done?

Well, the most logical thing would be to file a bug upstream, i.e. with Arch. But don’t tell them you’re using Manjaro — they will chew you up and spit you out. :frowning_man:

Same issue for me. Limited to one of my CalDAV calendars, though. Another one (posteo) works like a charm and e.g. owl as well.
Anyone dared to knock upstreams’ door already, by chance?

Actually, the problem isn’t upstream — as in Arch directly — but farther up the food chain. It’s because Google changed it’s API once again, and so it’ll take time for the Mozilla (and other) developers to catch up with the changes. :frowning_man:

I’ve said it before and I’ll say it again: Google is genuinely evil. :imp:

I am not syncing any google calendars and have the same issue.

EDIT: I am syncing CalDAV calendars from my university, I guess this was not clear from this post alone.

I have opened a ticket in Archlinux Forum
They said they do not have this problem using thunderbird 115.2. But we in Manjaro use 115.1. In flatpak 115.3 is already available.

Maybe I have to wait for the next bigger upgrade of thunderbird in manjaro.

I’m afraid you’ll be booted out if you do because Manjaro is not supported here.


You’re not up to date. 115.2.2-1 is available in the stable branch and 115.2.3-1 is available in the testing and unstable branches.

It is amazing. I have done an database update of pacman still this morning. No TB 115.2 was available.
Now again having run an database update. Now version 115.2.2-1 version is available within pamac. May be I had to wait for the latest update because I am using Kernel 6.1.53 LTS.

What kernel you’re on has nothing to do with it. It’s all about what mirror you use. But since update was 10 days ago, I doubt it took 10 days for mirror to sync and if it did you should remove it forever.

1 Like

How can I remove a specific mirror using pamac?

After my last update to Thunderbird 115.2.2-1 I have tried today to add a network calendar via caldav again. The result is even worse. Thunderbird is freezing completely after start so I cannot delete the network calendars anymore.

  1. Is there any file or directory in /home/user/.thunderbird where I can delete this network calendar configuration to make thunderbird run again at least?
  2. I have tried out version 115.3 from flatpak. Same problem.
    3) I have found out that this bug “The calendar freezes when subscribing to a network calendar via CALDAV” is fixed in beta-version Thunderbird 119 which can be found in AUR. I have installed and it works fine. SOLVED
    But the dark side is that not all extensions do still work.
    So I also still use Version 115 for some purposes.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.