Text not visible in any editor

Hello :slightly_smiling_face:,
When I want to modify an existing file with any editor, especially Gédit, the file opens, but the text written in it is not visible. Moreover, my cursor is placed very low in the window.
Here is an example of a photo. Would you please have an idea?

inxi --admin --verbosity=7 --filter --no-host --width

  Kernel: 6.1.1-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=7dc57551-ad43-4995-bd48-bc649c636189 rw quiet splash
  Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: Inspiron 3793 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0C1PF2 v: A00 serial: <superuser required> UEFI: Dell
    v: 1.20.0 date: 03/19/2022
  ID-1: BAT0 charge: 21.6 Wh (74.0%) condition: 29.2/42.0 Wh (69.6%)
    volts: 11.4 min: 11.4 model: SMP DELL VM73297 type: Li-poly serial: <filter>
    status: discharging
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  RAM: total: 23.25 GiB used: 3.3 GiB (14.2%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-1035G1 bits: 64 type: MT MCP arch: Ice Lake
    gen: core 10 level: v4 note: check built: 2019-21 process: Intel 10nm
    family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xB6
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 1250 high: 1301 min/max: 400/3600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1223 2: 1300 3: 1301
    4: 1200 5: 1200 6: 1276 7: 1200 8: 1300 bogomips: 19048
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
    avx512_vnni avx512_vpopcntdq avx512bw avx512cd avx512dq avx512f avx512ifma
    avx512vbmi avx512vl bmi1 bmi2 bts clflush clflushopt cmov constant_tsc
    cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms
    est f16c flexpriority flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp
    hwp_act_window hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed
    rdtscp rep_good sdbg sep sgx sgx_lc sha_ni smap smep split_lock_detect ss
    ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
    tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi
    vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Iris Plus Graphics G1 vendor: Dell driver: i915 v: kernel
    arch: Gen-11 process: Intel 10nm built: 2019-21 ports: active: eDP-1
    empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:8a56 class-ID: 0300
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-6:3 chip-ID: 0c45:671e class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.6 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: AU Optronics 0x139d built: 2018 res: 1920x1080
    hz: 60 dpi: 128 gamma: 1.2 size: 381x214mm (15x8.43") diag: 437mm (17.2")
    ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.3.1 renderer: Mesa Intel UHD Graphics (ICL GT1)
    direct render: Yes
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Dell
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_icl
    bus-ID: 00:1f.3 chip-ID: 8086:34c8 class-ID: 0403
  Sound API: ALSA v: k6.1.1-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.63 running: yes
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
    bus-ID: 01:00.0 chip-ID: 10ec:8136 class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: Dell driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-10:4
    chip-ID: 0cf3:e009 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.36 TiB used: 326.77 GiB (23.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT1000P5PSSD8
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: P7CR403 temp: 23.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD5000LPLX-00ZNTT0 size: 465.76 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 1A01 scheme: GPT
  Optical-1: /dev/sr0 vendor: PLDS model: DVD+-RW DU-8A5LH rev: 6D1M
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r state: running
  ID-1: / raw-size: 905.64 GiB size: 890.35 GiB (98.31%)
    used: 131.01 GiB (14.7%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: 7dc57551-ad43-4995-bd48-bc649c636189
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 3.5 MiB (1.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: B94D-6E15
  ID-3: /run/media/sl/SECOND raw-size: 465.76 GiB size: 457.38 GiB (98.20%)
    used: 195.75 GiB (42.8%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: SECOND
    uuid: 9f995a94-4fcc-46a6-b48d-3ef103c4f655
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 25.58 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3 label: swap
    uuid: 00eec800-1525-46aa-ab8e-4955dea9a4f6
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Device-2: 1-6:3 info: Microdia Integrated_Webcam_HD type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0c45:671e class-ID: 0e02
  Device-3: 1-10:4 info: Qualcomm Atheros type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 0cf3:e009
    class-ID: e001
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 47.0 C mobo: 25.0 C
  Fan Speeds (RPM): cpu: 0
  Processes: 222 Uptime: 5m wakeups: 3 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1399 pm: dpkg
  pkgs: 0 pm: pacman pkgs: 1393 libs: 346 tools: pamac pm: flatpak pkgs: 6
  Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.24

Moderator edit: Fixed image link

Use a different editor?
KDE Plasma is based on QT.
Gedit is a GTK application.
There are good editors for Plasma without having to jump through hoops to make them behave.
This is likely a theme issue.

There is nothing behind what you probably intended to be a link.


Why is this topic tagged terminal when the problem is GUI related :thinking:
(And no info available about what GUI is used in the OP nor the OP’s profile)
(except plasma as tag maybe, but not sure if that is KDE only)

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
    (Wisdom lies in reading :wink: )

Precision, I use Kwrite, but in order to verify that cal did not come from the latter, I tried Gparted that I know.
After testing several themes, no change. Curious, it worked fine under the LTS 5.15.85-1 kernel!

Just an idea. Assuming Gedit behaves like most other GUI text editors (I used Gedit in 2009, immediately switched to Geany), press Ctrl-A to select all text. Anything visible then?
Sometimes programs pull an invisibility cloak over the screen when dark mode is selected on the system. Because there are different settings for GTK and Qt and whatnot. You have to tweak both/all three/everything. E.g., Geany suffers from this as well, because it has its own special settings files you have to tweak the colors you want to use. It is not fun, but what to do?
On the system, going into settings, in the left column, there is a setting for Application Style. Far down at the bottom on that column to the right, there is a button to Configure GNOME/GTK Application Style…
Perhaps check that, in case you do get some text visible if you Ctrl-A. :slight_smile:

Thank you for your feedback. Being on KDE, I did not keep Gedit. However, I have uninstalled and reinstalled Kate, the KDE editor, without result.

I tried a clear default theme: nothing changes.
When I use my terminal (or Konsole on KDE PLamsa), everything works fine. However, when I want to edit a file, for example via this command: udo edit /etc/sddm.conf, the cursor is at the bottom of the page with this result: “/etc/sddm.conf” 48 lines, 1066 characters
It is the same display whatever the file. Nothing else is visible. If I want to write or ctrl A as mentioned by qruqs, it displays symbols and letters. But when I access the file via Dolphin as a super user, I manage to open it and modify it.
When I uninstalled Kate, I ran the above command in terminal to see. I would have thought that it should not have worked. Is there another default editor in Manjaro KDE? I can’t see!

Translated with DeepL Translate: The world's most accurate translator (free version)

… you meant to write:
sudo edit /etc/sddm.conf

and what you did here is to try and use an ancient terminal text editor,
called “edit”,
a program which YOU DO NOT really want to use :grimacing:

I do not know how to operate it.

nano is much easier
vi and vim are other text editors that run with a terminal interface, but there is quite a learning curve to using them - just type vim and you get to see the start of the tutorial …

sudo nano /etc/sddm.conf
is what you should use.

… make a backup of that file before you start changing it, in case you mess it up due to your unfamilarity with the editor …

If you like the terminal so much, try mc - a terminal file manager with many features, including a built in editor …
I use it all the time.

1 Like

Hello Nachlese,
Thank you very much for your excellent feedback! Indeed, using “nano”, it worked :slightly_smiling_face:.
Thanks for the suggestions of other managers, but I prefer to continue to use the one of KE for a better integration and stability.
As for my little knowledge of Linux, I’m slowly reading books to use it better.

Anyway, thanks a lot to all those who patiently help novices like me. :pray: :clap:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.