Texlive broken after update


I recently updated my system. texlive got updated in the process.

I wanted to edit a LaTeX document today. I ran pdflatex and I got this error message:

! LaTeX Error: File `eurosym.sty’ not found.

I used the package before I updated my system. I tried to install it, anyway.

I got (a bit unsurprisingly) this message:

$ sudo tlmgr install eurosym                                  
tlmgr: package repository /usr/share (not verified: unknown)
tlmgr install: package already present: eurosym

So, the package is missing and at the same time the package is already installed :exploding_head: Kind of a catch 22 :sweat_smile:

How do I fix this?

Furthermore, how do I prevent a system update from breaking things like this? Is that possible? I’d like to spend my time on more important things than fixing things that once worked :sweat_smile: (this isn’t a rant against manjaro/arch. If I disliked it, I know I could easily switch distro)

Have a great start in the weekend. Stay safe!

Perhaps the following has something to do with it? :arrow_down:

Thanks for the hint. This is probably be a piece of the puzzle.

On the other hand it won’t quite explain the issue.

sudo tlmgr info eurosym | grep collection
collection:  collection-fontsrecommended

I didn’t install texlive-fontsrecommended, but I installed eurosym manually. So, why does latex believe it isn’t present?

Because of the package reorganization. Just run… :arrow_down:

sudo pacman -Syu texlive-meta

… to get everything with the proper configuration.

You shouldn’t mix package managers.

Use pacman/palace for everything.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.