[Testing Updates] 2024-03-01 - Gnome Builder, Lazarus, Signal, XFCE, Python

Hello community,

here we have another set of package updates! This is rather a small one …

Current promotions

  • image

    We currently have a flashsale with our partner MINISFORUM on the UM790Pro featuring the Manjaro Linux GamingEdition. Use the device either as a MiniPC or Gaming Console! Use our link to get yours. Note: US Market only!

  • Find out all about our current Gaming Laptop the Hero with Manjaro pre-installed from Spain!

  • Protect your personal data, keep yourself safe with Surfshark VPN: 79% OFF + 2 mo. FREE

Recent News

Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog

image

Notable Package Updates

  • Gnome builder got updated to focus more on flatpaks separately
  • lazarus IDE got renewed to 3.2
  • Signal is now at 7.0.0.
    • more about the new option to use user names can be found here
  • Updates to XFCE and Python

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcements topics are off-topic and will be flagged, moved or removed without warning.

For help with AUR packages, please create a new topic in AUR and a helpful volunteer may be able to assist you.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.


Our current supported kernels

  • linux419 4.19.307
  • linux54 5.4.269
  • linux510 5.10.210
  • linux515 5.15.149
  • linux61 6.1.79
  • linux66 6.6.18
  • linux67 6.7.6
  • linux68 6.8.0-rc6
  • linux61-rt 6.1.77_rt24
  • linux66-rt 6.6.15_rt22
  • linux67-rt 6.7_rt6

Package Changes (Fri Mar 1 06:08:37 CET 2024)

  • testing extra x86_64: 270 new and 274 removed package(s)
  • testing kde-unstable x86_64: 49 new and 49 removed package(s)
  • testing multilib x86_64: 3 new and 3 removed package(s)
:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2024-02-28           2024-03-01
-------------------------------------------------------------------------------
                              arkdep         2024.02.25-1         2024.02.29-1
                            chromium      122.0.6261.94-1                    -
              manjaro-pacnew-checker              0.5.4-3              0.6.0-1
                   opengamepadui-git0.30.2.r1.g94f966b8-10.30.2.r2.g7323c1c5-1
                 tuxedo-drivers-dkms              4.2.2-1              4.3.0-1
               vivaldi-ffmpeg-codecs      122.0.6261.84-1                    -


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2024-02-28           2024-03-01
-------------------------------------------------------------------------------
                       android-tools             34.0.4-3             34.0.4-4
                             ansible              9.2.0-1              9.3.0-1
                        ansible-core             2.16.3-1             2.16.4-1
                              awxkit             23.8.0-1             23.9.0-1
                       bbswitch-dkms              0.8-654              0.8-655
                                 bcc             0.28.0-2             0.29.1-1
                           bcc-tools             0.28.0-2             0.29.1-1
                            binaryen              1:116-1              1:117-1
                            birdfont             2.32.3-1             2.33.4-1
                             blender          17:4.0.2-14          17:4.0.2-15
                            bpftrace             0.19.1-1             0.20.1-1
                             buildah             1.34.0-2             1.34.1-1
                            calligra             3.2.1-55             3.2.1-56
                          cargo-deny            0.14.14-1            0.14.15-1
                             cfitsio            1:4.3.1-1            1:4.4.0-1
                            chromium      122.0.6261.69-1      122.0.6261.94-1
                                crun             1.14.3-1             1.14.4-1
                         dark-reader             4.9.77-1             4.9.78-1
                           darkhttpd               1.15-1               1.16-1
                              docker           1:25.0.2-1           1:25.0.3-1
                                dolt             1.34.3-1             1.35.0-1
                      doublecmd-gtk2             1.1.10-1             1.1.10-2
                       doublecmd-qt5             1.1.10-1             1.1.10-2
                       doublecmd-qt6             1.1.10-1             1.1.10-2
                                dpkg             1.22.0-1             1.22.5-1
                              dqlite             1.16.2-1             1.16.4-1
                               dunst              1.9.2-1             1.10.0-1
                             dvisvgm                3.2-1              3.2.1-1
                       dwarffortress              50.11-1              50.11-2
                          electron27             27.3.3-1             27.3.4-1
                          electron28             28.2.4-1             28.2.5-1
                          electron29             29.0.1-1             29.1.1-1
                            epiphany               45.2-1               45.3-1
                                 eza             0.18.4-1             0.18.5-1
                           fcitx5-qt              5.1.4-4              5.1.4-5
                 firefox-dark-reader             4.9.77-1             4.9.78-1
           firefox-developer-edition            124.0b4-1            124.0b5-1
  firefox-developer-edition-i18n-ach            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-af            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-an            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-ar            124.0b4-1            124.0b5-1
  firefox-developer-edition-i18n-ast            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-az            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-be            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-bg            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-bn            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-br            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-bs            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-ca            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-ca-valencia      124.0b4-1            124.0b5-1
  firefox-developer-edition-i18n-cak            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-cs            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-cy            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-da            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-de            124.0b4-1            124.0b5-1
  firefox-developer-edition-i18n-dsb            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-el            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-en-ca            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-en-gb            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-en-us            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-eo            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-es-ar            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-es-cl            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-es-es            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-es-mx            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-et            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-eu            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-fa            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-ff            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-fi            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-fr            124.0b4-1            124.0b5-1
  firefox-developer-edition-i18n-fur            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-fy-nl            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-ga-ie            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-gd            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-gl            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-gn            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-gu-in            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-he            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-hi-in            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-hr            124.0b4-1            124.0b5-1
  firefox-developer-edition-i18n-hsb            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-hu            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-hy-am            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-ia            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-id            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-is            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-it            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-ja            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-ka            124.0b4-1            124.0b5-1
  firefox-developer-edition-i18n-kab            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-kk            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-km            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-kn            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-ko            124.0b4-1            124.0b5-1
  firefox-developer-edition-i18n-lij            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-lt            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-lv            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-mk            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-mr            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-ms            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-my            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-nb-no            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-ne-np            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-nl            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-nn-no            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-oc            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-pa-in            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-pl            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-pt-br            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-pt-pt            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-rm            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-ro            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-ru            124.0b4-1            124.0b5-1
  firefox-developer-edition-i18n-sat            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-sc            124.0b4-1            124.0b5-1
  firefox-developer-edition-i18n-sco            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-si            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-sk            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-sl            124.0b4-1            124.0b5-1
  firefox-developer-edition-i18n-son            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-sq            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-sr            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-sv-se            124.0b4-1            124.0b5-1
  firefox-developer-edition-i18n-szl            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-ta            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-te            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-tg            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-th            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-tl            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-tr            124.0b4-1            124.0b5-1
  firefox-developer-edition-i18n-trs            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-uk            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-ur            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-uz            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-vi            124.0b4-1            124.0b5-1
   firefox-developer-edition-i18n-xh            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-zh-cn            124.0b4-1            124.0b5-1
firefox-developer-edition-i18n-zh-tw            124.0b4-1            124.0b5-1
                     flatpak-builder              1.4.0-1              1.4.2-1
                   gentium-plus-font              6.200-1                    -
                             git-lfs              3.4.1-1              3.5.0-1
                          github-cli             2.43.1-1             2.44.1-1
                       gitlab-runner             16.9.0-1             16.9.1-1
                        gitlab-shell          3:14.33.0-1          3:14.34.0-1
                            glfw-doc             3.3.10-1                    -
                        glfw-wayland             3.3.10-1                    -
                            glfw-x11             3.3.10-1                    -
                     glib-networking           1:2.78.0-1           1:2.78.1-1
                       gnome-builder               45.0-3               45.0-4
                      gnome-contacts               45.0-1               45.1-1
                         gnome-panel             3.50.0-3             3.50.0-4
                               gopls             0.14.2-1             0.15.1-1
                             gparted              1.5.0-1              1.6.0-1
                       grafana-agent             0.40.0-1             0.40.1-1
                    grafana-agentctl             0.40.0-1             0.40.1-1
                             haproxy              2.9.5-1              2.9.6-1
                                hugo            0.123.4-1            0.123.6-1
                            hyprlang              0.4.0-1              0.4.1-1
                               imath             3.1.10-1             3.1.11-1
                               kafka              3.6.1-1              3.7.0-1
                             krename              5.0.2-9             5.0.2-10
                             lazarus                3.0-2                3.2-1
                        lazarus-gtk2                3.0-2                3.2-1
                        lazarus-gtk3                3.0-2                3.2-1
                         lazarus-qt5                3.0-2                3.2-1
                         lazarus-qt6                3.0-2                3.2-1
                              libbsd             0.12.0-1             0.12.1-1
                              libluv           1.48.0_0-1           1.48.0_1-1
                             libsrtp            1:2.5.0-1            1:2.6.0-1
                        libsrtp-docs            1:2.5.0-1            1:2.6.0-1
                            libunrar           1:6.2.12-1            1:7.0.7-1
                   libxfce4windowing             4.19.2-1             4.19.3-2
                         liquidshell              1.9.0-2              1.9.0-3
                          lua-dkjson                2.6-1                2.7-1
                             lua-luv           1.48.0_0-1           1.48.0_1-1
                        lua51-dkjson                2.6-1                2.7-1
                           lua51-luv           1.48.0_0-1           1.48.0_1-1
                        lua52-dkjson                2.6-1                2.7-1
                           lua52-luv           1.48.0_0-1           1.48.0_1-1
                        lua53-dkjson                2.6-1                2.7-1
                           lua53-luv           1.48.0_0-1           1.48.0_1-1
                            luarocks             3.10.0-1             3.10.0-2
                                mame              0.262-1              0.263-1
                          mame-tools              0.262-1              0.263-1
                              mandoc             1.14.6-2             1.14.6-3
                           materialx             1.38.8-8             1.38.9-1
                             melange              0.6.4-1              0.6.5-1
               netfilter-fullconenat      r73.0cf3b48-351      r73.0cf3b48-352
                 networkmanager-l2tp            1.20.10-1            1.20.12-1
                  nextcloud-app-mail              3.5.6-1              3.5.7-1
                                 nix             2.19.1-2             2.20.3-1
                            nix-docs             2.19.1-2             2.20.3-1
                                 npm             10.4.0-2             10.5.0-1
                                 orc             0.4.37-1             0.4.38-1
                             osbuild                109-1                111-1
                               pango           1:1.51.2-1           1:1.52.0-1
                          pango-docs           1:1.51.2-1           1:1.52.0-1
                       piping-server             0.17.0-1             0.18.0-1
                                pixi             0.15.1-1             0.15.2-1
                              pixman             0.43.2-1             0.43.4-1
     plasma5-applets-thermal-monitor              1.3.0-2                    -
                            polymake               4.11-6               4.11-7
                        prusa-slicer              2.7.1-1              2.7.2-1
                            pstoedit               3.78-1               4.00-1
                            pstotext                1.9-7                    -
           pycharm-community-edition           2023.3.3-1           2023.3.4-1
                             pyright            1.1.351-1            1.1.352-1
                      python-astroid             2.15.6-1              3.1.0-2
                          python-bcc             0.28.0-2             0.29.1-1
                        python-build              1.0.3-1              1.1.1-1
                       python-crc32c          2.3.post0-1                2.4-1
                python-flask-htmlmin              2.2.1-3                    -
                   python-hypothesis            6.98.13-1            6.98.15-1
                    python-inflate64              0.3.1-2              1.0.0-1
                       python-openai             1.13.2-1             1.13.3-1
                       python-poetry              1.7.1-1              1.8.1-1
                  python-poetry-core              1.9.0-2              1.9.0-3
                       python-pylint             2.17.7-1              3.1.0-1
                    python-pyscipopt              4.4.0-1              4.4.0-2
                         python-rich             13.7.0-1             13.7.1-1
                         python-ruff              0.2.2-1              0.3.0-2
              python-setuptools-rust              1.8.1-1              1.9.0-1
            python-trove-classifiers          2024.1.31-1          2024.2.22-1
                           python-uv             0.1.11-1             0.1.13-1
                                   r              4.3.2-4              4.3.3-1
                          rapidcheck      r1056.ff6af6f-1      r1056.ff6af6f-2
                              rasqal           1:0.9.33-6           1:0.9.33-7
                                rauc             1.11.1-1             1.11.2-1
                                 rcs             5.10.1-1             5.10.1-2
                              recoll             1.37.4-1             1.37.4-2
                         release-plz             0.3.48-1             0.3.49-1
                           repro-env              0.3.3-1              0.4.0-1
                                ruff              0.2.2-1              0.3.0-2
                            ruff-lsp             0.0.52-1             0.0.53-1
                                sane              1.2.1-6              1.3.0-1
                                scip              8.1.0-2              9.0.0-1
                         sequoia-wot             0.10.0-1             0.11.0-1
                      signal-desktop             6.48.1-1              7.0.0-1
                                sile            0.14.17-1            0.14.17-2
                         slicer-udev              2.7.1-1              2.7.2-1
                    ssh-openpgp-auth              0.2.1-1              0.2.2-1
                   sshd-openpgp-auth              0.2.1-1              0.3.0-1
              svelte-language-server             0.16.3-1             0.16.5-1
                           tailscale             1.60.0-1             1.60.1-1
             thunderbird-dark-reader             4.9.77-1             4.9.78-1
                              tinygo             0.31.0-1             0.31.1-1
                                 tor           0.4.8.10-1           0.4.8.10-2
                ttf-scheherazade-new              4.000-1              4.000-3
                               unrar           1:6.2.12-1            1:7.0.7-1
                                 usd             23.11-12             23.11-13
                          usd-extras             23.11-12             23.11-13
                                  uv             0.1.11-1             0.1.13-1
                               vault             1.15.5-1             1.15.6-1
                    vhba-module-dkms           20240202-3           20240202-4
               vivaldi-ffmpeg-codecs      120.0.6099.80-1      122.0.6261.84-1
           vscode-css-languageserver             1.86.0-1             1.87.0-1
          vscode-html-languageserver             1.86.0-1             1.87.0-1
          vscode-json-languageserver             1.86.0-1             1.87.0-1
      vscode-markdown-languageserver             1.86.0-1             1.87.0-1
                            wasmtime             18.0.1-1             18.0.2-1
                            waycheck              1.1.0-1              1.1.1-1
                            wrangler             3.30.0-1             3.30.1-1
              xf86-input-elographics              1.4.3-1              1.4.4-1
                xfce4-clipman-plugin              1.6.5-1              1.6.6-1
                         xfce4-panel             4.18.5-1             4.18.6-1
                   xfce4-taskmanager              1.5.6-2              1.5.7-1
                      xfce4-terminal              1.1.2-2              1.1.3-1
                                 znc              1.9.0-1              1.9.0-3
                             zziplib            0.13.72-2            0.13.73-1
                                glfw                    -                3.4-2
                 gnome-builder-clang                    -               45.0-4
               gnome-builder-flatpak                    -               45.0-4
                      python-joserfc                    -              0.9.0-1
                    ttf-gentium-plus                    -              6.200-5


:: Different overlay package(s) in repository kde-unstable x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2024-02-28           2024-03-01
-------------------------------------------------------------------------------
                    akonadi-contacts23.08.5.r3700.g8ec4c2fb-123.08.5.r3701.gb122e972-1
                        akonadi-mime23.08.5.r1998.g16e9fa7-123.08.5.r2000.g1a94ad3-1
                      akonadi-search23.08.5.r1600.g436bae6-123.08.5.r1606.g60857d7-1
                               baloo5.114.0.r3417.gc334530b-15.114.0.r3421.gc6ce8eb9-1
                       baloo-widgets23.08.5.r960.gb1a3f60-123.08.5.r962.gd9c9de7-1
                           calindori23.08.1.r831.gaa8d656-123.08.1.r832.g3a287b0-1
                             dolphin23.08.5.r7867.gf13f3c7a2-123.08.5.r7871.g992272f8c-1
                               elisa23.08.4.r3715.g707bfbe2-123.08.5.r3724.gdc125b06-1
                          elisa-qtmm23.08.4.r3715.g707bfbe2-123.08.5.r3724.gdc125b06-1
                           granatier23.08.5.r1144.gdac423a-123.08.5.r1145.gfce1eb6-1
                                 k3b1:23.08.5.r7147.g6810d711c-11:23.08.5.r7150.gaf0743069-1
                        kaddressbook23.08.5.r6659.g2fbdb2bf-123.08.5.r6661.gc913e17e-1
                            kcmutils5.114.0.r1094.g80db4e37-15.114.0.r1095.gd52a573d-1
                      kconfigwidgets5.114.0.r1051.g1ed5434e-15.114.0.r1053.g3cfbbeab-1
                       kde-cli-tools5.27.10.r2319.ga28aa659-15.27.10.r2320.gcb94a787-1
                            kdenlive23.08.5.r19607.g9c51caa25-123.08.5.r19616.g0791d4462-1
                            keysmith23.08.1.r588.ge49900e-123.08.1.r590.gef70642-1
                       kfilemetadata5.114.0.r1089.gb3643aa-15.114.0.r1091.g49aa1f8-1
                         kfourinline23.08.5.r1224.g2da8f64-123.08.5.r1225.g5a5e57d-1
                               ki18n5.114.0.r720.g7e987c1-15.114.0.r722.g7e6e758-1
                 kidentitymanagement23.08.5.r4288.gcd421c05-123.08.5.r4289.gb2c611ee-1
                         kinfocenter5.27.10.r2674.g89ff2977-15.27.10.r2677.g5e441188-1
                                 kio5.114.0.r6892.g67207a96e-15.114.0.r6894.gac50baa8f-1
                     kirigami-addons1:1.0.0.r4.g2d5904d-11:1.0.1.r0.ga1a67ea-1
                           kirigami25.114.0.r4404.g4500d6b1-15.114.0.r4405.gef4aeb77-1
                          kitinerary23.08.5.r3553.gafe59512-123.08.5.r3557.g46cc76b4-1
                      kmailtransport23.08.5.r2123.gededc00-123.08.5.r2124.gc1eb9eb-1
                           kmenuedit5.27.10.r1296.g554d40a-15.27.10.r1298.ge5b6c48-1
                           knewstuff5.114.0.r1803.ga6a02162-15.114.0.r1804.gdbf0f45b-1
                       kopeninghours23.08.5.r438.g95a9e0f-123.08.5.r439.g3eb449e-1
                         ktextaddons23.08.5.r1253.gcd85505-123.08.5.r1254.g1f7d373-1
                         ktexteditor5.114.0.r4412.g28e37d1c2-15.114.0.r4413.g8a74e8efd-1
                     kunitconversion5.114.0.r595.g793b415-15.114.0.r596.g583284a-1
                       kuserfeedback5.249.0.r10.ge1be745-1  6.0.0.r4.g5cb5a96-1
                                kwin5.27.10.r26232.g4d6f6223bc-15.27.10.r26275.g86ede0ecf2-1
                         libkdegames23.08.5.r2475.g6e67dda6-123.08.5.r2476.g94487c36-1
                  libkeduvocdocument23.08.2.r1872.gd6afb08-123.08.5.r1895.gd05366b-1
                             libkleo23.08.5.r1990.g4c86cf41-123.08.5.r1991.g5a7a63a0-1
                        libkmahjongg23.08.5.r638.g3960d8c-123.08.5.r639.g30f12d0-1
                          messagelib23.08.5.r7775.gb7d0cb363-123.08.5.r7782.gc2fbefd5a-1
                             neochat23.08.1.r4178.g628de5608-123.08.1.r4183.g0c24996b4-1
                           pimcommon23.08.5.r2341.g0e1f4c2d-123.08.5.r2343.g7bde8d58-1
                       plasma-camera  1.0.r237.ga972ea0-1  1.0.r238.gc183b28-1
                     plasma-firewall5.27.10.r877.g0bb4426-15.27.10.r880.g1f6bf95-1
                     plasma-settings23.08.1.r1378.gffc96a1-123.08.1.r1381.gf0c24b1-1
                  plasma-thunderbolt5.27.10.r334.gb204d86-15.27.10.r335.gc4ff615-1
                                sddm0.19.0.r262.g63780fcd-10.19.0.r273.gcc03fabf-1
                            spacebar23.08.1.r882.ga4231c0-123.08.1.r884.g9ea6caa-1
                         vakzination23.08.1.r405.gdbdc46b-123.08.1.r406.gd456830-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2024-02-28           2024-03-01
-------------------------------------------------------------------------------
               lib32-glib-networking           1:2.78.0-1           1:2.78.1-1
                           lib32-orc             0.4.37-1             0.4.38-1
                         lib32-pango           1:1.51.2-1           1:1.52.0-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:

2 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2024-03-01

2024-02-23

gnome-keyring: ssh component is not included

ssh component is not included (#3) · Issues · Arch Linux / Packaging / Packages / gnome-keyring · GitLab

2024-01-25

polkit update might remove your local modified config

With polkit 124-1 there were changes made to etc/pam.d/polkit-1. So check if you made local changes to the file. See also: ropid comments on Today's update moved polkit-1 to polkit-1.pacsave without providing a new config

bashrc-manjaro is now merged into bash

Yes, replace bashrc-manjaro with bash

pacman and pacman-contrib changes

pacman-contrib is now split out from pacman. If you have anything installed that depends on pacman-contrib, update with:

sudo pacman -Syu pacman-contrib

2024-01-11

Making dbus-broker our default D-Bus daemon

2024-01-09 - Jan Alexander Steffens

We are making dbus-broker our default implementation of D-Bus, for improved performance, reliability and integration with systemd.

For the foreseeable future we will still support the use of dbus-daemon, the previous implementation. Pacman will ask you whether to install dbus-broker-units or dbus-daemon-units. We recommend picking the default.

For a more detailed rationale, please see our RFC 25.

Arch Linux - News: Making dbus-broker our default D-Bus daemon

2023-11-10

Nvidia 545 drivers might have issues

:information_source: Due to various issues including non working backlights on some machines, the NVIDIA 545 series feature branch drivers have been downgraded to the 535 series production branch drivers.

If you are having no issues with the 545 series, there is nothing to do. If you are, you can downgrade to the 535 series with pamac update --enable-downgrade or sudo pacman -Syuu.

So far we know about these issues the Nvidia 545 driver series has:

If you experience similar or new issues please run sudo usr/bin/nvidia-bug-report.sh and post either in an already given post or create a new one, including your generated nvidia-bug-report.log.gz for Nvidia to fix the issue: Linux - NVIDIA Developer Forums

Changes in JDK / JRE 21 packages may require manual intervention

2023-11-02 - Frederik Schwan

We are introducing a change in JDK/JRE packages of our distro. This is triggered from the way a JRE is build in modern versions of Java (>9). We are introducing this change in Java 21.

To sum it up instead of having JDK and JRE packages coexist in the same system we will be making them conflict. The JDK variant package includes the runtime environment to execute Java applications so if one needs compilation and runtime of Java they need only the JDK package in the future. If, on the other hand, they need just runtime of Java then JRE (or jre-headless) will work.

This will (potentially) require a manual user action during upgrade:

  • If you have both JDK and JRE installed you can manually install the JDK with pacman -Sy jdk-openjdk && pacman -Su and this removes the JRE related packages.
  • If you have both JRE and JRE-headless you will need to choose one of them and install it manually since they would conflict each other now.
  • If you only have one of the JDK/JRE/JRE-headless pacman should resolve dependencies normally and no action is needed.

At the moment this is only valid for the upcoming JDK 21 release.

Arch Linux - News: Incoming changes in JDK / JRE 21 packages may require manual intervention

Previous testing threads:

Anybody else lose audio after the update? Might be something unrelated tho, I’ll update here if I figure out whats up.

edit: nevermind, for some reason I had to unplug my headphones and then plug them back in to get the audio working. I guess after update it was just somehow unaware that headphones were plugged in or something odd like that.

i had to downgrade networkmanager-l2tp back to 1.20.10-1 for my work vpn to connect. was there an associated update to networkmanager, networkmanager-strongswan, or strongswan that may have been missed?

I got this message in the post-transaction hooks:

( 1/15) Creating system user accounts...
( 2/15) Reloading system manager configuration...
( 3/15) Reloading user manager configuration...
( 4/15) Updating udev hardware database...
( 5/15) Creating temporary files...
( 6/15) Reloading device manager configuration...
( 7/15) Arming ConditionNeedsUpdate...
( 8/15) Updating TeXLive filename database...
( 9/15) Updating GIO module cache...
(10/15) Updating 32-bit GIO module cache...
ERROR: ld.so: object '/usr/lib/libinput-config.so' from /etc/ld.so.preload cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
(11/15) Compiling GSettings XML schema files...
(12/15) Updating icon theme caches...
(13/15) Looking for Pacnew/Pacsave created.
(14/15) Updating the info directory file...
(15/15) Updating the desktop file MIME type cache...

The upgrade didn’t fail, but I’m not sure what’s the source of the issue.