[Testing Update] 2024-05-08 - Kernels, InputPlumber, LibPamac, Mhwd-DB, LibreOffice, LxQt 2.0, VirtualBox

Hello community, here we have another set of package updates.

Current Promotions

  • Find out all about our current Gaming Laptop the Hero with Manjaro pre-installed from Spain!
  • Protect your personal data, keep yourself safe with Surfshark VPN: 85% OFF + 2 mo. FREE

Recent News

Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates

  • Most Kernels got renewed
    • Firmware got renewed
  • glibc got fixes added to support Nvidia drivers better on Steam
  • inputplumber gained many fixes. can now be combined with opengamepadui-git
  • libpamac gained support to use libalpm internal download engine for downloading files
  • mhwd-db fixed issues in Nvidia and FOSS drivers
  • more updates to Gnome 46.1 packages
  • LibreOffice got renewed to 24.2.3
  • LxQt 2.0.0 gained Qt6 support
  • Thunderbird got renewed to 115.10.2
  • VirtualBox is now at 7.0.18
  • Wine is updated to 9.8
  • various Python and Haskell package updates and fixes

A list of all package changes can be found here

Additional Info

Python 3.12 info

:information_source: You will need to rebuild any AUR Python packages that install files to site-packages or link to libpython3.11.so. :information_source:

Print a list of of packages that have files in /usr/lib/python3.11/ :

pacman -Qoq /usr/lib/python3.11/

Rebuild them all at once:*

pamac build $(pacman -Qoq /usr/lib/python3.11)

* Note that if any fail to build, you’ll have to rebuild what’s remaining one or a few at a time.

Use rebuild-detector to see if anything else needs to be rebuilt:

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcements topics are off-topic and will be flagged, moved or removed without warning.

For help with AUR packages, please create a new topic in AUR and a helpful volunteer may be able to assist you.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.313
  • linux54 5.4.275
  • linux510 5.10.216
  • linux515 5.15.158
  • linux61 6.1.90
  • linux66 6.6.30
  • linux68 6.8.9
  • linux69 6.9.0-rc7
  • linux61-rt 6.1.83_rt28
  • linux66-rt 6.6.23_rt28
  • linux67-rt 6.7_rt6

Package Changes (Tue May 7 14:51:30 CEST 2024)

  • testing core x86_64: 22 new and 23 removed package(s)
  • testing multilib x86_64: 28 new and 28 removed package(s)
  • testing extra x86_64: 1070 new and 1058 removed package(s)

Overlay Package Changes

  • testing core x86_64: 26 new and 35 removed package(s)
  • testing extra x86_64: 123 new and 129 removed package(s)

A list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:

1 Like

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2024-05-08

Qemu: MacOS is not bootable with 9.0

Due to a bug MacOS is not bootable with 9.0: [9.0.0] qemu breaks mac os vm (#2334) · Issues · QEMU / QEMU · GitLab
Workaround: remove virtio-serial and org.qemu.guest_agent.0 from libvirt XML until bug will be fixed.


The default KDE Plasma session has been changed to X11

As of Plasma 6, KDE decided to make Wayland the default. However, since issues were discovered, we have reverted the default to X11. Users are free to choose whichever works best for them.


Konsole font rendering issue

if you use manjaro-zsh-config on Plasma 6,
please check your Font settings in Konsole:

Konsole: Open Settings → Edit Current Profile → Appearance,
click Select Font and select MesloLGS NF Regular.


Plasma 6 issues with Manjaro themes & tools

Prepare for a Plasma 6 release (#2) · Issues · Release plan / KDE · GitLab

DKMS fails for v4l2loopback on 6.8 kernel

DKMS fails for v4l2loopback on 6.8 kernel (#2) · Issues · Arch Linux / Packaging / Packages / v4l2loopback · GitLab

New version of kvantum does not support QT5 theme

Install new package kvantum-qt5 for QT5 theme support
required for manjaro-settings-manager and audacious

pamac install kvantum-qt5

If Theme shows wrong colors:

cd $HOME; ln -s .profile .xprofile

Manjaro-settings-manager has light theme instead of dark

issues with auto-mount of ntfs filesystem using Kernel 6.8

The kernel changed default ntfs driver from FUSE one to ntfs3.
These two are not fully compatible, mainly as far as mount options go. If you have custom mount options in the fstab (or any other application, such as VeraCrypt) they need to be changed.

Mount fails with: Device or resource busy
DMesg reports: Can't open blockdev

Migrate your mount options. For me the changes were:

  • allow_otherumask=000
  • default_permissions → [drop]
  • user_id=1000uid=1000
  • group_id=1000gid=1000


gnome-keyring: ssh component is not included

ssh component is not included (#3) · Issues · Arch Linux / Packaging / Packages / gnome-keyring · GitLab

Previous testing threads:


The problem with FZF (ctrl + r) that caused the screen display to break was finally resolved.

fzf --version 0.51.0 (260a65b0)
I’ve been downgrading for several months.

sudo pacman -U https://archive.archlinux.org/packages/f/fzf/fzf%2D0.45.0%2D1%2Dx86_64.pkg.tar.zst

1 Like

Issue with pcmanfm-qt but not pcmanfm accessing file in a popup terminal.

  • Hyprland

Trying to open a file (e.g. text/mardown file).
pcmanfm open the file but pcmanfm-qt doesn’t:

  • Popup message
Valid key file could not be found in search dirs
  • Console message
nvim '/home/steph/Perso/CarJaune.md' 

(process:3387233): GLib-CRITICAL **: 09:23:55.063: unquote_string_inplace: assertion 'err == NULL || *err == NULL' failed

Appears to be relative to opening the terminal (kitty). Error with nvim and glow but file is opened with typora or meld.

Ran into this:

Solution: Manually changed the permissions in line with the package

So far no issues, I do not use the software tpm as far as I can tell.

Kernel Updates for 6.6 and 6.8 broke gaming while not running an UEFI-Installation (missing BAR support) :frowning:

Issue: Bisected: Games crash on 6.9rc-5+/6.8.9+/6.6.30+ if above 4g decoding/resize bar is disabled or not supported (#3343) · Issues · drm / amd · GitLab

A fix seems already underway. Until then keep older kernel version or downgrade, e.g. 6.6.21-1 is working fine.


After switching to Manjaro Testing, the app icons running under wine or java do not have an icon.
It seems that any app that does not have an entry in the menu does not have an icon.

1 Like

I’m unsure of the cause, but after doing a pamac upgrade, I’m having trouble with AppImages working - nothing is displayed in the window that’s opened, but you can still navigate the application like it’s being rendered, and the application itself is still functioning. This only seems to be a problem on my laptop (Ryzen 5 4500U with Radeon RX Vega 6) vs my desktop (i5-13500 with Intel Arc A750). I’ve dug around but haven’t found any logging to indicate what’s happening. Willing to provide more info if needed but I’m not sure where to look.

The two applications I’ve run into so far that are having trouble are Beeper and RadarOmega

[edit] I cleared the GPUCache directory for each application (in ~/.config/<application name> and that seemed to fix it.


Mac Os vm is not able to boot with qemu 9.0.0-1.
I opened an issue here and a workaround was posted, until the bug is solved:

1 Like

The thing I noticed on Xfce, my icon theme got altered. Couldn’t change it back.

1 Like
Total Download Size:    729.12 MiB
Total Installed Size:  1529.20 MiB
Net Upgrade Size:      -352.67 MiB

Interesting, I wonder what that was…

1 Like

Mostly linux-firmware package.


@angrytux can you confirm 6.6.30-2 and 6.8.9-2 fixes that issue for you?

1 Like

One problematic game starts without problem. Wasn´t the case before after the kernel update. Will tell if any new strange things occur :slight_smile:
Did you include the patch already or revert the last update? Looking at the issue on gitlab it shouldn´t be upstream yet.

I’ve experienced similar behavior as @angrytux and reverted to linux61 and that was a workaround for me in one case. With 6.8.9-2 this behavior does not manifest itself so far, however I cannot reliably trigger it, I experienced random crashes that do not happen anymore.

All issues with AUR/python were resolved using your instructions. Thanks!

1 Like

6 posts were split to a new topic: I think switching branches wiki needs an improvement

Looks like the DMABUF renderer is broken in webkitgtk with the proprietary nvidia driver. Because of this I got a blank screen on the Manjaro Starter application.

The solution in the link below fixes issue for me.

[bug] app window fails under Linux with Nvidia gpu · Issue #9304 · tauri-apps/tauri · GitHub

Yup, as I thought, it’s an issue with webkit2gtk being broken under 2.44 with Nvidia GPUs https://gitlab.archlinux.org/archlinux/packaging/packages/webkit2gtk/-/issues/1

For your local dev environment, you can add WEBKIT_DISABLE_DMABUF_RENDERER=1 in /etc/environment for the time beeing.


I believe this issue is related to this update.

Failed to load firmware “amdgpu/green_sardine_sdma.bin”

no issue except the computer suddenly logged in with xorg session. I did not see a pacnew related to this so it was a bit surprising and caused glitching and flickering as the display output changed from console mode to wayland mode to xorg mode.