[Testing Update] 2024-03-23 - Pacman 6.1, KDE Gear, Nvidia, Gstreamer, AMD ROCm

Hello community,

here we have another set of package updates. This brings the latest pacman 6.1, KDE Gear updates and many more!

Current promotions

  • image

    We currently have a flashsale with our partner MINISFORUM on the UM790Pro featuring the Manjaro Linux GamingEdition. Use the device either as a MiniPC or Gaming Console! Use our link to get yours. Note: US Market only!

  • Find out all about our current Gaming Laptop the Hero with Manjaro pre-installed from Spain!

  • Protect your personal data, keep yourself safe with Surfshark VPN: 79% OFF + 2 mo. FREE

Recent News

Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates

  • pacman got updated to 6.1.0
    • all packages got updated, including libpamac. However there seems to be an issue which may freeze the UI of Pamac
  • Firefox is at 124.0.1 and Thunderbird at 115.9.0
  • KDE Gear 24.02.1 got released
  • Nvidia driver got renewed to 550.67
  • Gstreamer is at 1.24.1
  • Qt5 got updated to 5.15.13
  • AMD ROCm got renewed to 6.0.2
  • Wireplumber is at 0.5.0
  • Updates to Deepin, Haskell and Python

Breaking changes

Mkinitcpio: --microcode has been deprecated and replaced by the new microcode hook for early loading microcode files.

mkinitcpio hook migration and early microcode

2024-03-04 - Morten Linderud

With the release of mkinitcpio v38, several hooks previously provided by Arch packages have been moved to the mkinitcpio upstream project. The hooks are: systemd, udev, encrypt, sd-encrypt, lvm2 and mdadm_udev.

To ensure no breakage of users’ setup occurs, temporary conflicts have been introduced into the respective packages to prevent installing packages that are no longer compatible.

The following packages needs to be upgraded together:

  • mkinitcpio 38-2
  • systemd 255.4-2
  • lvm2 2.03.23-3
  • mdadm 4.3-2
  • cryptsetup 2.7.0-3

Please note that the mkinitcpio flag --microcode, and the microcode option in the preset files, has been deprecated in favour of a new microcode hook. This also allows you to drop the microcode initrd lines from your boot configuration as they are now packed together with the main initramfs image.

Arch Linux - News: mkinitcpio hook migration and early microcode

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcements topics are off-topic and will be flagged, moved or removed without warning.

For help with AUR packages, please create a new topic in AUR and a helpful volunteer may be able to assist you.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.310
  • linux54 5.4.272
  • linux510 5.10.213
  • linux515 5.15.152
  • linux61 6.1.82
  • linux66 6.6.22
  • linux67 6.7.10
  • linux68 6.8.1
  • linux61-rt 6.1.77_rt24
  • linux66-rt 6.6.21_rt26
  • linux67-rt 6.7_rt6

Package Changes (Sat Mar 23 02:15:57 CET 2024)

  • testing core x86_64: 31 new and 31 removed package(s)
  • testing extra x86_64: 1421 new and 1697 removed package(s)
  • testing multilib x86_64: 27 new and 26 removed package(s)

A list of package Changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:

1 Like

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2024-03-23

Konsole font rendering issue

if you use manjaro-zsh-config on Plasma 6,
please check your Font settings in Konsole:

Konsole: Open Settings → Edit Current Profile → Appearance,
click Select Font and select MesloLGS NF Regular.


Plasma 6 issues with Manjaro themes & tools

Prepare for a Plasma 6 release (#2) · Issues · Release plan / KDE · GitLab

DKMS fails for v4l2loopback on 6.8 kernel

DKMS fails for v4l2loopback on 6.8 kernel (#2) · Issues · Arch Linux / Packaging / Packages / v4l2loopback · GitLab

New version of kvantum does not support QT5 theme

Install new package kvantum-qt5 for QT5 theme support
required for manjaro-settings-manager and audacious

pamac install kvantum-qt5

If Theme shows wrong colors:

cd $HOME; ln -s .profile .xprofile

Manjaro-settings-manager has light theme instead of dark


gnome-keyring: ssh component is not included

ssh component is not included (#3) · Issues · Arch Linux / Packaging / Packages / gnome-keyring · GitLab


polkit update might remove your local modified config

With polkit 124-1 there were changes made to etc/pam.d/polkit-1. So check if you made local changes to the file. See also: https://old.reddit.com/r/archlinux/comments/19bnj0i/todays_update_moved_polkit1_to_polkit1pacsave/kit2v33/

bashrc-manjaro is now merged into bash

Yes, replace bashrc-manjaro with bash

pacman and pacman-contrib changes

pacman-contrib is now split out from pacman. If you have anything installed that depends on pacman-contrib, update with:

sudo pacman -Syu pacman-contrib


Making dbus-broker our default D-Bus daemon

2024-01-09 - Jan Alexander Steffens

We are making dbus-broker our default implementation of D-Bus, for improved performance, reliability and integration with systemd.

For the foreseeable future we will still support the use of dbus-daemon, the previous implementation. Pacman will ask you whether to install dbus-broker-units or dbus-daemon-units. We recommend picking the default.

For a more detailed rationale, please see our RFC 25.

Arch Linux - News: Making dbus-broker our default D-Bus daemon

Previous testing threads:

2 posts were split to a new topic: Pacnew-chaser question

can we have more info about this

Nouvelles dépendances optionnelles pour grub
    install-grub: Script to install Grub after package updates

pacman -Si install-grub
Dépôt                    : core
Nom                      : install-grub
Version                  : 2.12-4
Description              : GNU Grub (2) Install Script on Updates
Architecture             : x86_64
URL                      : https://www.gnu.org/software/grub/
Licences                 : GPL-3.0-or-later
Groupes                  : --
Fournit                  : --
Dépend de                : coreutils  efibootmgr  gawk  grep  grub
Dépendances opt.         : --
Est en conflit avec      : --
Remplace                 : --
Taille du téléchargement : 5,22 KiB
Taille installée         : 6,77 KiB
Paqueteur                : Mark Wagie <mark@manjaro.org>
Compilé le               : dim. 17 mars 2024 18:22:08
Validé par               : Somme MD5  Somme SHA-256  Signature

last check for suspend screen & login xfce & nvidia :
failed , still black screen with mouse cursor appear

switched yesterday night to testing, plasma6, ext4, x11
this morning veracrypt deed not open my old truecrypt volume
deed today update and is the same, in options there is not anymore for selection of truecrypt volume

Operation failed due to one or more of the following:
 - Incorrect password.
 - Incorrect Volume PIM number.
 - Incorrect PRF (hash).
 - Not a valid volume.

password is not changed, always the old one

I found a little issue on konsole: before upgrading to plasma 6 (and konsole to version 24.02.0-1) I took the following screenshot:

Look at the theme, because now it’s like the following screenshot:

So, searching in the pacman log I see a zsh upgrade (done within the plasma6 one), then I tried to downgrade the zsh package, but the theme was the same.
So my suspects fallen to konsole, after downgraded it to version 23.08.5-1 the zsh theme is like it was before upgrading to plasma 6, like in the first screenshot.

Pamac issue solved.

Install a nerd-ttf-fonts of your choice, set it in your profile of Konsole.

For more information about install-grub see:
Install-grub: a new way to keep your EFI/MBR in-sync with grub package
[root tip] [How To] Primer on handling a grub package update



Wiki post:

1 Like

@notageek Veracrypt version 1.26.7 removed the option to run truecrypt mode.
Please see official changelog: https://launchpadlibrarian.net/689937121/README.TXT

  • Remove TrueCrypt Mode support. Version 1.25.9 can be used to mount or convert TrueCrypt volumes.
1 Like

@philm i still do not get one thing about the mkinit hook

  1. We add the hook to mkinitcpio.conf
  2. do we actively delete/comment out the line ALL_microcode=(/boot/*-ucode.img) in the presets?
  3. do we do smth else? Like in grub?

Thanks I’ve reverted back to stable and deed the operation, now I will go back to testing… :smile:

Problems with auto-mount/VeraCrypt NTFS volumes using Kernel 6.8:
The kernel changed default ntfs driver from FUSE one to ntfs3.
These two are not fully compatible, mainly as far as mount options go. If you have custom mount options in the fstab (or any other application, such as VeraCrypt) they need to be changed.

Mount fails with: Device or resource busy
DMesg reports: Can't open blockdev

Migrate your mount options. For me the changes were:

  • allow_otherumask=000
  • default_permissions → [drop]
  • user_id=1000uid=1000
  • group_id=1000gid=1000
1 Like


The advice appears to be: add to /etc/default/grub

1 Like

ktorrent has problems since KDE Gear 24.02.1. It will not run. A re-install did not change that.

qt.dbus.integration: Could not connect "org.freedesktop.NetworkManager" to "stateChanged" : Type not registered with QtDBus in parameter list: QNetworkManagerInterface::NMState
qt.dbus.integration: Could not connect "org.freedesktop.NetworkManager" to "connectivityChanged" : Type not registered with QtDBus in parameter list: QNetworkManagerInterface::NMConnectivityState
qt.dbus.integration: Could not connect "org.freedesktop.NetworkManager" to "deviceTypeChanged" : Type not registered with QtDBus in parameter list: QNetworkManagerInterface::NMDeviceType
qt.dbus.integration: Could not connect "org.freedesktop.NetworkManager" to "meteredChanged" : Type not registered with QtDBus in parameter list: QNetworkManagerInterface::NMMetered
kf.coreaddons: "Could not load plugin from /usr/lib/qt6/plugins/ktorrent_plugins/StatsPlugin.so: Cannot load library /usr/lib/qt6/plugins/ktorrent_plugins/StatsPlugin.so: (libKF6Plotting.so.6: cannot open shared object file: No such file or directory)"
QLayout: Attempting to add QLayout "" to kt::FileView "", which already has a layout
kf.coreaddons: "Could not load plugin from /usr/lib/qt6/plugins/ktorrent_plugins/StatsPlugin.so: Cannot load library /usr/lib/qt6/plugins/ktorrent_plugins/StatsPlugin.so: (libKF6Plotting.so.6: cannot open shared object file: No such file or directory)"
zsh: segmentation fault (core dumped)  ktorrent

edit: installed the missing kplotting package. ktorrent still did not run. removed .config/ktorrentrc and now it does start. But only once!

Am I the only one having an error message when SDDM is being initialized?
The error message is: “Configuration file ‘’/var/lib/sddm/.config/sddm-greeter-qt6rc’’ not writable. Please contact your system administrator.”

Not a very warm welcome. I didn’t have this message at first when KDE6 was released a few days ago. Pretty curious that it comes up suddenly.

EDIT: Found this old thread. It doesn’t explain the difference between now vs last update, but at least it will most likely fix the issue, as indeed, somehow .config directory is owned by root and not sddm for some reasons. Configuration file "/var/lib/sddm/.config/sddm-greeterrc" not writable - #4 by cscs :person_shrugging:

EDIT 2: OK so I dunno what the f- I did, but I had a custom theme for SDDM installed somehow, a Windows 9x style theme called Reactionary. I have no clue where it comes from, I guess I was drunk when I did it or whatever. I uninstalled it and I click on “Apply Plasma settings on SDDM” too and it fixed it. Hum whatever.

@notageek No need to go back to stable next time. Do use downgrade or manjaro-downgrade.

pamac install manjaro-downgrade
manjaro-downgrade veracrypt


pamac install downgrade
sudo downgrade veracrypt

On stable it’s normally restricted as it’s only a temporary solution and needs DOWNGRADE_FROM_ALA=1
Please see wiki: Downgrading packages - Manjaro


I explain that in this video/post: [Testing Update] 2024-03-16 - Kernel, Calamares, Mesa, Plasma 6, KF 6, KDE Gear 24.04, LibreOffice - #87 by zar0nick

That is only the first step as we now know there are 3 steps (hooks, presets, grub)