[Testing Update] 2024-03-16 - Kernel, Calamares, Mesa, Plasma 6, KF 6, KDE Gear 24.04, LibreOffice

Hello community,

here we have another set of package updates!

Current promotions

  • image

    We currently have a flashsale with our partner MINISFORUM on the UM790Pro featuring the Manjaro Linux GamingEdition. Use the device either as a MiniPC or Gaming Console! Use our link to get yours. Note: US Market only!

  • Find out all about our current Gaming Laptop the Hero with Manjaro pre-installed from Spain!

  • Protect your personal data, keep yourself safe with Surfshark VPN: 79% OFF + 2 mo. FREE

Recent News

Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates

  • Kernel updates
    • including linux-firmware updates
  • OrangePi Neo related updates:
    • HHD 2.1.1, HHD-UI 2.0.2, Adjustor 2.0.0 - including GDF-G2102_F03D_V1.0_240314b MCU firmware support
    • HandyGCCS supports now GDF-G2102_F03D_V1.0_240314b MCU firmware
  • Calamares 3.3.5
  • Mesa 24.0.3
  • Firefox 123.0.1
  • Thunderbird 115.8.1
  • :kde: KDE MegaRelease 6 + Plasma 6.0.2
  • LibreOffice 24.2.1
  • GStreamer 1.24
  • Phosh 0.37.0
  • Pipewire 1.0.4
  • Mkinitcpio 38
  • Updates to Haskell and Python

Breaking changes

Mkinitcpio: --microcode has been deprecated and replaced by the new microcode hook for early loading microcode files.

mkinitcpio hook migration and early microcode

2024-03-04 - Morten Linderud

With the release of mkinitcpio v38, several hooks previously provided by Arch packages have been moved to the mkinitcpio upstream project. The hooks are: systemd, udev, encrypt, sd-encrypt, lvm2 and mdadm_udev.

To ensure no breakage of users’ setup occurs, temporary conflicts have been introduced into the respective packages to prevent installing packages that are no longer compatible.

The following packages needs to be upgraded together:

  • mkinitcpio 38-2
  • systemd 255.4-2
  • lvm2 2.03.23-3
  • mdadm 4.3-2
  • cryptsetup 2.7.0-3

Please note that the mkinitcpio flag --microcode, and the microcode option in the preset files, has been deprecated in favour of a new microcode hook. This also allows you to drop the microcode initrd lines from your boot configuration as they are now packed together with the main initramfs image.

Arch Linux - News: mkinitcpio hook migration and early microcode

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcements topics are off-topic and will be flagged, moved or removed without warning.

For help with AUR packages, please create a new topic in AUR and a helpful volunteer may be able to assist you.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.310
  • linux54 5.4.272
  • linux510 5.10.213
  • linux515 5.15.152
  • linux61 6.1.82
  • linux66 6.6.22
  • linux67 6.7.10
  • linux68 6.8.1
  • linux61-rt 6.1.77_rt24
  • linux66-rt 6.6.21_rt26
  • linux67-rt 6.7_rt6

Package Changes (Wed Mar 15 2024 12:30:48 GMT)

Overlay Packages

  • testing core x86_64: 34 new and 38 removed package(s)
  • testing extra x86_64: 177 new and 306 removed package(s)
  • testing multilib x86_64: 11 new and 11 removed package(s)

Sync Packages

  • testing multilib x86_64: 38 new and 38 removed package(s)
  • testing extra x86_64: 2667 new and 2515 removed package(s)

A list of package Changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2024-03-16

Plasma 6 issues with Manjaro themes & tools

Prepare for a Plasma 6 release (#2) · Issues · Release plan / KDE · GitLab

DKMS fails for v4l2loopback on 6.8 kernel

DKMS fails for v4l2loopback on 6.8 kernel (#2) · Issues · Arch Linux / Packaging / Packages / v4l2loopback · GitLab

New version of kvantum does not support QT5 theme

Install new package kvantum-qt5 for QT5 theme support
required for manjaro-settings-manager and audacious

pamac install kvantum-qt5

If Theme shows wrong colors:

cd $HOME; ln -s .profile .xprofile

Manjaro-settings-manager has light theme instead of dark


gnome-keyring: ssh component is not included

ssh component is not included (#3) · Issues · Arch Linux / Packaging / Packages / gnome-keyring · GitLab


polkit update might remove your local modified config

With polkit 124-1 there were changes made to etc/pam.d/polkit-1. So check if you made local changes to the file. See also: https://old.reddit.com/r/archlinux/comments/19bnj0i/todays_update_moved_polkit1_to_polkit1pacsave/kit2v33/

bashrc-manjaro is now merged into bash

Yes, replace bashrc-manjaro with bash

pacman and pacman-contrib changes

pacman-contrib is now split out from pacman. If you have anything installed that depends on pacman-contrib, update with:

sudo pacman -Syu pacman-contrib


Making dbus-broker our default D-Bus daemon

2024-01-09 - Jan Alexander Steffens

We are making dbus-broker our default implementation of D-Bus, for improved performance, reliability and integration with systemd.

For the foreseeable future we will still support the use of dbus-daemon, the previous implementation. Pacman will ask you whether to install dbus-broker-units or dbus-daemon-units. We recommend picking the default.

For a more detailed rationale, please see our RFC 25.

Arch Linux - News: Making dbus-broker our default D-Bus daemon


Nvidia 545 drivers might have issues

:information_source: Due to various issues including non working backlights on some machines, the NVIDIA 545 series feature branch drivers have been downgraded to the 535 series production branch drivers.

If you are having no issues with the 545 series, there is nothing to do. If you are, you can downgrade to the 535 series with pamac update --enable-downgrade or sudo pacman -Syuu.

So far we know about these issues the Nvidia 545 driver series has:

If you experience similar or new issues please run sudo usr/bin/nvidia-bug-report.sh and post either in an already given post or create a new one, including your generated nvidia-bug-report.log.gz for Nvidia to fix the issue: Linux - NVIDIA Developer Forums

Changes in JDK / JRE 21 packages may require manual intervention

2023-11-02 - Frederik Schwan

We are introducing a change in JDK/JRE packages of our distro. This is triggered from the way a JRE is build in modern versions of Java (>9). We are introducing this change in Java 21.

To sum it up instead of having JDK and JRE packages coexist in the same system we will be making them conflict. The JDK variant package includes the runtime environment to execute Java applications so if one needs compilation and runtime of Java they need only the JDK package in the future. If, on the other hand, they need just runtime of Java then JRE (or jre-headless) will work.

This will (potentially) require a manual user action during upgrade:

  • If you have both JDK and JRE installed you can manually install the JDK with pacman -Sy jdk-openjdk && pacman -Su and this removes the JRE related packages.
  • If you have both JRE and JRE-headless you will need to choose one of them and install it manually since they would conflict each other now.
  • If you only have one of the JDK/JRE/JRE-headless pacman should resolve dependencies normally and no action is needed.

At the moment this is only valid for the upcoming JDK 21 release.

Arch Linux - News: Incoming changes in JDK / JRE 21 packages may require manual intervention

Previous testing threads:

1 Like

Whatever update is being released, I’m being met with this error in pamac;

conflicting dependencies:
- breeze5 and breeze are in conflict (breeze<5.27.80)

NOTE: PLEASE SEE philm’s post; “…don’t update yet.”

The github snippet is showing package versions from stable instead of previous versions from testing update 2024-03-08

Some incompatible widgets, but that was to be expected.

1 Like

Updated, and have to change SDDM theme. It’s OK. LatteDoc doesn’t load, it’s OK. But what happened to the possibility to view and change kernels? I cannot see it in System Settings menu anymore! And no opportunity to watch SystemD processes, timers (if needed). Why?

1 Like

But what happened to the possibility to view and change kernels? I cannot see it in System Settings menu anymore! And no opportunity to watch SystemD processes, timers (if needed). Why?

Some legacy KCMs are based on QtWidgets, however this is not recommended for new KCMs and it’s not possible to load these in plasma-settings .

for your information

New version of kvantum does not support QT5 theme for manjaro-settings-manager and audacious

Install new package kvantum-qt5 for QT5 theme support

pamac install kvantum-qt5

Manjaro-settings-manager has light theme instead of dark


First of all thank you for your work, guys.

I have few problems and decided to revert back to KDE5.

  1. Wayland is choppy. It is expected with my nvidia, so i had to use X (Any chance to make it work btw?).
  2. Missing icons at bottom right corner for network and everything else(sound, clipboard, etc) with BreezeTwilight theme.

I guess ill wait for a week or so before going to KDE6.


So, what was unique for Manjaro (the possibility to choose kernels from a list and change them) just disappeared. Sad.

However, you can continue to use manjaro-settings-manager alone. :joy:


I have an issue with service menus in KDE Plasma 6, they seem to show all entries instead of respecting what is configured/ticked in Dolphin Settings, for example I updated kf5-servicemenus-rootactions to kf6-servicemenus-rootactions, and it shows all possible actions even when I select none in Dolphin Settings. It does the same with other service menus it shows all entries.


Thanks a lot.

Users can also continue to use mhwd-kernel to manage kernels on any DE


After the update the “Date” column in KMail shows nothing at all.
This happens with any “Theme” (from View->Message List->Theme).
Tried on two different installations, same behaviour.

Upstream bug: 483782 – Kmail Message list does not show anything in "Date" column

1 Like

Shall I add to known issues that the mouse cursor (breeze white theme) disappears after the plasma 6 update?

  • Maybe it will appear again after restart? I haven’t tested.
  • Maybe there is another workround?

The Breeze cursor theme name changed from Breeze_Snow to Breeze_Light as far as I noticed.

Maybe. :wink:

Terrible mouse lags and one panel kept flashing and could not turn it off.

I had to roll back the update with Timeshift. Back to 5.27.11.

I switched to stable branch and added

IgnoreGroup = plasma to pacman.conf

Okay… Please create a new Support thread and provide more details. You’ve been around long enough to know the routine.

How are you going to find out what the problem was now?

That will put you in an unsupported, partial upgrade state once Plasma 6 hits the stable branch.

1 Like

I saw some regular, noticeable screen flashing and the only thing that made it go away (for me) was to set Adaptive Sync to ‘Never’ in KDE System Settings

My monitor supports Adaptive Sync, and it’s enabled on the monitor but I had to disable it via KDE—it was also making controlling my mouse impossible in games.

EDIT: I double checked, I had to disable the monitor setting as that was causing the mouse control problem.

EDIT 2: After enabling HDR I had to follow the original settings before the first edit; HDR on, Adaptive Sync enabled in monitor, ‘Never’ in KDE settings

7900XTX via DisplayPort, FWIW

1 Like