[Testing Update] 2024-02-23 - KDE Gear, Mesa, Qt, LibreOffice

Hello community,

here we have another set of package updates!

Current promotions

  • image

    We currently have a flashsale with our partner MINISFORUM on the UM790Pro featuring the Manjaro Linux GamingEdition. Use the device either as a MiniPC or Gaming Console! Use our link to get yours. Note: US Market only!

  • Protect your personal data, keep yourself safe with Surfshark VPN: 79% off + 2 mo. FREE

Recent News

Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog

image

Notable Package Updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcements topics are off-topic and will be flagged, moved or removed without warning.

For help with AUR packages, please create a new topic in AUR and a helpful volunteer may be able to assist you.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.


Our current supported kernels

  • linux419 4.19.307
  • linux54 5.4.268
  • linux510 5.10.209
  • linux515 5.15.148
  • linux61 6.1.79
  • linux66 6.6.18
  • linux67 6.7.6
  • linux68 6.8.0-rc5
  • linux61-rt 6.1.77_rt24
  • linux66-rt 6.6.15_rt22
  • linux67-rt 6.7_rt6

Package Changes

A list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:

4 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2024-02-23

gnome-keyring: ssh component is not included

ssh component is not included (#3) · Issues · Arch Linux / Packaging / Packages / gnome-keyring · GitLab

2024-01-25

polkit update might remove your local modified config

With polkit 124-1 there were changes made to etc/pam.d/polkit-1. So check if you made local changes to the file. See also: ropid comments on Today's update moved polkit-1 to polkit-1.pacsave without providing a new config

bashrc-manjaro is now merged into bash

Yes, replace bashrc-manjaro with bash

pacman and pacman-contrib changes

pacman-contrib is now split out from pacman. If you have anything installed that depends on pacman-contrib, update with:

sudo pacman -Syu pacman-contrib

2024-01-11

Making dbus-broker our default D-Bus daemon

2024-01-09 - Jan Alexander Steffens

We are making dbus-broker our default implementation of D-Bus, for improved performance, reliability and integration with systemd.

For the foreseeable future we will still support the use of dbus-daemon, the previous implementation. Pacman will ask you whether to install dbus-broker-units or dbus-daemon-units. We recommend picking the default.

For a more detailed rationale, please see our RFC 25.

Arch Linux - News: Making dbus-broker our default D-Bus daemon

2023-11-10

Nvidia 545 drivers might have issues

:information_source: Due to various issues including non working backlights on some machines, the NVIDIA 545 series feature branch drivers have been downgraded to the 535 series production branch drivers.

If you are having no issues with the 545 series, there is nothing to do. If you are, you can downgrade to the 535 series with pamac update --enable-downgrade or sudo pacman -Syuu.

So far we know about these issues the Nvidia 545 driver series has:

If you experience similar or new issues please run sudo usr/bin/nvidia-bug-report.sh and post either in an already given post or create a new one, including your generated nvidia-bug-report.log.gz for Nvidia to fix the issue: Linux - NVIDIA Developer Forums

Changes in JDK / JRE 21 packages may require manual intervention

2023-11-02 - Frederik Schwan

We are introducing a change in JDK/JRE packages of our distro. This is triggered from the way a JRE is build in modern versions of Java (>9). We are introducing this change in Java 21.

To sum it up instead of having JDK and JRE packages coexist in the same system we will be making them conflict. The JDK variant package includes the runtime environment to execute Java applications so if one needs compilation and runtime of Java they need only the JDK package in the future. If, on the other hand, they need just runtime of Java then JRE (or jre-headless) will work.

This will (potentially) require a manual user action during upgrade:

  • If you have both JDK and JRE installed you can manually install the JDK with pacman -Sy jdk-openjdk && pacman -Su and this removes the JRE related packages.
  • If you have both JRE and JRE-headless you will need to choose one of them and install it manually since they would conflict each other now.
  • If you only have one of the JDK/JRE/JRE-headless pacman should resolve dependencies normally and no action is needed.

At the moment this is only valid for the upcoming JDK 21 release.

Arch Linux - News: Incoming changes in JDK / JRE 21 packages may require manual intervention

Previous testing threads:

1 Like

Get the following message

error: failed to prepare transaction (could not satisfy dependencies)
:: installing linux66-acpi_call (1.2.2-44) breaks dependency ‘acpi_call’ required by tpacpi-bat

Yeah, because @Yochanan removed provides=("$_pkgname"). :stuck_out_tongue:

Oops. :grimacing:

Now I have to rebuild acpi_call modules for testing and unstable…

Note: Please do not post asinine workarounds. Thread cleaned.

Patience is a virtue. If there’s something not quite right, then don’t update until it’s ready.

1 Like

Rebuilt acpi_call modules pushed.

Thanks for letting me know I made a mistake so I could fix it. :+1:

1 Like

If you had aliases saved in /etc/bash.bashrc, the update clears them with an entirely new
/etc/bash.bashrc file.
In case you didn’t already have your aliases saved into a separate file, you’ll find your old one named /etc/bash.bashrc.pacsave. As root or with root privileges, delete the new /etc/bash.bashrc, and rename /etc/bash.bashrc.pacsave to /etc/bash.bashrc.
Then enter source /etc/bash.bashrc as your normal user account, and everything should be as it was. Cheers.

I didn’t have the chance to share my update pains in the last round of testing updates, but I ran into a rather unique issue where binaries involving networking (pacman and NetworkManager included) could not run with an error message similar to this:

libnghttp3.so.9: cannot open shared object file: No such file or directory

It turned out that my system was missing the libnghttp3 package, but somehow it was never installed automatically nor did it raise broken dependency errors when I ran the update. To solve this, I had to use the live ISO, then from there I ran manjaro-chroot -a on one terminal to mount the root partition to /mnt/ and pacman --sysroot=/mnt/ -Syy libnghttp3 on another terminal.

Considering you are doing -Syy it’s safe to say you were in a partial upgrade state.

-Syy will „force“ a database Sync

That might be true, although the missing library problem showed up after I ran sudo pacman -Syuu as usual (there is an extra u on the command in case of package conflicts). That tells me that there is something that prevented my system to install libnghttp3 automatically.

That is for downgrade and has nothing to do with package conflicts.

Please post relevant logs.

First version of libnghttp3 1.1.0-1 was released in Testing update 2024-02-15
Package is required by curl , that is required by pacman and network-manager
so it should have been installed automatically

[2024-01-18T10:36:20+0000] [ALPM] installed libnghttp3 (1.1.0-1)