[Testing Update] 2024-01-18 - Kernels, Wine, Gamescope, Xorg-Server, KDE Framewoks, Virtualbox

Hello community,

here we have another set of package updates!

Recent News:

  • Some of our team will attend FOSDEM 2024 in Brussels. You can meet us in person on the weekend of 3 & 4 February 2024 at ULB Campus du Solbosch. We bring some Manjaro stickers and gaming gear to test. It will be a great opportunity to talk about future plans and direction of the Manjaro project, to share our passion with like-minded individuals and get first hand infos about upcoming devices powered by Manjaro Linux!
  • Protect your personal data, keep yourself safe (unlimited devices): 82% off + 4 mo. FREE
Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates:

  • Some Kernels got updated
    • linux65 and linux65-rt got dropped
    • we added linux-firmware-uncompressed for linux419 series
  • Wine 9.0 got released
  • we added initial gestures support to gamescope-plus
  • Xorg-Server 21.1.11 fixed another security issue
  • KDE Frameworks are now at 5.114.0.
  • those who still use pulseaudio, that is now at 17.0
  • pipewire got renewed to 1.0.1
  • Virtualbox is at 7.0.14
  • Usual KDE-git, Haskell and Python updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcements topics are off-topic and will be flagged, moved or removed without warning.

For help with AUR packages, please create a new topic in AUR and a helpful volunteer may be able to assist you.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.305
  • linux54 5.4.267
  • linux510 5.10.208
  • linux515 5.15.147
  • linux61 6.1.73
  • linux66 6.6.12
  • linux67 6.7.0
  • linux61-rt 6.1.70_rt21
  • linux66-rt 6.6.10_rt19

Package Changes (Wed Jan 17 23:40:40 CET 2024)

  • testing core x86_64: 45 new and 40 removed package(s)
  • testing extra x86_64: 1833 new and 1853 removed package(s)
  • testing kde-unstable x86_64: 275 new and 274 removed package(s)
  • testing multilib x86_64: 12 new and 12 removed package(s)

A list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2024-01-18


Making dbus-broker our default D-Bus daemon

2024-01-09 - Jan Alexander Steffens

We are making dbus-broker our default implementation of D-Bus, for improved performance, reliability and integration with systemd.

For the foreseeable future we will still support the use of dbus-daemon, the previous implementation. Pacman will ask you whether to install dbus-broker-units or dbus-daemon-units. We recommend picking the default.

For a more detailed rationale, please see our RFC 25.

Arch Linux - News: Making dbus-broker our default D-Bus daemon


Nvidia 545 drivers might have issues

:information_source: Due to various issues including non working backlights on some machines, the NVIDIA 545 series feature branch drivers have been downgraded to the 535 series production branch drivers.

If you are having no issues with the 545 series, there is nothing to do. If you are, you can downgrade to the 535 series with pamac update --enable-downgrade or sudo pacman -Syuu.

So far we know about these issues the Nvidia 545 driver series has:

If you experience similar or new issues please run sudo usr/bin/nvidia-bug-report.sh and post either in an already given post or create a new one, including your generated nvidia-bug-report.log.gz for Nvidia to fix the issue: Linux - NVIDIA Developer Forums

Changes in JDK / JRE 21 packages may require manual intervention

2023-11-02 - Frederik Schwan

We are introducing a change in JDK/JRE packages of our distro. This is triggered from the way a JRE is build in modern versions of Java (>9). We are introducing this change in Java 21.

To sum it up instead of having JDK and JRE packages coexist in the same system we will be making them conflict. The JDK variant package includes the runtime environment to execute Java applications so if one needs compilation and runtime of Java they need only the JDK package in the future. If, on the other hand, they need just runtime of Java then JRE (or jre-headless) will work.

This will (potentially) require a manual user action during upgrade:

  • If you have both JDK and JRE installed you can manually install the JDK with pacman -Sy jdk-openjdk && pacman -Su and this removes the JRE related packages.
  • If you have both JRE and JRE-headless you will need to choose one of them and install it manually since they would conflict each other now.
  • If you only have one of the JDK/JRE/JRE-headless pacman should resolve dependencies normally and no action is needed.

At the moment this is only valid for the upcoming JDK 21 release.

Arch Linux - News: Incoming changes in JDK / JRE 21 packages may require manual intervention


Mechanical HDDs may not spin-down properly on shutdown

There might be a regression introduced with 6.6.0-rc4 which got also backported to 6.1.59 and 6.5.8 Kernels. There is a discussion with the author of the offending patch ongoing here.

ZFS package changes

ZFS extramodules; i.e., linuxXX-zfs, have been dropped from the repos. There have been recent difficulties building them and no one on the Manjaro Team uses ZFS.

Please install zfs-dkms instead. You will to need to manually remove the old 2.1.13 extramodule package(s) first to install the new 2.2.0 packages; i.e., with linux61:

sudo pacman -R linux61-zfs && sudo pacman -Syu zfs-dkms
Restarting gnome-shell using Alt+F2 and entering R, causes a crash

FS#79884 : [gnome-shell] Restarting gnome-shell using Alt+F2 and entering R, causes a crash

GNOME Extensions that target older GNOME versions will not work in GNOME 45

It is recommended to remove all third-party extensions before updating, then install the compatible versions after updating and rebooting. All Most extensions in the Manjaro repos are already updated.


glibc-locales update requires manual intervention

If you had the old glibc-locales package from the extra repo installed, the update to the new core package will need manual intervention:

 sudo pacman -Syu glibc-locales --overwrite /usr/lib/locale/\*/\*

Previous testing threads:

Here we go again. After update reboot did not work. Had to cold restart the computer. Cold boot worked. But it took A LOT of time for Plymouth or whatever to boot the system.

UPD: Yes, reboot does not work. Cold start works.

1 Like

Had to remove “quiet splash” from grub menu to boot. Same issue with plymouth as one of the last updates.

1 Like

After seeing the last 2 posts I tested a cold boot on my desktop—black screen. Rebooting had worked fine after the update and I used the comp for hours. Now, cold booting doesn’t work unless I make the “quiet splash” edit and boot.

AMD 7800X3D, B650 mobo

Tried a cold boot on the (Acer Spin) laptops; boots fine to login screen. Issue might be with newer CPUs/AMD?

All using Plasma/Wayland sessions

on shutdown , i have this process stay in 1mn30 before end
in journalog on this in red

janv. 18 07:15:15 dbus-broker-launch[661]: Activation request for 'org.freedesktop.nm_dispatcher' failed.

2 posts were split to a new topic: Auf dem Gerät ist kein Speicherplatz mehr verfügbar

This update again results in a black screen after a reboot with no way to get to a tty. Problem is still with Plymouth on my system (AMD cpu and NVIDIA gpu). Editing grub menu and removing “quiet” and “splash” will allow you to log in.
I went ahead and removed the “plymouth” Hook from /etc/mkinitcpio.conf and ran sudo mkinitcpio -P. Then I edited /etc/default/grub to remove “splash” and ran sudo update-grub. I don’t have the second or two of the Plymouth splash screen any longer, but at least I can boot the computer.

There are two issues. Manjaro neither used kms nor Plymouth by default. Only with recent changes to 23.1 ISOs those got activated.

KMS hook created also issues within mkinitcpio due to the fact that on our end we use a symlink for extramodules which is not copied as a regular folder with 37.2 release to avoid the inclusion of the large Nvidia GSP firmware blob. That issue is now fixed.

Plymouth is more or less eyecandy and can create issues if not properly set up.

You can remove splash from /etc/default/grub and regenerate the menu for grub via update-grub.

kms hook can be removed from /etc/mkinitcpio.conf and regenerated via mkinitcpio -P

We are still working to get the situation with Plymouth active more supportive.

1 Like

i received this morning for remove manjaro-hotfixes with pacmac

This update left this line in my log:

dbus-broker-launch[1582]: Ignoring duplicate name 'org.gnome.Shell.Extensions.GSConnect' in service file '/usr/share/dbus-1/services/org.gnome.Shell.Extensions.GSConnect.service' 

Prompting me to clean up this extension that I don’t have activated and don’t use anymore.

After uninstalling this error does not return in the logs.

To be clear, following these instructions is what you’re suggesting? Thank you.

EDIT: Yes.

Since extramodules is a symlink on our end, mkinitcpio 37.2 originally messed up nvidia drivers as the host was touched when users had chosen to uncompress modules for kms and faster booting. That was fixed in a more recent update of mkinitcpio.

Nvidia drivers should be removed, checked for uncompressed .ko files should get removed and after driver installed again

A SSD/partition is set up to auto mount but in fact does not auto mount after this update.

Checking the settings it is still configured to auto mount and it does mount if I manually force it to(asks for password in that case leading me to wonder if there’s something up with that, but the specific SSD/partition directories are all under my users full ownership).

Would you mind sharing

  1. The specific polkit action and ID shown in the authentication dialog (may be under Details).
  2. The device’s entry from your /etc/fstab.

I am assuming that this may be related to manjaro-hotfixes, but am just fishing for clues.

This thread may be useful:

That’s probably right:

Action: Mount a filesystem on a system device
ID: org.freedesktop.udisks2.filesystem-mount-system

Entry for the specific SSD/Partition is missing from fstab. I presume it gets added when I manually mount the drive. But again, should auto mount as per: