[Testing Update] 2022-11-08 - Kernels, GNOME 43, OpenSSL 3.0, Firefox, Thunderbird, Mesa, KDE Gear 22.08.3, LibreOffice, LXQt 1.2.0

Cannot sync calendar with nextcloud after upgrading to gnome 43

Do not push it into the stable branch, it would broke many workstations when using Gnome and nextcloud.

Kernel 6.0.x still has the issue with hibernation and suspend when using AMD GPU. But the path would fix Kernel 6.1.x.rc only.

My system hang on starting service PCR TPM2 Barrier (Initialization), y have to reboot with the installation disk to move the service file /usr/lib/systemd/systemd-pcrphase to another location to be able to boot.

This look like the problem but I don’t know for sure: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1023515

1 Like

Just upgraded and mostly ok except it no longer wants to connect to the Wi-Fi network I always use. After I’ve launched Gnome Settings and go to the Wi-Fi section, then click the network (its name or the cog icon) to try and re-configure that connection (under Visible Networks), the Gnome settings application crashes with no error message displayed.

I found this the logs right after it crashes and I think it’s related but am not too sure what to try next to troubleshoot this.

settings object created with schema 'org.gnome.nm-applet.eap' and path '/org/gnome/nm-applet/eap/d0c3b23d-de76-4e4e-abb7-075fef1de7c5/', but path '/org/gnome/nm-applet/eap/' is specified by schema

minor update… I removed (“forgot”) the connection, started again, adding it anew, and the settings tool no longer crashed however it still doesn’t connect and I think it’s the same issue as this person reported.

issue appears to be fixed with last updates.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

1 Like

For real, removing tpm2-abrmd resolved the issue. I did it before updating systemd to 252 and on next boot there was no indefinite “Starting TPM2 PCR Barrier” message of the respective service preventing system from booting.

1 Like

Well my system is not using systemd-boot nor grub, is starting with a Unified kernel image on EFI. I will try to removing tpm2-abrmd package and enabling the pcrphase to test it.

Confirmed after removing the above package the system boot now.

On pamac update I get many ruby warnings. Last time an update on ruby before the system update solved this, but this time I still get warnings.

And pamac wants to download 2.1 GB of updates. Is this right? I update my system daily.

This update appears to have broken most of the Appearance settings for me…

Logs from running systemsettings5 from command line:

 "Error loading QML file.\n145: Type NewStuff.Action unavailable\n184: Type NewStuff.Page unavailable\n487: Type NewStuff.EntryDetails unavailable\n163: Type Kirigami.UrlButton unavailable\n21: Kirigami.LinkButton - Kirigami is neither a type nor a namespace\n"
qml: The item SubCategoryPage_QMLTYPE_113(0x55a998529150) is already in the PageRow


A post was split to a new topic: I am unable to connect to wifi on 802.1x profiles on KDE

Please check/reinstall packages

neither gdm or gnome-shell starts, oops crap is shown. Switched to lightdm/Cinnamon…

Is that still relevant for v252.1 release of Systemd? Also was it reported upstream? There are some TPM issues also reported for 251: https://github.com/systemd/systemd/issues/25099

Most likely you hit this issue: device_set_syspath: Segmentation fault logging into GNOME Shell · Issue #25299 · systemd/systemd · GitHub

No, I think that this is problem: /usr/bin/gjs: error while loading shared libraries: libmozjs-102.so: cannot open shared object file: No such file or directory

Problem is that I don’t know which package installs that library…

most likely js102

Thanx, now I log into Gnome but there is nothing except apps that I start on login.
Error is now:gsd-xsettings[101835]: Failed to get current display configuration state: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Name “org.gnome.Mutter.DisplayConfig” does not exist

Maybe you have an partly updated system …

It says everything up to date. Before update, there were no problems.
Perhaps, problem is beacause I update with pacman -Syudd ?

using -dd is not recommended at all as it ignores dependency checks completely. why you came up with that?

1 Like

Well, it worked so far good :stuck_out_tongue:
In future, I’ll be more carefull. Googlong around problem
is probably because incompatibility between mutter and
Gnome settings.