[Testing Update] 2022-10-03 - Kernels, Systemd, AMDVLK, Deepin, Pamac, Qemu, Thunderbird

Hello community,

Another testing branch update with some usual package updates for you.

We partnered up with Slimbook to bring the Titan Gaming Laptop to our Community

  • We updated most of our Kernels
  • Systemd is now at 251.5
  • Thunderbird got renewed to 102.3.1
  • Deepin and AMDVLK got updated
  • Pamac got prepped for GNOME 43 release
  • Qemu gained firmware support
  • Some KDE-git updates as usual

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

:information_source: You may need to rebuild any AUR packages that install files to site-packages …

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.259
  • linux54 5.4.214
  • linux510 5.10.145
  • linux515 5.15.70
  • linux518 5.18.19 [EOL]
  • linux519 5.19.11
  • linux60 6.0.0rc6
  • linux515-rt 5.15.55_rt48
  • linux519-rt 5.19.0_rt10

Package changes (Sun Oct 2 22:27:30 CEST 2022)

  • testing community x86_64: 1338 new and 1321 removed package(s)
  • testing core x86_64: 37 new and 35 removed package(s)
  • testing extra x86_64: 281 new and 328 removed package(s)
  • testing kde-unstable x86_64: 328 new and 328 removed package(s)
  • testing multilib x86_64: 14 new and 14 removed package(s)

A list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

1 Like

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2022-10-03


Nvidia 3060RTX cards may have issues with the 515.76 driver
Removing python2 from the repositories

2022-09-23 - Jelle van der Waa

Python 2 went end of life January 2020. Since then we have been actively cutting down the number of projects depending on python2 in our repositories, and we have finally been able to drop it from our distribution. If you still have python2 installed on your system consider removing it and any python2 package.

If you still require the python2 package you can keep it around, but please be aware that there will be no security updates. If you need a patched package please consult the AUR, or use an unofficial user repository.*

Arch Linux - News: Removing python2 from the repositories

* Note: Unofficial user repositories are not supported


Changes with Back In Time packages
  • backintime has been renamed to backintime-qt
  • backintime-cli has been renamed to backintime

After replacing backintime-cli with backintime, you will need to install backintime-qt manually if you want the Qt frontend installed again.


electron12, electron13, electron14 & electron16 have been dropped to the AUR

Unsupported Electron packages have been dropped from the official repos to the AUR. They no longer receive security updates and nothing in the repos depend on them.

If you have AUR packages depending on those versions, install the binary version from the AUR to replace them; i.e., electron16-bin.

See FS#75490 - electron12, electron13, electron14, electron16 are unsupported and vulnerable packages

End of Support for 15.x.y and 16.x.y

Electron 15.x.y and 16.x.y has reached end-of-support. As per Electron’s new 8-week cadence, we were supporting the latest four versions of Electron until May 2022. With this Electron 19 release, we’ll return to supporting the latest three major versions, as well as the alpha, beta, and nightly releases.

Release electron v19.0.0 · electron/electron · GitHub


element-desktop dependency error (fixed with 1.11.4)
error: failed to prepare transaction (could not satisfy dependencies)
:: installing electron (20.0.0-1) breaks dependency 'electron19' required by element-desktop

The upstream package was already flagged out of date (it needs to be rebuilt against latest electron).

Workaround for now:

sudo pacman -Syy electron electron19 --asdeps
sudo pacman -Su


Glibc 2.36 update will break EasyAntiCheat within Proton (should be fixed with glibc 2.36-2)

Temporary workaround for now is to use the flatpak version of steam:

sudo pacman -S flatpak --needed --noconfirm
sudo flatpak install com.valvesoftware.Steam -y

You can use flatseal (another flatpak app) to grant it access to your existing game library so you don’t have to re-download your games (add the game library install path under “Other files” under “Filesystem”).

sudo flatpak install com.github.tchx84.Flatseal -y

For advanced users (not recommended by us): patched glibc and lib32-glibc are available here. They remove the commit that broke EAC.


Fixed: Pamac shows archlinux-keyring (20220713-2) and manjaro-keyring (20220514-2) as orphans
sudo pacman -D --asexplicit archlinux-keyring manjaro-keyring

Resolved: w/ base 3-2 Revert changes:

sudo pacman -D --asdeps archlinux-keyring manjaro-keyring


wxWidgets 3.2 update may need manual intervention

Packages have been renamed from wxgtk- to wxwidgets-. The GTK2 frontend is no longer provided. If you have wxgtk2 installed, the upgrade will fail with:

In such case, uninstall wxgtk2 first and then proceed with the upgrade.


Linux518: could not insert 'amd_pstate': No such device

With Kernel 5.18.11 there was added a regression to AMD P-State driver preventing it from loading.


Wireplumber 0.4.11 may crash for GDM users

Currently there is an issue with 0.4.11 and GDM crashing on boot-up. More in the upstream bugtracker issue: wireplumber segfault: system boot and could see in my dmesg (#305) · Issues · PipeWire / wireplumber · GitLab


Locale file changes

C.UTF8 locale is now included in glibc:

Credits @diabonas for this change. Systemd wants us to include C.UTF8 by default and it seems the locale may be in included by glibc upstream in the future. To fix building and avoid nasty fixing in devtools, we include the locale in the package. See systemd/systemd#23252 (comment) FS#74864 : [systemd] >= 251 breaks devtools' locale

There is a pacsave for /etc/locale.conf as it has been removed from the filesystem package.

UPDATE: With filesystem 2022.06.08-2, it will automatically restore /etc/locale.conf if it did not already exist.

There is a pacnew for /etc/locale.gen. Please review it and regenerate your locale if necessary.

Thank you for the update! Seems fine except on thing as I see. I don’t know if it’s just with me, but qbittorent 4.5.1. from the official repository looks totally weird. It has lost the style of the system, the cursor in the program window is very large etc. Changing the appearance shell does not help. It’s on GNOME.

This update broke my system. Could not boot into shell anymore. Seemed like graphic driver issues with 5.10 kernel, so I replaced it with 5.15 and now it works.

1 Like

Qbittorrent is only version 4.4.5-1, so you are likely experiencing the issue that @bogdancovaciu linked to (AKA the switch to qt6).

I noticed that your custom avatar is missing in KDE SDDM login screen.


Delete two deprecated files in your home directory:

rm ~/.face
rm ~/.face.icon

OBS 28.0.2-2 is unstable on gnome wayland, possibly not a manjaro issue - just a warning.
Works fine on Xorg.
Even the flatpak version 28.0.3 has same issues. Seems GUI related, if once configured, just recording via app-indicator works.
Changing settings, eg → settings-video-fps or randomly in GUI or settings, gnome-shell crashes.

Still getting seemingly random crashes with Timeshift gui (timeshift cli works) since glib2 update to 2.74.0 (glib2 2.74.0-2 does not fix it). Downgrade glib2 to 2.72.3-3 and the crashes stop.

Reported in Arch forums also:

And in Timeshift issues:


/usr/lib/cups/filter/rastertogutenprint.5.3" nicht verfügbar: No such file or directory"

while trying to print using my default printer. Of note: This has worked for several years.
Installing gutenprint with pamac seems to have solved that.

Update failed because of conflicting files.
The problem is that pcre2-static is now included in pcre2, but there is no “replaces” line in the PKGBUILD file.
Uninstalling pcre2-static first and then run update, fixes it.

pcre2-static is no regular package from the repositories, one can find it in the AUR.
Package(r)s from the repositories (like pcre2) won’t consider AUR packages, you’re always on your own with those.

I have a few Gnome extensions break after the update. I checked the main GitHub pages for each, but did not see any updates on if these will be fixed soon.

Gnome Extensions Not Working:
-Compiz alike windows effect
-Extension Update Notifier
-Hide Activities Button

Anyone else seeing problems with these extensions on your system? Thanks.

I got the known problem of Kernel 5.19.12 for Intel APU when connecting some Laptop to any external monitors.

The issue:

The main display starts blinking at boot that depends on text input. So each input per a screen blinking.


  • Downgrade to 5.19.11 fixes this annoying problem.

Do not push it to the stable branch, there are many laptops with Intel APU.

1 Like

This happened yesterday on one of our laptops during a session. I wouldn’t have thought it was a kernel issue.

5.19.13 should fix those: https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.19.13


:information_source: An update for plasma-settings and kirigami-addons will be along shortly. You will need to manually update kirigami-addons from 1:0.3-1 to 0.4-1.

EDIT: No one probably has either application installed as only kclock and ktrip depend on them.

1 Like

Isn’t that for Plasma Mobile?

Yes. But it’s now in upstream Arch Linux. (woo) \o/

1 Like

Do we recall why we needed the epoch on our end?