[Testing Update] 2022-07-08 - Kernels, Pipewire, Mesa, KDE Gear, Gnome, Python, Haskell

I got the wireplumber v0.4.11 error from Journactl notify after every reboot.

Process 933 (wireplumber) of user 120 dumped core.
                                             Module linux-vdso.so.1 with build-id 70743e6fa18b5c64207700f7b95a6f0ab6b1ff10
                                             Module libspa-v4l2.so with build-id f01bc8a61c561672c4e5a1f9f6224314d2cf2da2
                                             Module libudev.so.1 with build-id bce2b8a5c23fcbcf5542f34b741e18db4452160a
                                             Module libasound.so.2 with build-id 037b70e73a363662ffa089fcb4370cecb6ca7bd8
                                             Module libspa-alsa.so with build-id d90b05d7d5adfa484750beb978dc2cc01e683010
                                             Module libwireplumber-module-logind.so with build-id ba06b6aa5616f6a27e7bc94143b1e2ddb826d73d
                                             Module libwireplumber-module-si-audio-endpoint.so with build-id 8748a763fd09decf36703562a79545da0f96d04d
                                             Module libwireplumber-module-si-node.so with build-id d3ae5b8221764926c5208963f148db21267d4f06
                                             Module libwireplumber-module-mixer-api.so with build-id 6c98529d81973729faa2b7a21d9e54cc46023b91
                                             Module libwireplumber-module-si-audio-adapter.so with build-id d072c67fd7c50fdc9b32c3c4b72ae970271ca25e
                                             Module libwireplumber-module-default-nodes-api.so with build-id 0c2eb814a76f554cd91cede590c746a02de16ed1
                                             Module libwireplumber-module-si-standard-link.so with build-id 36695a978542b89cad22db5789a596734bdecf89
                                             Module libwireplumber-module-reserve-device.so with build-id 7e6cafc74c530b638502f3256864adf6c9b8c204
                                             Module libwireplumber-module-portal-permissionstore.so with build-id 1a798a1f3ebfce36fe6ee4f2e29ec17c3e399063
                                             Module libwireplumber-module-default-nodes.so with build-id cbb060d8f6ec036d6bddc719732b5532380e2897
                                             Module libwireplumber-module-metadata.so with build-id 2aba1d6959c5469e64a395e0603dbf2c6f38e823
                                             Module libwireplumber-module-default-profile.so with build-id cdff4dacc78a130d7a2ed21923bead1bab199650
                                             Module libwireplumber-module-file-monitor-api.so with build-id 032224a0ce97c7b1b02ebb5e962263ffbf85d3ba
                                             Module libgvfscommon.so with build-id 2cfa9a05d5e376857a2dacaf4893238a88eefb9e
                                             Module libgvfsdbus.so with build-id f6f918ab413a1eaaa77134863653c4382b7cf8de
                                             Module libm.so.6 with build-id 1b7296ef9fd806e47060788389293c824b09ad72
                                             Module libdl.so.2 with build-id 94198b268228074fa9f405bbedbbae94112593ed
                                             Module liblua.so.5.4 with build-id 7bdd0ca9ab751d85d87f9f5cc170c7a7a9b7f08f
                                             Module libwireplumber-module-lua-scripting.so with build-id 5b466456e157ae2b3365c115fca7fcf5795cfdae
                                             Module libpipewire-module-session-manager.so with build-id 2b0119ae941e982d2b92be4e2c03ab7d23579ba8
                                             Module libpipewire-module-metadata.so with build-id 60be1c48e2f0bd4c03d8d8a18ae87e6d3f8e9544
                                             Module libpipewire-module-adapter.so with build-id 1da1733fb0cd3c594f8c18a0cdd88570f429630a
                                             Module libpipewire-module-client-device.so with build-id 4e39fde2c49b069d81564301c896ab3d5b9a5875
                                             Module libpipewire-module-client-node.so with build-id f1faac9431417bbd29fe692af66a8a10a54b38e5
                                             Module libpipewire-module-protocol-native.so with build-id 9a5f4ff5e6c2d2b6ca2b124a0535f41788bad17c
                                             Module libpipewire-module-rt.so with build-id 1807376eedf83c478415634a62c82889fe941a7b
                                             Module libgpg-error.so.0 with build-id 4738b8a9478177c202cccd64e0eb65d3dea2bfae
                                             Module liblz4.so.1 with build-id e63600ab23b2f6997f42fac2fa56e1f02ce159a1
                                             Module libzstd.so.1 with build-id ab54c2881f53ab314e134f3e08c76d504376dd5d
                                             Module liblzma.so.5 with build-id 28b40c7af8098a66af6ee093b6986b91cad7694d
                                             Module libgcrypt.so.20 with build-id 8bf3cb884124273640de797a3e77d86c98434ea4
                                             Module libcap.so.2 with build-id 21b00ab76bb16fde56fd741f07233c78069f0579
                                             Module libsystemd.so.0 with build-id 6430b2bd03335142b596061e30d2508dc604a1b4
                                             Module libdbus-1.so.3 with build-id 7f4b16b4b407cbae2d7118d6f99610e29a18a56a
                                             Module libspa-dbus.so with build-id 9f4e1bcbc6a903ea88028a84ff03b1c641059f87
                                             Module libspa-support.so with build-id 4ff8b6276863386bdc342e0af5d3f012baf39be1
                                             Module libblkid.so.1 with build-id 140694a62d8d4d07c6c320a501f948dd1b389d73
                                             Module libpthread.so.0 with build-id 95ae4f30a6f12ccbff645d30f8e1a3ee23ec7d36
                                             Module libmount.so.1 with build-id 4436aeea0cd8c01b5a77969e0531184f8b3513ce
                                             Module libz.so.1 with build-id fefe3219a96d682ec98fcfb78866b8594298b5a2
                                             Module ld-linux-x86-64.so.2 with build-id 0effd0e43efa4468d3c31871c93af0b7f3005673
                                             Module libpcre.so.1 with build-id 845483dd0acba86de9f0313102bebbaf3ce52767
                                             Module libffi.so.8 with build-id f0a9586cf0f42d2b9971bd1065ca3a6b19f4a2c2
                                             Module libgio-2.0.so.0 with build-id 7a769ec24a9a705d04ee0297730032f70ed0835b
                                             Module libgmodule-2.0.so.0 with build-id abd986222e2cf12fc7324cb0182dfc2c8f2269c0
                                             Module libc.so.6 with build-id 60df1df31f02a7b23da83e8ef923359885b81492
                                             Module libgcc_s.so.1 with build-id 0e3de903950e35ae59a5de8c00b1817a4a71ca01
                                             Module libpipewire-0.3.so.0 with build-id 1c31e9ce9f8164c5e8128338569ffcd56c6163e6
                                             Module libglib-2.0.so.0 with build-id 1340f3a762b2293ebf6d725edf0eb14839f85317
                                             Module libgobject-2.0.so.0 with build-id a7515bd8cd51064d187953c0f506a43958de31a6
                                             Module libwireplumber-0.4.so.0 with build-id 3b077e387ac568e6b3fe46bd1a4ff822da078d9c
                                             Module wireplumber with build-id 0d4af843b78c77316d55948702a956e98989edf6
                                             Stack trace of thread 933:
                                             #0  0x00007f9a702edf11 n/a (libwireplumber-0.4.so.0 + 0x25f11)
                                             #1  0x00007f9a6fcf2544 n/a (libgio-2.0.so.0 + 0xa4544)
                                             #2  0x00007f9a6fcf257d n/a (libgio-2.0.so.0 + 0xa457d)
                                             #3  0x00007f9a70180c6b g_main_context_dispatch (libglib-2.0.so.0 + 0x54c6b)
                                             #4  0x00007f9a701d7001 n/a (libglib-2.0.so.0 + 0xab001)
                                             #5  0x00007f9a701801cf g_main_loop_run (libglib-2.0.so.0 + 0x541cf)
                                             #6  0x000056306af9e2f2 n/a (wireplumber + 0x22f2)
                                             #7  0x00007f9a6fe49290 n/a (libc.so.6 + 0x29290)
                                             #8  0x00007f9a6fe4934a __libc_start_main (libc.so.6 + 0x2934a)
                                             #9  0x000056306af9e5a5 n/a (wireplumber + 0x25a5)
                                             Stack trace of thread 956:
                                             #0  0x00007f9a6ff25c3f __poll (libc.so.6 + 0x105c3f)
                                             #1  0x00007f9a701d6f68 n/a (libglib-2.0.so.0 + 0xaaf68)
                                             #2  0x00007f9a701801cf g_main_loop_run (libglib-2.0.so.0 + 0x541cf)
                                             #3  0x00007f9a6fd56acc n/a (libgio-2.0.so.0 + 0x108acc)
                                             #4  0x00007f9a701b0405 n/a (libglib-2.0.so.0 + 0x84405)
                                             #5  0x00007f9a6feac54d n/a (libc.so.6 + 0x8c54d)
                                             #6  0x00007f9a6ff31874 __clone (libc.so.6 + 0x111874)
                                             Stack trace of thread 946:
                                             #0  0x00007f9a6ff25c3f __poll (libc.so.6 + 0x105c3f)
                                             #1  0x00007f9a701d6f68 n/a (libglib-2.0.so.0 + 0xaaf68)
                                             #2  0x00007f9a7017e392 g_main_context_iteration (libglib-2.0.so.0 + 0x52392)
                                             #3  0x00007f9a7017e3e2 n/a (libglib-2.0.so.0 + 0x523e2)
                                             #4  0x00007f9a701b0405 n/a (libglib-2.0.so.0 + 0x84405)
                                             #5  0x00007f9a6feac54d n/a (libc.so.6 + 0x8c54d)
                                             #6  0x00007f9a6ff31874 __clone (libc.so.6 + 0x111874)
                                             Stack trace of thread 941:
                                             #0  0x00007f9a6ff31c9e epoll_wait (libc.so.6 + 0x111c9e)
                                             #1  0x00007f9a70360489 n/a (libspa-support.so + 0x14489)
                                             #2  0x00007f9a70352d11 n/a (libspa-support.so + 0x6d11)
                                             #3  0x00007f9a7008dd47 n/a (libpipewire-0.3.so.0 + 0x3fd47)
                                             #4  0x00007f9a6feac54d n/a (libc.so.6 + 0x8c54d)
                                             #5  0x00007f9a6ff31874 __clone (libc.so.6 + 0x111874)
                                             Stack trace of thread 2844:
                                             #0  0x00007f9a6ff2b30d syscall (libc.so.6 + 0x10b30d)
                                             #1  0x00007f9a701d1063 g_cond_wait_until (libglib-2.0.so.0 + 0xa5063)
                                             #2  0x00007f9a7014f8d3 n/a (libglib-2.0.so.0 + 0x238d3)
                                             #3  0x00007f9a701b363b n/a (libglib-2.0.so.0 + 0x8763b)
                                             #4  0x00007f9a701b0405 n/a (libglib-2.0.so.0 + 0x84405)
                                             #5  0x00007f9a6feac54d n/a (libc.so.6 + 0x8c54d)
                                             #6  0x00007f9a6ff31874 __clone (libc.so.6 + 0x111874)
                                             ELF object binary architecture: AMD x86-64

I have no idea, why is this error.


  • Downgrade to wireplumber v0.4.10, then no error appears after reboot.

I reported the issue:

A post was merged into an existing topic: [Stable Update] 2022-07-04 - Kernels, Firefox, Thunderbird, Nvidia 515.57, Python, Haskell

2 posts were split to a new topic: Need to rebiuld megasync after recent testing update

There is a new configuration in /etc/mkinitcpio.conf.pacnew in this update.

# Decompress kernel modules during initramfs creation.
# Enable to speedup boot process, disable to save RAM
# during early userspace. Switch (yes/no).

When “no” is set to MODULES_DECOMPRESS, that means “Enable to speedup boot process and disable to save RAM”. Right?

I thought, no compression and no decompression make boot startup faster.

There is no info about this configuration.

No, the comma separates what “yes” and “no” do. Decompress for faster boot, compress for lower RAM utilisation.
The wording here could be improved.

A post was merged into an existing topic: Need to rebiuld megasync after recent testing update

My cifs mount fails with error 22 after the update.

I think it has to do with the updated 5.18 kernel. This bug report indicates that the error occurs for some servers since 5.18.8 and has possibly been fixed with 5.18.10. Not for me, it seems.

I’m using the 5.15 kernel for now.

Edit: Adding “vers=2.0” as a mount option seems to work, too (see this thread).

1 Like

4 posts were split to a new topic: Conflicts with npm files

Noone will look at that. However you may want to comment on this one: wireplumber segfault: system boot and could see in my dmesg (#305) · Issues · PipeWire / wireplumber · GitLab

After updating Firefox would not start for me and crashed to the crash reporter, using firefox --safe-mode also results in a immediate crash and the crash reporter. The content of the crash report does not give me any clues what could be the issue. Starting firefox from the command line does not output any errors or messages.

Solution: remove ~/.mozilla/ and start firefox with a clean profile (and syncing settings solved this for me)

1 Like

EXACTLY, ESPECIALLY since 5.25 has features 5.24.6 doesn’t.

1 Like

alternate views to think about manjaro branchs;

when you are in the testing branch, you are effective in the process of testing manjaro with the intent of delivering stable releases/updates. and stable plasma release still is 5.24.6 as deemed by the manjaro team (which is wise with it being the LTS release)

your self-centered intentions being in the testing branch might be to have one layer of insulation to avoid possible rogue updates, while still getting the latest updates, but it just doesnt work that way, not in software testing.

the only branch that is devoid of this debacle is the unstable branch. so either move to the unstable branch OR be happy with what you get, when you get it. (this statement in only meant for ppl in testing branch who keep whining over delayed updates and hypocritical enough to call other ppl silly)

Moderator edit: Removed inappropriate language


Agree wholeheartedly!

Please keep on topic and enjoy the free service without complaints and a whole lot of gratitude.

Moderator edit: Removed inappropriate language from quoted post


So, to be clear if we want to test out this new feature (speedup boot process), do we uncomment the MODULE_DECOMPRESS line and leave it with the value of ‘yes’ ?

Just want to be sure I am making the correct change. Thank you!

Can you tell me the exact grep command you are running for this output @Zesko? I want to check if I also am having this issue or not. Sorry for the ‘newb’ question, still learning my way around Linux.

Thanks for the help!

Correct. Remember to generate initramfs images with mkinitcpio after.

1 Like

Current pipewire versions do not seem to work well with chromium - tried with chromium from the official repo as well as with chromium 105.0.5153.0 compiled by myself.

See Audio stutters when playing YouTube videos in Chromium for details.

Amendment: Possibly related to Heavy stuttering when more than one audio source is playing (regression started in 0.3.53) (#2525) · Issues · PipeWire / pipewire · GitLab although Firefox does not seem to be affected on my machine.

What is the exact command I need to run? Is it:

mkinicpio -p

And I’m good with the updated config?

No that’s not it the case is important here, always check manual for instant answer of what switch does what man mkinitcpio

I’m on Chromium “103.0.5060.114 (Official Build) Arch Linux (64-bit)” from the Repository. I tried playing video from there and Firefox 102.0.1 (repository) at the same time (simultaneously) and am not experiencing this. Pipewire 0.3.54-1

Different sources you mean apps or physically routed from/to different sources (Line out and USB speakers simultaneously)?