[Testing Update] 2022-06-07 - Kernels, Mesa 22.1.1, Haskell, Perl, Python, Pamac

Corrected with filesystem 2022.06.08-1 and systemd 251.2-3. The default is now set to C.UTF-8.


After update I still have only LANG=“C” in my locale.conf file, but I don’t see any issues on Plasma. Should i manually change it to C.UTF-8?

No, that’s only the fallback default if there is no /etc/locale.conf. If one uses U.S. English for example, it would be set to to LANG=en_US.UTF-8.

The easy way is using Manjaro Settings Manager > Locale Settings and make your language changes there. After applying, it will set the LANG value in /etc/locale.conf.


i applied 2nd update

cat /etc/locale.conf
   System Locale: LANG=fr_FR.UTF-8
       VC Keymap: fr-latin9
      X11 Layout: fr
       X11 Model: logitech_base
     X11 Variant: oss_latin9

i have in manjaro settings


locale -a

Thanks! The corrections fixed it.

I noticed that when I upgraded filesystem to 2021.12.07-5. Veracrypt stopped working. Does anyone know how to fix this or why it is happening?

For now, my solution was to downgrade filesystem back to the previous version. But eventually, I’ll have to upgrade so I hope I find a solution by then.

@NeoTheo No issues with veracrypt for me. Current filesystem version in testing branch is 2022.06.08-2. Must be something else.
Run it in terminal and see if it brings up an error message.

That’s not the current version.

Please read the messages already posted in this thread (preferably before posting).

I got it working. Thanks for all your help.

Please leave the solution so that, if anyone else has the same problem, they can easily fix it.


I am not really sure what fixed it. I just re-updated the filesystem and then rebooted and it worked.

The restoration of /etc/locale.conf probably.

The current filesystem package restores the previously created /etc/locale.conf.pacsave (if that wasn’t fixed manually like laid out above) and informs about it while updating.
You should read update messages.

Ok, thanks.

after the update. My login screen becomes english but my locale and other software are all chinese

@Firestar Have you checked Manjaro Settings Manager > Locale Settings > Detailed Settings? Most likely all fields are empty. Adjust accordingly or use the method described in the announcement and reboot.
Your programs are correctly in your desired language because it’s set in User profile > System Settings > Regional Settings > Language / Formats.

You can see that on the post above, I only have one Language.

On the other hand, I changed zsh locale before by adding export LANG=en_US.UTF-8 to ~/.zshrc, I don’t know if it causes some bug.

SDDM is before you login to use user settings, so initially global system settings, as described should be in /etc/locale.conf or if empty a system default C.UTF-8

~/.zshrc is within your user profile, so shouldn’t matter from my point of view.
From ‘[HowTo] provided system information’ tutorial about terminal language:

1 Like

@Yochanan As mentioned before here I think MSM needs some adjustment with locale handling.
MSM does not take care of updating the following value in /etc/locale.conf


When someone uses different locales for formats and display language and adjusting it with MSM can lead to the situation below where LANGUAGE= is not automatically updated according to the value set in LANG= :

cat /etc/locale.conf                                                                                                   ✔ 

In short it describes the issue mentioned by @Firestar where system language stays in English although maintained differently with MSM.
While it’s no problem to manually change nano /etc/locale.conf I think MSM should update both correctly.

Am I missing something?

1 Like

I had to revert locale.conf to settings from its pacsave file, because systemd-vconsole-setup kept failing to start otherwise. LANG=C is cool, but my locale is cooler :upside_down_face: