[Testing Update] 2022-04-25 - Kernels, Mesa, Gnome 42, KDE Apps & Frameworks, LxQt, Firefox, Thunderbird, Virtualbox

No, my information is not related to your problem.

postgresql is database management. You do not need it, it is useless if you are not database manager.



ok, so i have the same unresolved problem.

Well, there goes my 20-day uptime. Updating now!

1 Like

I heard KDE Frameworks 5.93 has a lot of regression bugs, such as the volume control OSD showing up on the top left corner of the screen. Will this update contain some backported fixes from the upcoming 5.94 release?

Gnome 42: Would be really cool if there was a Manjaro-Adwaita icon theme, which ensures that non-standard Gnome apps have a visually pleasing look. If you select Adwaita icon theme right now then many icons have this horrible pixelated look,

it was, however it was fixed(patched) in plasma-framework 5.93.0-4 which is what you get here, so no need to worry.


extensions (gui) won’t start

I did remember running into that (OSD bug) being mentioned. Haven’t installed this Testing update yet to confirm.

Control OSDs show up correctly on my side, so maybe other issues are also fixed?

Anyway, the update on Plasma went OK, everything seems to be working properly. The only thing I had to do, was to remove kalendar-git from AUR and instal kalendar after the update. Other then that, all went fine.

Well… maybe apart download speeds… Usually such update takes less then a minute, but this one had serious issues to download. There were several download errors and it took over an hour. Of course I updated pacman-mirrors first, didn’t help.

1 Like

I can confirm that on my laptop; I haven’t done the upgrade on the desktop yet as of writing. As @koshikas already said, the backported patches I mentioned did make it to this update, the largest I’ve ever seen since switching to this branch. You can also check in the Arch package details page for plasma-framework if you want to see which patches were applied.

I didn’t get any issues downloading the packages, but when it got to the integrity checks, some of the packages had invalid keys, so I had to install manjaro-keyring on its own first and I was able to pass that phase.

The fosshost server gave me multiple errors (pacman said something about too slow speed, I have seen this issue since the pacman parallel download option being added) I had to restart the update 5 times to finish downloading all packages.

Before posting this I was verifying the name of the server/host having issue, ran pacman-Syu and I got the name of server and the same error I got multiple times on multiple packages when I was trying to update:

error: failed retrieving file 'core.db' from mirrors.fossho.st : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds

So it may be just this server that has issues sometimes.

Almost everything working here. Except the Google Drive integration (nautilus). I tried to remove the online account and add it again sometimes and it still not working.

See top of thread:

Nope, I got exactly the same error from a UK mirror when I updated yesterday.

5 posts were split to a new topic: After waking up from suspending my system was unresponsive

Re-ordered the language in my post accordingly.
What I wanted to say is that due to these system package upgrades, any programs that were compiled against one of them, might break.
Unfortunately, I currently only have an AUR package as an example present here. I did not mean to ask for support for that particular program here. Apologies for the misunderstanding.

That is expected, and that is still off topic. Just don’t talk about AUR packages issues, deal with them on your side.

Thanks, I just wanted to share my experience in the hope that it might be useful for others. As I understand that this is not wanted here, I will delete my posts.
Thanks and apologies once again.

So that option

does not apply if AUR packages are involved, correct?

No the poll is about issues from the update. AUR or manually installed external packages not provided by Manjaro have nothing to do with the poll. People shouldn’t report it as an update issue obviously (but many do every time anyway).