[Testing Update] 2022-01-17 - OpenSearch, Kernels, KDE, Cinnamon, Pipewire, Mesa

Yes, it’s a minor update, so there won’t be a new update thread.

I’ve to fix the mismatch of Virtualbox versions after adding the kernel update.

AUR Search results showing like this

edit: Solved, it working now , it solved itself

It’s a AUR package so have you enabled AUR? Click on the 3 dots > Preferences > Third Party > AUR.

Don’t use a VPN, don’t get blocked from AUR, then it will work.

It’s working. Start pamac from terminal, give terminal output when you search.

I think there may be issues with the aur atm as its happening to me now. Whatever i search for in the aur comes back with the same “No package found”


Refreshing database seems to fix it

Ah, this is why! I was wondering what happened, and I couldn’t believe it was supposed to be an upgrade. It looks really awful. Will there be any solution to that? Maybe a separate qt5 version?
Or maybe I should downgrade it and keep it that way till some solution shows up.

There is qbittorrent-qt5 in the AUR, FYI.

1 Like

Ah, thanks! Downgrade is not an option, because the older version won’t even start. I’ll switch to AUR version then.

The long-term solution is for KDE to add qt6 support to its breeze themes. You can use another qt theme engine like kvantum for the time being if you want qt6 apps to have the same look as qt5.

1 Like

I do use Kvantum and the new look is still horrible. Unless there is some setting to apply it to qt6? This is new to me, so I’m clueless. Will have to check.

By the way, pamac is not seeing qbittorrent-qt5, thanks for yay that works reliably, unlike pamac.


qbittorrent-qt5 is compiled and installed. Works and looks fine. I guess this is the best solution for now. Thank you.

I haven’t tried kvantum yet. I had read it was updated to support qt6.

kvantum 1.0.0 added Qt6 support, yes:

The install.md says:

NOTE: Experimental compilation of Kvantum’s plugin against Qt6 can be done with cmake .. -DENABLE_QT5=OFF. For now, it lacks blurring support (which requires version 6 of kwindowsystem). When Qt6 becomes the default version of Qt in some distros, that compilation option will be set to OFF by default and all components of Kvantum will be compiled against Qt6.

Does it mean that it’s not enabling of this support like a regular option, the kvantum must be compiled with that option? This would mean the repo version won’t work with qt6. I guess it’s easier to install -qt5 version.

It is compiled with that option for Qt6 and without it for Qt5.

kvantum-qt5 no longer exists.

1 Like

Assuming this test branch inspired the stable released pushed this morning… was there a way found for pamac (GUI) to stop hammering AUR? Did you notice in your updates here the return of ALL package search results including AUR? I much prefer AUR packages being listed within ALL, and just wanted the feel-good that the AUR folks won’t be complaining now that this appears to be enabled again.



It still has the RPC code? isn’t that supposed to be discarded in favor of the new static database search instead?

1 Like