[Testing Update] 2021-05-12 - Kernels, KDE Frameworks, Plasma, Systemd, Mesa, LibreOffice, KDE Gear Mobile, FF, TB

Did anyone forget about informing about the next update on the forum? I just got an info that 1,4 GB of packages are waiting to get downloaded but nothing about it on the forum… And I already had installed the update this thread is actually about.

I tried updating but it throws an error at install.

yeah there’s a new update without a thread - happens sometimes ^^
only issue i have with it is btrfs-progs - so if you don’t use btrfs i can’t report any issues :wink:

with me… it doesn’t even finish the update.

you should always report indeed!
what’s the issue exactly?
I am using btrfs since the early days, I’m particularly interested…

I’ve noted it in the unstable thread for the time being (till the correct thread appears ^^).
btrfs-progs 5.12 has a bug (fixed in 5.12.1 already, should release soon) - so maybe skip that while updating :slight_smile:

Open a support thread then I guess?

This is expected, the announcement thread is made when many of the mirrors are updated, and/or when the thread is actually written.

It is pointless to announce an update if people can not update or if everyone update from the one or to up to date mirrors. If you feel like you need to wait for the announcement to do the update, then wait for it it will come in due time.

1 Like

I use BTRFS. Does this mean I should not update until btrfs-progs 5.12.1 reaches testing?

only if you use snap, it seems.

Error updating:
conflicting files:

  • plasma-workspace: /usr/share/locale/ta/LC_MESSAGES/kcm_autostart.mo already exists in filesystem (owned by plasma-desktop-primex)
    To fix it I moved kcm_autostart.mo to kcm_autostart.mo-bak and then did the update.
1 Like

Unless you have a reason for using plasma-desktop-primex, why not just replace it with regular plasma-desktop?

What does plasma-desktop-primex offer in comparison with the regular one? I just replaced it with the regular one and the update applied itself flawlessly. Did I lose anything important by doing it?


I actually got my performance back in steam proton with most games by swapping to regular plasma-desktop. I don’t even know what the change made, but all my games were lagging a lot with plasma-desktop-primex.

I updated one machine. There is an update for protobuf and while the last few times it somehow wasn’t necessary, this time we need a rebuild of compiz-easy-patch again.

i’ve not encountered any immediate issues, mainly around snapper (snapper-gui and snap-pac-grub). If you automated your snapshots in another way that doesn’t use btrfs-progs (or is not affected from the bug), you should be fine

That got fixed via btrfs-progs 5.12-2


Nice, seems to be ok on my side - thank you! :smiley:

Installed kernel 5.12 again. Still the same issue. No big problem so far though. When I want i3, I start with kernel 5.11, otherwise I have sway.