[Testing Update] 2021-04-26 - Kernels, Mesa, Wine, Ruby, JDK, KDE-Dev

Since this last update (probably with mesa), my HDMI2 output disappeared. (The HDMI connection of the laptop). eDP1 is the main screen which works.

# xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 310mm x 170mm
   1920x1080     60.01*+  59.93    40.00  
   [...]
   640x360       59.84    59.32    60.00  
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
# inxi -G
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Device-2: Logitech HD Webcam C525 type: USB driver: snd-usb-audio,uvcvideo 
           Device-3: Chicony Chicony USB2.0 Camera type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.11 driver: loaded: intel resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 21.0.3 

Doesn’t matter if kernel 5.11 or 5.12. Unfortunately, I can’t identify out-of-ordinary messages from dmesg or journalctl -xb.

# /etc/modprobe.d/i915.conf
options i915 enable_guc=2
options i915 fastboot=1
options i915 enable_fbc=1

Kernel parameters:

options root=UUID=820eeb04-e930-491c-9751-b39b8c1b13aa resume=/dev/mapper/volgroup0-rootvol resume_offset=99213311 rw quiet systemd.show_status=0 apparmor=1 lsm=lockdown,yama,apparmor systemd.unified_cgroup_hierarchy=1

There is also no error in the Xorg.0.log.

What happens if you downgrade Mesa to 21.0.2? @mithrial

I switched to stable branch, rebooted, and had the same problem. Then, I reverted to testing and after the reboot, the output is there.
Unfortunately, I don’t have any clue why this happened.

Same error here… :frowning:

Are you guys serious it is second person who ‘report same error’. Of course you have the issue. That is not an error did you even read what he posted? This is on purpose, Arch is blocking Pamac for now because of the Pamac bug.

6 Likes

This is fixed now

1 Like

Here, the update went without major problems.

The only thing I note:

On XFCE, after reboot with the new kernel, it lasts a considerable amount of time until the desktop gets fully loaded. The taskbar appears, but the background remains black, with no icons, during that time.
After about half a minute, the background image and the icons are finally loaded and the desktop works as expected.

Deleting the stored sessions as advised at several places on the net, does not really help.

Do you have any other ideas how I can improve the loading times for the XFCE desktop?

Do you know what I should do then? I have the same wireless adapter as you and I was probably using a DKMS driver as I had to do something custom to get my adapter to work when I first installed Manjaro, but in 5.12 kernel, my adapter is no longer detected. I am having to boot 5.11 kernel and then it works fine.

  1. Is linux512-headers installed?
  2. Is some module blacklisted in /etc/modprobe.d?

Have you set a specific limit for vt?

I have seen that, starting with kernel 5.12, the X screen is on vt2 instead of vt1

To be honest, I don’t even know what vt stands for in this case. So, I didn’t intentionally set any vt-value.

EDIT: Oh, wait. Do you mean virtual terminal? So, I have to find out, where such a limit to the first terminal is set.

Excuse me, I didn’t think that doing that would alter the correct order of the world. Thanks for taking the time to explain.

I don’t understand why people say that free software communities are so toxic to beginners when there are people as kind and magnanimous as you.

1 Like

Reading is encouraged.

Are you sure it’s a kernel problem? If you’re using sddm you might be affected by this one:

1 Like

In my case, I’m sure it has nothing to do with sddm. I don’t even use any DM. I either exec startx or exec sway directly from .zprofile and in the the case of X.org exec i3 is written in ~/.xinitrc
It must be something with the kernel, because X.org with i3 is working without any problem when started with kernel 5.10 or 5.11 even after the latest updates, but not with kernel 5.12.

I have the same TTY issue mentioned above. I’m not sure it started on this update. TTY1 still has the systemd output. TTY2 has Xorg-Server on it. The usable TTYs for a text-based session are TTY3 through TTY6.

1 Like

Ah, weird, yes. Seems like before I could CTRL-ALT-F2 (or F3, F4…) to go to a TTY, and from TTY I could ALT-F1 to go back to desktop.
Now F1 is for a black screen with blinking cursor, F2 is desktop, and F3->… is free TTY. Will reboot on other kernel to see if it is only 5.12.

//EDIT: no it is the same on kernel 5.10.
This ‘issue’ is pretty recent, from previous update or something like that.

https://bugs.archlinux.org/task/70528

Yes linux512-headers is installed.
rtw88_8821ce is blacklisted, however I had tried appending the file to .old and restarting but my wireless was still not detected, however you just got me thinking… This laptop has needed to be shut down and power unplugged a time or two when I’ve made driver changes and I don’t think I did that after renaming the blacklist file, so I’ll try that again with shutdown and unplug and see what happens.

Ok I’m on Linux 5.12, wifi working. I guess I just needed to kill the power completely after the update. The blacklist file is still appended .old so I assume I will no longer need it. Thanks for the help!

sddm-0.19.0-5.0 reverts to Revision 4 state. However I also did sddm-0.19.0-5.1, which reflects the latest git-develop state. Maybe @chainofflowers you can test that also.

https://sourceforge.net/projects/manjarodev/files/users/philm/sddm/

1 Like