[Testing Update] 2021-02-10 - Kernels, AMDVLK, Palemoon, Firefox-dev, Firefox, Haskell, Python

Hello community,

Another testing branch update with some usual updates for you.

Test out the latest Linux kernel … #stayhome, #staysafe, #stayhealthy

  • Most of the Kernels got updated
  • A lot of Browsers got updated
  • A new AMDVLK release: 21.Q1.3
  • Other regular upstream updates including python and haskell
  • Introduction of kde-unstable repo

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE

Our current supported kernels

  • linux44 4.4.257
  • linux49 4.9.257
  • linux414 4.14.221
  • linux419 4.19.175
  • linux54 5.4.97
  • linux59 5.9.16 [EOL]
  • linux510 5.10.15
  • linux511 5.11-rc7
  • linux54-rt 5.4.93_rt51
  • linux59-rt 5.9.1_rt19

Packages Changes (Wed Feb 10 13:07:09 CET 2021)

  • testing kde-unstable x86_64: 362 new and 0 removed package(s)
  • testing community x86_64: 1319 new and 1287 removed package(s)
  • testing core x86_64: 31 new and 31 removed package(s)
  • testing extra x86_64: 327 new and 379 removed package(s)
  • testing multilib x86_64: 5 new and 5 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Recent Arch Linux news:

PHP 8.0 and PHP 7 legacy packages are available

PHP 8.0 and PHP 7 legacy packages are available

2021-01-28 - Pierre Schmitz

The php package has been updated to version 8.0. Please refer to the upstream migration guide. As some applications are not compatible with PHP 8 yet we provide a php7 package which can be installed alongside version 8. Packages that depend on PHP reflect this update and will require php7 if needed. You might need to update your configuration accordingly. PHP 7 binaries and configuration have the “7” suffix:

  • /usr/bin/php → /usr/bin/php7
  • /etc/php → /etc/php7
  • /usr/bin/php-fpm → /usr/bin/php-fpm7
  • /usr/lib/systemd/system/php-fpm.service → /usr/lib/systemd/system/php-fpm7.service
  • /run/php-fpm → /run/php-fpm7

We also provide third party modules compiled for PHP 7:

Note that support for php7 will be limited and likely be dropped in about a year depending on how soon the majority of applications will be compatible with version 8.


Chromium losing Sync support in early March

Chromium losing Sync support in early March

2021-02-03 - Evangelos Foutras

Google has announced that they are going to block everything but Chrome from accessing certain Google features (like Chrome sync) starting on March 15. This decision by Google is going to affect Arch’s chromium package a bit earlier, on March 2, when Chromium 89 gets released.

We know for sure that data syncing will stop working (passwords, bookmarks, etc.). Other features such as geolocation or enhanced spell check might continue to function for a bit longer. Extensions integrating with Google Drive might misbehave and LibreOffice will lose access to documents stored there.

Other distros such as openSUSE and Fedora have already removed the soon-to-be-limited API keys from their Chromium 88 packages. Fedora’s advisory provides a great deal of perspective on this and I also found this Hackaday post to be quite informative.


Older Issues

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: https://forum.manjaro.org/c/support/Graphic-Cards/33 or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.


OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Fehler: Konnte den Vorgang nicht durchführen (In Konflikt stehende Dateien)
psmisc: /usr/share/man/de/man1/fuser.1.gz existiert im Dateisystem (gehört zu man-pages-de)
psmisc: /usr/share/man/de/man1/killall.1.gz existiert im Dateisystem (gehört zu man-pages-de)
psmisc: /usr/share/man/de/man1/peekfd.1.gz existiert im Dateisystem (gehört zu man-pages-de)
psmisc: /usr/share/man/de/man1/prtstat.1.gz existiert im Dateisystem (gehört zu man-pages-de)
psmisc: /usr/share/man/de/man1/pslog.1.gz existiert im Dateisystem (gehört zu man-pages-de)
psmisc: /usr/share/man/de/man1/pstree.1.gz existiert im Dateisystem (gehört zu man-pages-de)

How to fix this and continue update?


Running cinnamon and update has broken the desktop. I can still launch things from the panel but I can’t do anything at all on the desktop. Right click, left click , can’t do anything. Also nemo won’t respond either so guessing it’s tied in together

Known issue: FS#69578 : [psmisc man-pages-l10n] File conflict on psmisc 23.4-1 and man-pages-l10n 4.2.0-1


Thanks - moveing the files in question to *.old made the update work though.

Well if one doesn’t speak german why not do a # pacman -R man-pages-de instead? :stuck_out_tongue:

With the --overwrite parameter, you can define which files are allowed to be overwritten with the update:
pacman -Su --overwrite "/usr/share/de/man1/*.gz"

1 Like

Its definitely nemo that’s broken in the update, I think its nemo-preview 4.8.0-4 that’s the problem

Edit tried downgrading nemo-preview and nemo-python no joy. Nemo just won’t respond unless it’s launched as root

Kernel 5.10.15 just appeared on the Stable channel - was this intended?

Looks that way. See here

Had the same issue. I resolved it with this:

pacman -S --overwrite "*" psmisc

i have theses orphans

sudo pacman -Qdt
alsa-card-profiles 1:0.3.21-1
go 2:1.15.8-1
kvantum-theme-matcha 20190810-1
lib32-alsa-oss 1.1.8-2
lib32-lz4 1.9.3-1

you could try ```
sudo pacman -Rns $(pacman -Qtdq)

The problem with relying on pacman -Qdt output is that it ALSO lists some packages installed when you built something from AUR. For example, go package was likely pulled for building some app written in Go language. So if you remove it, next time when there’s an update to your AUR app, it will be pulled and installed again. So if you have some apps which are usually built from source, it might be a better approach to leave make dependencies installed and mark them explicitly installed so they won’t be listed when querying with -Qdt flags. That’s usually are boost, rust and go. To mark them, issue sudo pacman -D --asexplicit <packagename>

1 Like

For me too, your command helped. Thank you.

I’ve figured out the issue with nemo and the latest update but have no idea to fix it. No matter what theme I run I get the following gtk error

Current gtk theme is not known to have nemo support (CBlack) - checking…

and it just hangs there until I have to fc nemo. I’ve tried every theme there is and its the same issue, I have to select a theme so nemo and the desktop are unusable


Seems megasync was the issue, removing megasync and nemo-megasync plugin fixed it

Hello folks,

can someone explain briefly why we insist on having the nvidia-uvm module removed from Nvidia driver 390?

    # Fix compile problem with 5.10
    # FATAL: modpost: GPL-incompatible module nvidia-uvm.ko uses GPL-only symbol 'radix_tree_preloads'
    msg2 "PATCH: disable-module-nvidia-uvm"    
    patch -p1 -i "$srcdir"/disable-module-nvidia-uvm.patch

If I understand the comment correctly, there was formerly a compile problem due to a GPL issue. As I cannot reproduce this problem here anymore (driver compiles well with nvidia-uvm included), I am just wondering why it is still necessary to have the nvidia-uvm module removed from the linux510-nvidia390xx package.

Is it safe to do? Won’t it change package ownership of those files which could cause similar issue in the future? I’m just asking, because I don’t understand how this package ownership works.

@philm, what is the advised solution? Move to .old, overwrite or any will do? Or maybe wait for the upstream fix?

I’m using video-hybrid-amd-nvidia-prime, and since this driver update (460), I can’t run any game or blender. I’ve tried changing the kernel to LTS, fully uninstalled and installed steam, deleted all installed games (but later found that other 3D applications were affected). The AMD (Vega) GPU runs flawlessly.