[Testing Update] 2021-02-05 - Kernels, Gnome 40-Alpha, KDE Apps 20.12.2, Systemd, Mesa, LibreOffice 7.1

Hello community,

Another testing branch update with some usual updates for you. Since most of our team is focusing on ARM architecture and the pinephone, updates to Manjaro x64 might be more delayed for February. However we managed to squeeze this one in.

People with the hang of Gnome may test our lastest developer images with Gnome 40! #stayhome, #staysafe, #stayhealthy

  • Most of the Kernels go updated
  • A lot of effort went into Gnome 40
  • Some Deepin packages got updated
  • Firefox and Thunderbird got renewed: FF 85.0.1, TB 78.7.0
  • Systemd is now at 247.3
  • Nvidia driver got updated to 460.39
  • ZFS is now updated to 2.0.2
  • A new point-release of KDE-Apps 20.12 landed in our repos
  • AMDVLK is now at 2021.Q1.2
  • LibreOffice got renewed to 7.0.4 and 7.1.0
  • Mesa is now at 20.3.4
  • Other regular upstream updates including python and haskell

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE

Our current supported kernels

  • linux44 4.4.255
  • linux49 4.9.255
  • linux414 4.14.219
  • linux419 4.19.173
  • linux54 5.4.95
  • linux59 5.9.16 [EOL]
  • linux510 5.10.13
  • linux511 5.11-rc6
  • linux54-rt 5.4.93_rt51
  • linux59-rt 5.9.1_rt19

Packages Changes (Fri Feb 5 18:53:25 CET 2021)

  • testing community x86_64: 1677 new and 1598 removed package(s)
  • testing core x86_64: 35 new and 35 removed package(s)
  • testing extra x86_64: 962 new and 1104 removed package(s)
  • testing multilib x86_64: 42 new and 42 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Recent Arch Linux news:

PHP 8.0 and PHP 7 legacy packages are available

PHP 8.0 and PHP 7 legacy packages are available

2021-01-28 - Pierre Schmitz

The php package has been updated to version 8.0. Please refer to the upstream migration guide. As some applications are not compatible with PHP 8 yet we provide a php7 package which can be installed alongside version 8. Packages that depend on PHP reflect this update and will require php7 if needed. You might need to update your configuration accordingly. PHP 7 binaries and configuration have the “7” suffix:

  • /usr/bin/php → /usr/bin/php7
  • /etc/php → /etc/php7
  • /usr/bin/php-fpm → /usr/bin/php-fpm7
  • /usr/lib/systemd/system/php-fpm.service → /usr/lib/systemd/system/php-fpm7.service
  • /run/php-fpm → /run/php-fpm7

We also provide third party modules compiled for PHP 7:

Note that support for php7 will be limited and likely be dropped in about a year depending on how soon the majority of applications will be compatible with version 8.


Chromium losing Sync support in early March

Chromium losing Sync support in early March

2021-02-03 - Evangelos Foutras

Google has announced that they are going to block everything but Chrome from accessing certain Google features (like Chrome sync) starting on March 15. This decision by Google is going to affect Arch’s chromium package a bit earlier, on March 2, when Chromium 89 gets released.

We know for sure that data syncing will stop working (passwords, bookmarks, etc.). Other features such as geolocation or enhanced spell check might continue to function for a bit longer. Extensions integrating with Google Drive might misbehave and LibreOffice will lose access to documents stored there.

Other distros such as openSUSE and Fedora have already removed the soon-to-be-limited API keys from their Chromium 88 packages. Fedora’s advisory provides a great deal of perspective on this and I also found this Hackaday post to be quite informative.


Older Issues

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: https://forum.manjaro.org/c/support/Graphic-Cards/33 or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.


OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Latest pipewire-pulse update to 0.3.21 has made a huge positive change in usability in my end replacing pulseaudio.

Now at least it auto sets the default output sink when connecting BT headphones and the running audio streams are automatically moved to it. And it seems volume levels are remembered (most of the time).

Surely there still has to be lots of bugs in more complicated setups, but this is a big step in the right direction.


Getting the following error with docker if I try to start existing containers or new ones:

Error response from daemon: OCI runtime create failed: container_linux.go:367: starting container process caused: process_linux.go:495: container init caused: apply apparmor profile: apparmor failed to apply profile: write /proc/self/attr/exec: invalid argument: unknown

I’ve tried restarting apparmor and docker services; no change.

Edit: Seems docker is incompatible with LSM changes made with kernel 5.10.13?

1 Like

Should I use unstable for a more up-to-date system?

I just found out about the Pinephone and I’m super excited the Manjaro Team is getting involved! Really want to kick my Android to the curb and forget Google’s spyware. Can’t wait to see what comes in the future.

1 Like

Replace gnome 40 alpha from AUR with official. Everything fine.

Still up to date: (Now it’s just version 2.5.8.r48.g9b70f24e9-1)

I’m still using an older version, which works.

For testing gnome 40 there is gnome-shell-dev in the official repos…

I know, I just said that I replaced package from AUR with that.

after update digikam does not start anymore

Telegram Desktop resets Theme and Language setting (even after restoring /.local/share/TelegramDesktop from Backup) other than that everything seems fine here on KDE/AMD :+1:

And while i’m really looking forward to something like the pinephone being ready for a daily driver, i also hope you don’t neglect x64 too much :stuck_out_tongue_winking_eye:

1 Like

Some more updates to round this one up …

BoxIt memo

User philip created a snapshot of branch ‘unstable’ to ‘testing’.

  • testing community x86_64: 149 new and 150 removed package(s)
  • testing core x86_64: 19 new and 20 removed package(s)
  • testing extra x86_64: 13 new and 14 removed package(s)
  • testing multilib x86_64: 1 new and 1 removed package(s)
:: Different sync package(s) in repository community x86_64

                             PACKAGE           2021-02-05           2021-02-06
                          argocd-cli              1.8.3-1              1.8.4-1
                           bctoolbox             4.4.26-1             4.4.27-1
                               broot              1.2.1-1              1.2.3-1
                           bsd-games                3.0-2                3.1-1
                               bzrtp             4.4.26-1             4.4.27-1
                             cryptol            2.10.0-59            2.10.0-61
                               darcs            2.16.3-71            2.16.3-72
                               dhall            1.37.1-32             1.38.0-1
                          dhall-bash            1.0.35-53             1.0.36-1
                          dhall-json             1.7.4-51              1.7.5-1
                    dhall-lsp-server            1.0.12-49             1.0.13-1
                          dhall-yaml             1.2.4-39              1.2.5-1
                 digikam-plugin-gmic              2.9.4-1                    -
                            electron             11.2.1-3             11.2.3-1
                          fingerterm             1.3.11-2             1.3.13-1
                    gimp-plugin-gmic              2.9.4-1              2.9.5-1
                           git-annex         8.20210127-2         8.20210127-3
                               gitea             1.13.1-1             1.13.2-1
                                gmic              2.9.4-1              2.9.5-1
                    haskell-arch-web             0.1.0-18             0.1.0-19
                haskell-authenticate            1.3.5-267            1.3.5-268
                         haskell-aws             0.22-199             0.22-200
                       haskell-brick            0.58.1-26               0.59-1
       haskell-cabal-install-parsers               0.4-41               0.4-42
                 haskell-casa-client            0.0.1-199            0.0.1-200
                  haskell-casa-types             0.0.2-40             0.0.2-41
                          haskell-ci           0.10.3-138           0.10.3-140
                         haskell-dav            1.3.4-254            1.3.4-255
                        haskell-dbus             1.2.18-7             1.2.18-8
                  haskell-fdo-notify            0.3.1-406            0.3.1-407
                          haskell-gi            0.24.7-23            0.24.7-24
                    haskell-gi-cairo            1.0.24-59            1.0.24-60
                     haskell-git-lfs             1.1.1-48             1.1.1-49
             haskell-haddock-library             1.9.0-94             1.9.0-95
                 haskell-hledger-lib            1.20.3-11             1.20.4-1
                        haskell-hosc              0.18-58              0.18-59
                       haskell-hpack            0.34.3-38            0.34.3-39
                        haskell-http         4000.3.15-92         4000.3.15-93
                 haskell-http-client              0.7.5-1              0.7.5-2
      haskell-http-client-restricted             0.0.4-16             0.0.4-17
                   haskell-js-jquery            3.3.1-584            3.3.1-585
                       haskell-lucid            2.9.12-91            2.9.12-92
                    haskell-memotrie            0.6.10-77            0.6.10-78
                   haskell-mime-mail             0.5.0-90             0.5.0-91
                    haskell-mustache            2.3.1-262            2.3.1-263
                haskell-mysql-simple             0.4.5-33             0.4.5-34
            haskell-newtype-generics             0.5.4-77                0.6-1
                  haskell-pipes-http            1.0.6-288            1.0.6-289
                         haskell-req             3.9.0-13             3.9.0-14
                      haskell-scotty              0.12-64              0.12-65
              haskell-servant-client            0.18.2-18            0.18.2-19
              haskell-servant-server            0.18.2-18            0.18.2-19
                       haskell-shake            0.19.4-16            0.19.4-17
                 haskell-shakespeare            2.0.25-64            2.0.25-65
                 haskell-skylighting            0.10.2-13            0.10.2-14
            haskell-skylighting-core            0.10.2-13            0.10.2-14
           haskell-tagstream-conduit             0.5.6-89             0.5.6-90
        haskell-tamarin-prover-sapic             1.6.0-57             1.6.0-58
         haskell-tamarin-prover-term             1.6.0-45             1.6.0-46
       haskell-tamarin-prover-theory             1.6.0-57             1.6.0-58
        haskell-tamarin-prover-utils             1.6.0-42             1.6.0-43
                       haskell-tidal                1.7-7                1.7-8
                   haskell-tree-diff              0.1-189              0.1-190
                    haskell-trifecta              2.1-130              2.1-131
                         haskell-vty              5.32-35              5.32-36
       haskell-wai-middleware-static             0.9.0-64             0.9.0-65
                        haskell-warp             3.3.14-2             3.3.14-3
                    haskell-warp-tls            3.3.0-122            3.3.0-123
                  haskell-yesod-form            1.6.7-366            1.6.7-367
                  haskell-yesod-test            1.6.12-47            1.6.12-48
                             hledger            1.20.3-12             1.20.4-1
                          hledger-ui            1.20.3-12             1.20.4-1
                         hledger-web            1.20.3-18             1.20.4-1
                      hopenpgp-tools            0.23.6-17            0.23.6-18
                               idris            1.3.3-165            1.3.3-166
                                jmol           14.31.29-1           14.31.31-1
                               jsmol           14.31.29-1           14.31.31-1
                   krita-plugin-gmic              2.9.4-1              2.9.5-1
                        matterbridge             1.21.0-1             1.22.0-1
                       mediastreamer             4.4.26-1             4.4.27-1
                             openvdb              8.0.0-1              8.0.1-1
                                ortp             4.4.26-1             4.4.27-1
                              pandoc            2.11.3-21            2.11.3-23
                 perl-ppix-quotelike              0.014-1              0.015-1
                           postgrest            7.0.1-215            7.0.1-216
                    python-construct            2.10.56-3            2.10.57-1
                   python-ghp-import              1.0.0-1              1.0.1-1
                         python-praw              7.1.2-1              7.1.3-1
                          shellcheck            0.7.1-269            0.7.1-271
                               stack            2.5.1-103            2.5.1-104
                      tamarin-prover            1.6.0-126            1.6.0-127
                             taskell           1.10.1-106           1.10.1-108
         v2ray-domain-list-community     20210205091654-1     20210205154624-1
                              xmobar              0.36-97              0.36-98
                                  yq             2.11.1-2             2.12.0-1
                                zart              2.9.4-1              2.9.5-1

:: Different overlay package(s) in repository core x86_64

                             PACKAGE           2021-02-05           2021-02-06
                            autoconf               2.71-0                    -
                            linux510            5.10.13-1            5.10.13-2
                    linux510-headers            5.10.13-1            5.10.13-2

:: Different sync package(s) in repository core x86_64

                             PACKAGE           2021-02-05           2021-02-06
                            autoconf               2.70-1               2.71-1
                            binutils             2.35.1-1               2.36-3
                               bison              3.7.2-1              3.7.3-1
                           findutils              4.7.0-2              4.8.0-1
                                 gcc             10.2.0-4             10.2.0-6
                             gcc-ada             10.2.0-4             10.2.0-6
                               gcc-d             10.2.0-4             10.2.0-6
                         gcc-fortran             10.2.0-4             10.2.0-6
                              gcc-go             10.2.0-4             10.2.0-6
                            gcc-libs             10.2.0-4             10.2.0-6
                            gcc-objc             10.2.0-4             10.2.0-6
                               glib2             2.66.4-2             2.66.6-1
                          glib2-docs             2.66.4-2             2.66.6-1
                               glibc               2.32-5               2.33-3
                      lib32-gcc-libs             10.2.0-4             10.2.0-6
                         lib32-glibc               2.32-5               2.33-3
                   linux-api-headers                5.8-1            5.10.13-1

:: Different overlay package(s) in repository extra x86_64

                             PACKAGE           2021-02-05           2021-02-06
                            chromium      88.0.4324.150-1                    -
                  linux510-acpi_call             1.1.0-27             1.1.0-28
                   linux510-bbswitch               0.8-27               0.8-28
               linux510-nvidia-390xx           390.141-14           390.138-15
                     linux510-nvidia             460.39-6             460.39-7
                      linux510-r8168          8.048.03-27          8.048.03-28
                  linux510-rtl8723bu          20201124-27          20201124-28
                   linux510-tp_smapi              0.43-27              0.43-28
                linux510-vhba-module          20200106-27          20200106-28
   linux510-virtualbox-guest-modules             6.1.18-7             6.1.18-8
    linux510-virtualbox-host-modules             6.1.18-7             6.1.18-8
                        linux510-zfs              2.0.2-2              2.0.2-3

:: Different sync package(s) in repository extra x86_64

                             PACKAGE           2021-02-05           2021-02-06
                            chromium      88.0.4324.146-2      88.0.4324.150-1
                            valgrind             3.16.1-2             3.16.1-4

:: Different sync package(s) in repository multilib x86_64

                             PACKAGE           2021-02-05           2021-02-06
                         lib32-glib2             2.66.4-2             2.66.6-1

I don’t know if it’s because of this update or a result of the update before. In any case firstly with this update and with the next following today I get an error-message on using sudo pacman-mirrors --fasttrack && sudo pacman -Syyu

FEL: GPGME-fel: Inget data
FEL: Kunde inte uppdatera core (ogiltig eller korrupt databas (PGP-signatur)

I tried with all you can find in the wiki-article Pacman troubleshooting - Manjaro But the error is recuring next time i use the usual update-line

Strangly enough the update with sudo pacman-mirrors -f5 && sudo pacman -Syyuu is working. But the error is back again on the next try with already shown command.

Was the downgrade of the linux510-nvidia-390xx package intentional?

If yes, the other nvidia-390xx packages also need to downgrade so I can update.

I wasn’t showing either of the updates even after refreshing databases in pamac gui or running sudo pacman -Syyu but running

sudo pacman-mirrors --fasttrack && sudo pacman -Syyu

did fix my issues and now both updates appear

Docker is back to being functional again :slight_smile:

Thx for the feedback mate.

Another set of updated packages:

BoxIt memo

User philip created a snapshot of branch ‘unstable’ to ‘testing’.

  • testing community x86_64: 2 new and 2 removed package(s)
  • testing extra x86_64: 1 new and 1 removed package(s)
:: Different overlay package(s) in repository community x86_64

                             PACKAGE              testing             unstable
                               brave            1.19.84-1            1.19.92-1
                          brave-beta            1.20.78-1            1.21.44-1

:: Different overlay package(s) in repository extra x86_64

                             PACKAGE              testing             unstable
               linux510-nvidia-390xx           390.138-15           390.141-15
1 Like

This update broke the clock module from py3status, a status bar replacement for i3wm. Downgrading from 3.32 to 3.31 fixes the clock.

Edit: This will be fixed with the next version.