[Testing Update] 2021-01-25 - Kernels, Deepin, Haskell, Python, LibRetro, Virtualbox, Gstreamer

Hello community,

Another testing branch update with some usual updates for you.

Don’t miss out on the second beta of Plasma-Mobile for your Pinephone! #stayhome, #staysafe, #stayhealthy

  • Most of the Kernels go updated
  • Virtualbox is now at 6.1.18
  • Deepin got more package updates
  • Lot of new Haskell and Python packages
  • Most of LibRetro got renewed
  • Another bug-fix release of Gstreamer
  • Other regular upstream updates

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest Manjaro Ornara 21.0 preview release! KDE, XFCE and Gnome

Our current supported kernels

  • linux44 4.4.253
  • linux49 4.9.253
  • linux414 4.14.217
  • linux419 4.19.170
  • linux54 5.4.92
  • linux59 5.9.16 [EOL]
  • linux510 5.10.10
  • linux511 5.11-rc5
  • linux54-rt 5.4.87_rt48
  • linux59-rt 5.9.1_rt19

Packages Changes (Mon Jan 25 08:50:50 CET 2021)

  • testing community x86_64: 1231 new and 1185 removed package(s)
  • testing core x86_64: 43 new and 42 removed package(s)
  • testing extra x86_64: 230 new and 212 removed package(s)
  • testing multilib x86_64: 11 new and 11 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Older Issues

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: https://forum.manjaro.org/c/support/Graphic-Cards/33 or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.


OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

A few glitches again.

At first, python (which is no surprise as it appears to be prone to such issues):

python-pip: /usr/lib/python3.9/site-packages/pip/_internal/resolution/resolvelib/__pycache__/reporter.cpython-39.pyc exists in the file system
python-pip: /usr/lib/python3.9/site-packages/pip/_internal/resolution/resolvelib/reporter.py exists in the file system

Second (but I guess this will remain as long as we have the Nvidia driver 390 available this way):

==> Building image from preset: /etc/mkinitcpio.d/linux510.preset: 'default'
  -> -k /boot/vmlinuz-5.10-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.10-x86_64.img
==> Starting build: 5.10.10-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [systemd]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [filesystems]
==> ERROR: module not found: `nvidia_uvm'

Otherwise, no problems so far.

This could indicate that something has been installed with sudo pip install instead of pacman.
Like pip it self maybe?

My ifi USB DAC is no longer recognised by 5.11-rc5. It was working fine with rc3. Switched back to 5.10 and all is well again.

Not recently, but I recall having tried a client for Onedrive some time ago (the most famous one, at GitHub - xybu/onedrived-dev: A Microsoft OneDrive client for Linux, written in Python3.).
Possibly, this error was a remnant of that activity (pity that there is no Onedrive client in Manjaro’s repos).

After the update, lutris is not starting. Terminal output:

    Traceback (most recent call last):
  File "/usr/bin/lutris", line 52, in <module>
    from lutris.gui.application import Application  # pylint: disable=no-name-in-module
  File "/usr/lib/python3.9/site-packages/lutris/gui/application.py", line 41, in <module>
    from lutris.gui.installerwindow import InstallerWindow
  File "/usr/lib/python3.9/site-packages/lutris/gui/installerwindow.py", line 17, in <module>
    from lutris.installer import interpreter
  File "/usr/lib/python3.9/site-packages/lutris/installer/interpreter.py", line 14, in <module>
    from lutris.installer.installer import LutrisInstaller
  File "/usr/lib/python3.9/site-packages/lutris/installer/installer.py", line 16, in <module>
    from lutris.services import get_services
  File "/usr/lib/python3.9/site-packages/lutris/services/__init__.py", line 2, in <module>
    from lutris.services.gog import GOGService
  File "/usr/lib/python3.9/site-packages/lutris/services/gog.py", line 9, in <module>
    from lxml import etree
ModuleNotFoundError: No module named 'lxml'

Edit: downgrading lutris to helped

AMDVLK, got corrected, no problem with some games anymore…

Everything seems fine from my end. No errors and I haven’t found anything funny after reboot. Thanks to the dev. team.

Yes, the package is broken. Arch just did a version bump without looking at upstream changes. python-lxml is a new dependency among other things. I would do an overlay, but there are other upstream issues that need to be dealt with before there’s reallly a stable package to manage.

In the meantime, I suggest installing lutris-git from the AUR. I’m the maintainer, so you’re in good hands. :wink:

  1. My logitech M590 cursor cannot move.

Solution: Bluetooth mouse - ArchWiki

2.User icon cannot change and does not fit the circle

this problem has not been fixed.

If you install python-lxml package works, all my games are accessable and playable.

1 Like

Is there an echo in here? I’m pretty sure I just said that. :wink:

1 Like

@echo is off

1 Like

Have you tried https://github.com/abraunegg/onedrive? I’m using it on Ubuntu as Manjaro.

Indeed, as it looks like that version by xybu is not maintained since ages, I have switched to the version provided by abraunegg as well.
There are more and more problems trying to install xybu’s version, fortunately I came across abraunegg’s posting there.

Looks like xybu has performed an excellent job on search engine optimization, though.
Although the last update is already more than 2 years ago, it still appears on top of the search results when looking for an Onedrive client for Linux on Google, while abraunegg’s version is never found there.
Respect :smile:

So thank you very much for pointing to GitHub - abraunegg/onedrive: #1 Free OneDrive Client for Linux - this works much better than that older client.

1 Like

The libpulse and pulseaudio (14.2-1 to 14.2-2) update broke my audio, I had to copy my custom sound profile from:




to fix it.

The changed volume up/down-sound confused me a bit, but other than that, everything seems fine here on KDE/amd :slight_smile:

I had issues with PulseEffects after upgrading to 5.0.0.

Fortunately the explanation can be found here - GitHub - wwmm/pulseeffects: Limiter, compressor, reverberation, equalizer and auto volume effects for Pulseaudio applications

From version 5.0.0 onward PulseEffects needs PipeWire. Pulseaudio users need to instal one of the 4.x releases or building a package directly from our legacy Pulseaudio branch GitHub - wwmm/pulseeffects at pulseaudio-legacy. Arch Linux users can also use the PKGBUILD on the same branch. This branch will receive updates for critical bugs as time goes by. So if PipeWire is not for you yet it is fine to use the legacy branch.

So I’ve decided to use the legacy branch for now. It’s available from AUR and can be installed via pamac-manager, etc. pulseeffects-legacy-git 4.8.4r10.gc63827fc-1 & gst-plugins-pulseeffects-legacy-git 4.8.4r10.gc63827fc-1

All be chill now. Thnx AUR


Since the latest updates i’m having temperature problems. It seems my cpu now run at maximum frequency all the time, like if it’s in a high performance governor. I have manjaro testing branch running in 2 systems (intel desktop i7 9700k and a intel laptop i7-1065G7) and both are having the same issue.