[Testing Update] 2020-12-22 - Kernels, Pamac 10.0.1, Firefox-Beta, Nvidia, KDE-git

Hello community,

Another testing branch update with some usual updates for you. Remember that we expect possible breakage of your system with this update!

Find out what changed in Pamac v10!.. #stayhome, #staysafe, #stayhealthy

  • 5.x Kernels got updated. 5.9 kernel series is now marked EOL
  • A lot of KDE-git packages got updated
  • Pamac updated to v10.0.1
  • Firefox got another beta release
  • Nvidia legacy driver got updated to 390.138.
  • Other regular upstream updates

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest Manjaro Nibia 20.2 release! KDE, XFCE and Gnome

Our current supported kernels

  • linux44 4.4.248
  • linux49 4.9.248
  • linux414 4.14.212
  • linux419 4.19.163
  • linux54 5.4.85
  • linux59 5.9.16 [EOL]
  • linux510 5.10.2
  • linux54-rt 5.4.82_rt45
  • linux59-rt 5.9.1_rt19

Packages Changes (Mon Dec 21 23:55:35 CET 2020)

  • testing community x86_64: 356 new and 343 removed package(s)
  • testing core x86_64: 8 new and 8 removed package(s)
  • testing extra x86_64: 85 new and 98 removed package(s)
  • testing multilib x86_64: 15 new and 22 removed package(s)

A detailed list of all changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

Older Issues

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.


OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

When updating the mirrors I got this message:

::FEHLER [Errno -2] Name or service not known 'https://mirror.philpot.de/manjaro/'

2 posts were split to a new topic: Terminator fails to start

Could you please let us know when the oled patches are included in the 510 series, currently it is included in the 59 series, so I’d like to know when to upgrade the kernel (I have an oled laptop).

1 Like

I updated the mirrors from preferences panel but some mirrors are out of date, others are partially updated; what can I do?
It’s impossible to update AUR apps since Pamac 10!

Mousepad dosn’t not open . No error in console, just the nomber of processus .
Solved by typing mousepad -o window

I can’t confirm as I just updated a bunch of AUR packages via Pamac 10.0.1: https://gitlab.manjaro.org/-/snippets/569/raw

1 Like

So far so good, will try to change to Nvidia later tonight.

A post was merged into an existing topic: Terminator fails to start

partial output from dig

➜  ~ dig mirror.philpot.de                                                  

; <<>> DiG 9.16.10 <<>> mirror.philpot.de
;mirror.philpot.de.		IN	A

philpot.de.		10800	IN	SOA	emma.ns.cloudflare.com. dns.cloudflare.com. 2035957902 10000 2400 604800 3600

;; WHEN: tir dec 22 19:03:46 CET 2020

There is no DNS for the mirror host.

my problem got solved now, so guess the mirror i was on was a bit behind

it’s OK Xfce screen locker ( light-lock ) is working now

Don’t know why, but few days ago I tried to move (again) to GNOME with clean install, found that Nvidia-utils conflicts with Nvidia-455xx-utils (IF I remember the error correct). Made a clean install of KDE, and now I can’t change to Nvidia on kernel 5.10 using optimus-manager.
Log from /var/log/optimus-manager/switch/switch-20201222T202210.log

optimus-manager log
[17] INFO: # Xorg pre-start hook
[17] INFO: Previous state was: {'type': 'pending_pre_xorg_start', 'requested_mode': 'nvidia', 'current_mode': 'integrated'}
[17] INFO: Requested mode is: nvidia
[234] INFO: Available modules: ['nouveau', 'nvidia', 'nvidia_drm', 'nvidia_modeset', 'nvidia_uvm']
[234] INFO: Unloading modules ['nouveau'] (if loaded)
[237] INFO: switching=none, nothing to do
[275] INFO: Loading module nvidia
[401] ERROR: Xorg pre-start setup error
Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/optimus_manager/bash.py", line 11, in exec_bash
    out = subprocess.check_output(
  File "/usr/lib/python3.9/subprocess.py", line 420, in check_output
    return run(*popenargs, stdout=PIPE, timeout=timeout, check=True,
  File "/usr/lib/python3.9/subprocess.py", line 524, in run
    raise CalledProcessError(retcode, process.args,
subprocess.CalledProcessError: Command '['bash', '-c', 'modprobe nvidia NVreg_UsePageAttributeTable=1']' returned non-zero exit status 1.

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/optimus_manager/kernel.py", line 238, in _load_module
    exec_bash("modprobe %s %s" % (module, options))
  File "/usr/lib/python3.9/site-packages/optimus_manager/bash.py", line 18, in exec_bash
    raise BashError(
optimus_manager.bash.BashError: Failed to execute 'modprobe nvidia NVreg_UsePageAttributeTable=1' :
modprobe: ERROR: could not insert 'nvidia': Exec format error

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/optimus_manager/hooks/pre_xorg_start.py", line 51, in main
    setup_kernel_state(config, prev_state, requested_mode)
  File "/usr/lib/python3.9/site-packages/optimus_manager/kernel.py", line 22, in setup_kernel_state
    _nvidia_up(config, hybrid=(requested_mode == "hybrid"))
  File "/usr/lib/python3.9/site-packages/optimus_manager/kernel.py", line 91, in _nvidia_up
    _load_nvidia_modules(config, available_modules)
  File "/usr/lib/python3.9/site-packages/optimus_manager/kernel.py", line 134, in _load_nvidia_modules
    _load_module(available_modules, "nvidia", options="NVreg_UsePageAttributeTable=%d" % pat_value)
  File "/usr/lib/python3.9/site-packages/optimus_manager/kernel.py", line 240, in _load_module
    raise KernelSetupError("error running modprobe for %s : %s" % (module, str(e)))
optimus_manager.kernel.KernelSetupError: error running modprobe for nvidia : Failed to execute 'modprobe nvidia NVreg_UsePageAttributeTable=1' :
modprobe: ERROR: could not insert 'nvidia': Exec format error

[402] INFO: Removing /etc/X11/xorg.conf.d/10-optimus-manager.conf (if present)
[402] INFO: Writing state {'type': 'pre_xorg_start_failed', 'switch_id': '20201222T202210', 'requested_mode': 'nvidia'}

This is strange, because before this adventure of mine to change to GNOME, optimus-manager was working on kernel 5.10 on KDE. Maybe I missed some step this time around??

I was also on testing that time around.

I also could update AUR packages without problems through pamac.

I switched from Stable to Testing yesterday on my main computer, with an NVIDIA GeForce GTX 970 in it.

After upgrade, it was still running drivers from the old (and now foreign, i.e. not in any repository at all) packages instead of the new ones. If I did not noticed it, my system could have failed anytime in the future because my GPU drivers would not have been upgraded.

I made the switch myself by uninstalling the old packages (now foreign, so easy to find with Pamac) and install the rolling drivers with Manjaro Settings Manager (with video-nvidia).

Did I miss a “manual intervention required” warning posted somewhere?

1 Like

I noticed a similar issue with mousepad after the previous update.
If you have another mousepad window minimised, launching mousepad again will create a new tab, but will not bring the window into focus anymore.
The behaviour could be changed from edit->preferences->window-> open files in: new window.
Nevertheless, I would prefer the new tab option to bring the window back on top, it is rather confusing otherwise.

I just upgraded to kernel 5.10, checked switching to hybrid mode with optimus-manager, run Steam, it used Nvidia correctly, all good on my end. Using Plasma.

Yeah, I honestly don’t know what happened over here, because this worked fine last time I ran KDE. This process of mine trying GNOME in the meantime seems to have messed something up for me.

Did you switch to gdp-prime? From experience of many users, although gdm-prime suppose to work, it oftentimes doesn’t work. Gdm simply sucks when it comes to optimus-manager setups, so I recommend using sddm.