Terminator fails to start

Why would my post be flagged as spam. Anway,

Terminator fails to start with

(terminator:4561): Gtk-WARNING **: 15:57:44.770: Theme parsing error: gtk.css:2:33: Failed to import: Error opening file »/home/user/.config/gtk-3.0/window_decorations.css«: No such file or directory
Traceback (most recent call last):
File “/usr/bin/terminator”, line 48, in
import terminatorlib.optionparse
File “/usr/lib/python3.9/site-packages/terminatorlib/optionparse.py”, line 24, in
from . import config
File “/usr/lib/python3.9/site-packages/terminatorlib/config.py”, line 76, in
from validate import Validator
ModuleNotFoundError: No module named ‘validate’

This package is not maintained by the Manjaro devs so if it must be fixed it will be done upstream (and is already flagged). Do your research before posting, and having just joined, your initial post does not leave a good first impression, on the contrary it shows no respect for the work they are doing, at least you could say a “Hi”.

This is an issue either because you have deleted a file or because the developer has a bug in the code.

This also seems to be an application error

Please search upstream for a solution

Hello @thirdrounder

Please take a look at how the forum works and please don’t antagonize with forum members.
I made a proper post for your issue.

By the error you get

It seems you are on KDE Plasma and using a custom GTK Theme. Either try Breeze, and see how that goes or disregard that because the bigger issue is in:

and what comes after that.
Try to reinstall terminator
pamac install terminator

Considering you restarted your system after update, it should work.

terminator is in the Arch community repo. :wink:

Yes, this is the issue. The latest testing update upgraded python-configobj, which appears to be causing it.

There is a patch on the way

sudo pacman -U https://mirror.f4st.host/archlinux/community/os/x86_64/terminator-2.0.1-1-any.pkg.tar.zst

1 Like

Updating from 1.9.2 to the most recent version did the trick. Thanks, top stuff.

Nope this is not the issue. It is an issue with the themes. Here is the file ~/.config/gtk-3.0/gtk.css

@import 'colors.css';
@import 'window_decorations.css';

The file window_decorations.css doesn’t exist.

This is a default KDE installation.

Here already on the forum: GTK themes doesn't work correctly after Plasma 5.20 upgrade (Manjaro testing)

Didn’t find a bug report.

//EDIT: switching the GTK theme from Adwaita-dark to Adwaita removes this line. switching back to Adwaita-dark doesn’t add the line back, so it must have been an issue now fixed by re-applying the GTK theme.
//EDIT2: and after reboot the line is back so no the issue is not fixed.

A missing css are not a showstopper - it is just theming so the initial issue causing terminator to fail is not related to the theming in use. You merely see them both and because you see them at the same time you think they are connected but they are not.

The Manjaro Team do a great job trying to create a consistent theming across GTK and Qt apps.

The css issue should be treated as a separate issue.

comment the line or create an empty file

/*@import 'window_decorations.css';*/

Just wanted to point that the issue was not because the user deleted his file or an issue with terminator code. This is an issue with themes in KDE. easily reproducible as demonstrated when I actually looked into it writing the reply.

I come back about this subject.
After all reboots, I’m obliged to do this command for Terminator; if not, always the same error. :face_with_thermometer:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.