[Testing Update] 2020-12-19 - KDE-git, Deepin, Firefox-Beta, Haskell, Pamac 10.0

Pamac 10 often does not return search results. I type what I want, press enter, and nothing happens

.

Here is (probably) the correct list of changes:
https://gitlab.manjaro.org/-/snippets/567/raw

Pamac gui is now fixed, thanks for the quick fix :+1: :+1:

I cannot upgrade pamac-trap-appindicator due to conflicting files with pamac-gtk (I am unsure why, but that is the only thing i cannot upgrade)

Yes because the new package is from the AUR… You might need to simply delete the offending files.
My guess is it would be these 2 files:

/usr/bin/pamac-tray
/etc/xdg/autostart/pamac-tray.desktop

I quite dislike the change in layout in pamac though… its a more vertical layout more usable on a phone while on desktop nowadays we have more realestate in terms of width.

2 Likes

getting:

Checking file conflicts…
Failed to commit transaction:
conflicting files:

  • pamac-tray-appindicator: /etc/xdg/autostart/pamac-tray.desktop already exists in filesystem (owned by pamac-gtk)
  • pamac-tray-appindicator: /usr/bin/pamac-tray already exists in filesystem (owned by pamac-gtk)

Yea im not too much of a fan of the new layout either, mostly since the left sidebar is gone, it looks a bit odd now. Got the package updated as well, thanks (hopefully it doesnt bite me later)

You can simply delete those two files, then update the tray-appindicator since its the same files afaik

I see that there are new pamac updates. Why so many new packages needs to be installed now and why pamac-tray-appindicator is from AUR now?

I also have the conflicting files. Which one needs to be deleted? Ah, never mind, I removed both of them.

I also am not a fan of UI changes, but maybe it’s only a matter of habit, so maybe I will get use to it with time.

im also getting this warning:

parallel: Warning: $HOME not set. Using /tmp.

and hopefully its not just me but since firefox developer 85 i have had an issue where it wont load. i just get one frozen firefox window on load and i have to kill it. uninstall it. reinstall it. log out. start in safe mode when it asks me too. then quit it and start it up again. then its fine till then next beta update.

Fixed with pamac-tray-icon-plasma 0.1.2-2. Now it properly conflicts with and replaces pamac-tray-appindicator.

so i have updated pamac-* to 10.0.0-2.

unfortunately the pamac still fails to find AUR updates. on top of that i did bit of testing tried installing a package, when pamac-manager crashed consistently. the stack traces and terminal dumps were reported in manjaro gitlab;

i’ve also logged a bug for the AUR update detection.

mhwd --list has no sense in this case. Use mhwd -li to show which configs are installed on your system.

Have you checked your mirrors have synced? The team pushed a second update for pamac that fixed the aur issue or at least it did for me

Can’t find the AUR repository after the latest update. Also no updates showing from AUR.

the second update is 10.0.0-2 (the latest as of now) which i’m on right now. didnt solve the AUR update issue for me, yet.

disabled aur. closed pamac, reopened and re-enabled. seems to have resolved it for me, just got an aur update for nordvpn

alright here is the latest, after seeing @zylan fixing the issue by first disabling AUR and closing pamac and re-enabling AUR, i doubted this is some sort of setting persistence issue. i tried it, didnt fix the issue for me.

so i invoked “refresh databases” in pamac options menu, and since then i’m getting the pending AUR and normal updates. the databases must be refreshed post 10.0.0 update

1 Like

The software mode need to be disabled in ordre to see AUR preferences

1 Like

check after reboot if nord vpn works, if it doesn’t read the aur comments :wink: anyway that’s not the topic but just warning you as it will 99% not work.