[Testing Update] 2020-11-13 - Kernels, Plasma 5.20.3, Mesa 20.2.2, OnlyOffice 6.0.1

You’ve customized it, so you can ignore it as those are just the defaults. However, I recommend not changing GRUB_CMDLINE_LINUX_DEFAULT and add your customizations to GRUB_CMDLINE_LINUX so it’s easier to merge any new defaults and keep track of your own customizations.

apparmor ones were there when I installed the system in June. I was wondering if it’s being phased out or something.
My own modifications have been the removal of ‘quiet’ and addition of ‘sysrq_always_enabled=1’

How did you upgade to 12.5-3? I only see 12.5-1 and that won’t start…

Install package from unstable branch e.g.

sudo pacman -U https://manjaro.lucassymons.net/unstable/extra/x86_64/postgresql-12.5-3-x86_64.pkg.tar.zst

Or install downgrade, run
sudo downgrade postgresql

and select version you want to install. This will pull package directly from arch repos.



Apparently a number of us are running NVidia Gfx solutions under 5.9. Can you tell us what type of machine(laptop/desktop) and what Gfx driver you are using. Someone here might be able to help.

Minor thing but I report it, every now and then I see posts like this one asking for the updated (>=5.20) OSD look

to which I responded that one could dirty copy paste the OSD folder of Breeze /usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/ to the official Breath2 by @bogdancovaciu, so you 'd want to maybe take a look at it before 20.2 Nibia comes out.


I encounter the same problem with the brightness control on 5.9.8-1 kernel. I switched to stable branch to have a previous 5.9.x kernel (5.9.3-1). The brightness is set to 100% on 5.9.8-1 with Intel card only and there is no possibility to change it.

How can I update from 5.9.3-1 to 5.9.6-1 kernel ? Pamac give me the 5.9.8-1 only. Thanks.

I set my system to french language but many parts are still in english under Manjaro 20.2 KDE-rc1 (Konsole menu items, system configuration buttons, …). I think everything is not translate on KDE plasma 5.20.3.

I tested plasma Wayland session and I hoped that it was ready now but it is not the case yet. Too bad. The virtual keyboard doesn’t work very well, and it miss a kgamma alternative (the color night option is not the best thing to change the gamma or modify the screen colors (RGB)).

One last thing. As I said on another topic, can you add the OEM installation option in Manjaro 20.2 KDE final version (as it is available in the Gnome version) ? So, I could install Manjaro 20.2 KDE version on the computers of my friends and family in OEM mode. Thanks.

Hi @AlanP I stayed on testing branch and installed linux59-5.9.6-1 from my pacman cache:

sudo pacman -U /var/cache/pacman/pkg/linux59-5.9.6-1-x86_64.pkg.tar.zst 

Depending on how many versions of packages you keep, you likely still have it on your machine.

For good measure, I have also set IgnorePkg = linux59 in /etc/pacman.conf for now to hold on to 5.9.6-1.

can you please try i915.enable_dpcd_backlight=0 or i915.enable_dpcd_backlight=3 and see if there is difference


linux-firmware and amd-ucode are not updated, only in unstable

Adding kernel parameter:


fixes issue with brightness control for me.

Thanks @phush0!

Thanks for the update! NVIDIA 390 driver is finally available for my GeForce 820M GPU.

Thank you @phush0! I can also confirm this solved the brightness control problem for me.


Thanks for your fix. I will tell you later if it has worked or not. In the instant I’m writing, I’m on another system than Manjaro.

Could you tell us what’s wrong ? Is it a bug in the 5.9.8-1 kernel ? We have no problem with older kernel.


I tried these two options and I haven’t seen any changes in control of backlight, I’m on a i7-8750H.

Also, I’m experience loss of video when returning from sleep (laptop lid closed) and lots of error on the journal.

I didn’t notice audio problems but I also got the following error.

snd_hda_intel can't change power state from D3cold to D0 (config space inaccessible)

Looks like something went bananas with an intel controller that’s failing to wake up several things.
I downgraded the kernel back to 5.9.6-2.

new patch, that obviously, is nor ready for prime, I suppose they will remove it in 5.9.8-2, because it causes more problems than solved

I have no issues on this Update, but I think its a good idea to post

hw-probe preview


latest one on this machine, I think, new Machine is in Order :slight_smile:

1 Like

Ok. I tested your fix and it works. Thank you. :wink:

Using with nvidia proprietary driver, sddm crashed, error message something like

could not get display id from pipeline

Downgrading plasma-desktop to 5.20.2-1 solved

I actually never needed to upgrade to an unstable pkg. Thanks!