[Testing Update] 2020-10-27 - KDE-git, Firefox, Deepin, Plasma 5.20.2, LibreOffice, Linux 5.10-rc1

warning: directory permissions differ on /var/lib/gdm/.local/
filesystem: 755  package: 700

Thank you for the updates.

Fine for me: KDE plasma 5.20.2 + Linux 5.9.1 + Ext4 + Wayland. Some french translations missing but otherwise it’s good.

Fine for me in both machines.
Intel + nvidia laptop: Manjaro i3 + linux 5.8.16 + prime using nvidia 450.
Ryzen + nvidia desktop: Manjaro KDE + linux 5.8.16 + nvidia 450.

how to get plasma 5.20? when will it will come to stable?

1 Like


Gnome - testing: accidentally read journalctl
many entries beginning with:

gnome-shell[1298]: Can’t update stage views actor …
(Can’t update stage views actor ClutterText is on because it needs an allocation.
Can’t update stage views actor StIcon is on because it needs an allocation.
Can’t update stage views actor Gjs_ui_appDisplay_AppIcon is on because it needs an allocation.)

I’m not sure if it is only me, but I had several GPU crashes with Kernel 5.8 and nvidia 455. First when it happened previous update I though it was the game I was playing on, but it happened some other times since then.

oct. 28 15:35:03 omano-nvme kernel: NVRM: GPU at PCI:0000:07:00: GPU-6741dc5c-a7dd-c3f6-ab1f-5c3df75b5786
oct. 28 15:35:03 omano-nvme kernel: NVRM: GPU Board Serial Number: 
oct. 28 15:35:03 omano-nvme kernel: NVRM: Xid (PCI:0000:07:00): 79, pid=0, GPU has fallen off the bus.
oct. 28 15:35:03 omano-nvme kernel: NVRM: GPU 0000:07:00.0: GPU has fallen off the bus.
oct. 28 15:35:03 omano-nvme kernel: NVRM: GPU 0000:07:00.0: GPU is on Board .
oct. 28 15:35:03 omano-nvme kernel: NVRM: A GPU crash dump has been created. If possible, please run
                                    NVRM: nvidia-bug-report.sh as root to collect this data before
                                    NVRM: the NVIDIA kernel module is unloaded.

It can happen when browsing Youtube, or playing a Proton game for example. It seems random.
When it happens, fans go full speed, I have no video output, and I can’t do anything but hard reboot.

I switched to Kernel 5.4 to see if it happens there too.

//EDIT: it happens on Kernel 5.4 too. I switched to drivers 450 and will see if issue is still there. I doubt it but it could be a hardware issue. I doubt it really.
//EDIT2: kernel 5.4 nvidia 450 same issue
//EDIT3: kernel 5.4 or 5.8 + nvidia 440 and no issue so far. Seems like 450 and 455 drivers have issues currently. No issues on Windows after a couple hours tests gaming.
//EDIT4: still no issue with nvidia 440 after one more day. For me there is an issue with latest 450 and 455 drivers. I might try to go back to 455 and troubleshoot and/or find a way to catch more error logs.

1 Like

If you want to get Plasma 5.20 now, you will have to switch branches according to instructions in the Wiki (it’s very easy to do). Otherwise, you’ll have to wait a few days. Manjaro devs will post in #announcements when they add Plasma 5.20 to the stable branch.

I find Plasma 5.20 stable enough that hopefully it should be pushed into stable soon.

1 Like

I have it too on 5.8 and Nvidia 455, but mostly resuming from standby

For now, no issue with nvidia 440 but it limits things like using NVENC (only supported with latest drivers), if you want to try and confirm the issue disappear it could help confirm an issue in 455/450 drivers.

This Discord entry from the wiki post can now be removed since Arch fixed the packaging screwup.

Hi. I’m having a few issues with the Manjaro Gnome since the Mikah 20.1.2 release. Such issues persisted with the Nibia 20.2 pre1, pre2 and pre3. The issues are:

  • I’m no longer able to install Dropbox and Spotify from the AUR (key issue; not trusted). I tried to add the keys, but the problem persists. However, I could install the Zoom app from the AUR with any problem whatsoever. I have never had any problem of this kind before since Manjaro 18.

  • When I suspend my laptop and “awake it up” to make login again, it first shows my freeze screen as I left it (like a printscreen) and only after a couple seconds my login screen appears. This issue causes a problem of privacy, since anyone can “awake” your laptop and see whatever window you left opened when you put it on suspension mode.

  • The system requires password when I turn on my laptop. When installing Manjaro, I checked the box “do not require password to login,” but the system keeps asking me my password anyway. When I go to Settings>Users, it shows the system is set to make “automatic login”, then I turn it off and on again, but this setting only lasts for one system initialization; the second time it already comes back asking my password. I never had this issues before.

Those were the issues I could detect so far.
Thanks for your attention.

It looks like the new version of fmt breaks waybar for Sway users. fmt 7.1.0-1 introduces this error:

waybar: symbol lookup error: /usr/lib/libspdlog.so.1: undefined symbol: _ZN3fmt2v76detail10vformat_toIcEENS0_20basic_format_contextISt20back_insert_iteratorINS1_6bufferIT_EEES6_E8iteratorERS7_NS0_17basic_string_viewIS6_EENS0_17basic_format_argsINS3_IS4_INS5_INS0_13type_identityIS6_E4typeEEEESH_EEEE

This looks like it is inherited from Arch, as users there have been experiencing this for a few days. Downgrading to fmt 7.0.3-1 solves the problem for now.

EDIT: It looks like Arch pushed out a fixed version of Waybar recompiled against the new fmt. Is there a chance that we could get this pushed out to Testing?

1 Like

Same problem here.

I switched yesterday from Stable to Testing, everything works well. (I wouldn’t normally reply that everything’s working, but I thought this extra information may help someone).

Using: Gnome, Wayland, AMD Graphics

How are we supposed to merge the changes to the /etc/mkinitcpio.conf config file ?
Diff says:



-HOOKS="base udev autodetect modconf block keyboard keymap encrypt filesystems fsck"
+HOOKS=(base udev autodetect modconf block filesystems keyboard fsck)

1 Like

Just substitute quotation marks with round brackets as suggested by the pacnew file. With your contents left intact. Like HOOKS=(base udev autodetect modconf block keyboard keymap encrypt filesystems fsck).
And add #COMPRESSION="zstd" to the list of compression methods.
Or better, copy your unique settings from old file into the new one, then delete old one and rename new one.


Yup, seeing this too.

There was just a new small update (23) some hours ago, right ? including keyring signatures update.

That’s right, it just got posted here: