[Testing Update] 2020-10-16 - Kernels, KDE-git, Mesa, Python, Haskell

Yeah, a few posts above. But here it is again:


1 Like

Oh, missed that. Strange since I replied to that comment. Oh well…

short version: no thanks :slight_smile:

long version

I think this is the best way to break the system and anyway considering that the aur version works I think a rebuild is enough and that’s why I tagged Helmut Stult which is the current packager.


I had it working on non latte panels before today’s update. Even that now appears to be not working.

Das wäre die Alternative:

nvidia440xx was missing too, last time I checked…

I am still trying to make the Leave > Shut Down sequence reproducible. What I think happens on newer builds is that the timer comes up, I hit enter, but I still have to wait 30 seconds.

But, no matter what the hard power button should be a last resort. What works for me when Leave > Shut Down does not is to open krunner (alt-space) and type systemctl poweroff.

This was not on Manjaro but rather on another Arch based distro. It is a heavily customized distro. My friend decided to install Manjaro and wait for 5.20 to get cleaned up. The ‘Leave’ was visible but did not do its job. And it used the Latte Dock. I just checked with my friend and she says she really likes the change.

Check the branch compare website, it only has 450 and 455 for linux59, I think they don’t build all modules all the time for beta kernels.

//EDIT: OK it appears it is not RC kernel anymore it is 5.9.0 now so I guess wait for an update on that.


I installed it, and when checking my disks SMART status (searched SMART in the application launcher, don’t know where to find it elsewhere), it says all my disks seem to not work correctly.

For me it says all my devices seem to not work properly

I updated and everything is still OK, but the new Plasma feature (plasma-disks) in the Info Center tells me that all my “devices seem to not work properly” (translated from my French localized system).

Anyone having an idea how to troubleshoot, or if there is something to do to have it to work properly?

//EDIT while writing the post: OOOOKKKK there is a BIG problem with the people translating


, really BIG problem. They translate the DIRECT OPPOSITE of what the English original message is telling me, this is really bad… I already noticed lot of ‘bad’ or ‘literal’ translations since I use Manjaro, I never reported any but this one has to be fixed ASAP (or else you’ll need to explain everyone who discover the new feature that they need to understand the opposite of what the message tells them) this is not OK, and I highly recommend people to check the original english text from terminal kinfocenter smart and from application launcher their localized version Info Center (German, Spanish, and so on…).

So the question now is, where should the translation errors be reported? please direct me to the proper source. //EDIT: I found that, probably on the good way, still looking… KDE Localization - Search a string in translations

For fun here you have original English SMART menu in Info Center: https://i.imgur.com/4qquO9q.png

Here you have the localized French non sense: https://i.imgur.com/g9KMOUa.png

I don’t inderstand how this is possible, this has to be malicious :upside_down_face: this is the total opposite in French from original English.

//EDIT: OK I found another page here KDE Localization - Apps » trunk-kf5 » French » plasma-disks and it seems the message in the file there is properly translate so it has probably already been corrected (again, even a monkey with google translation would not have made this mistake lol) and Manjaro is maybe using an outdated localization file.

Wait and see for update on Manjaro side for the localization file.

Two days I tried to find why it wasn’t reporting properly… I usually always try to open applications from terminal to see if the original version is the same when I have an issue… not this time… would have save all the wasted time…

I just ran this update and I got a lot of locale errors, like:

/etc/locale.conf: line 7: warning: setlocale: LC_NUMERIC: cannot change locale (en_AU.UTF-8): No such file or directory
/etc/locale.conf: line 10: warning: setlocale: LC_TIME: cannot change locale (en_AU.UTF-8): No such file or directory

Haven’t had this at all this year. Anyone else experiencing this? Not sure how to fix it either.

Hello Manjaro Team,

I tested Kde 5.20 on Wayland. I have a bug to report.

Qtvirtualkeyboard doesn’t work anymore when I do search (via configuration system settings or via search bar). QtVirtualkeyboard works on login screen only (the virtual keyboard is above and not below). Can someone here report the bug to Kde bugs team ?

Sometimes the system freeze when I try to reboot or shutdown the system in the login screen.


Note: Kde 5.20 and kernel 5.9 installed on my system.

What is in your /etc/locale.conf?

Thanks for the heads up. I just checked it and it’s really descriptive.

Solved by updating firejail to 0.9.64rc1-2…

just updated the kernel and it seems to work again with Kernel 5.9.1
so far no other issues with the update.
i’ve changed the vote to “no issue” aswell.

For some reason it was erased / made blank by some part of this update (I think), so I filled it again with all my usual values and that solved my immediate problems. Hopefully when I reboot nothing else will be broken :slight_smile:

1 Like

Sounds like [Testing Update] 2020-09-02 - Kernels, Xorg-Server, Systemd, Firefox, Thunderbird, Wine

Also there was a new update today this thread should be closed now.

Here is bugzilla where we report KDE bugs:


I know, it’s not not user-friendly, but if you are already using Manjaro testing branch, it means you have to be ready to report bugs either here (Manjaro bugs) or upstream (software bugs).

If you are unsure which one of the bugs this is, create a new topic on Manjaro forum, to ask other users if they have the same issue or not. If they do, this means it’s worth to report to bugzilla. Even if the report already exists and you didn’t find it, your bug report will be marked as duplicated and then linked to the first report, which give you direction where the actual bug is being worked on.

If the problem cannot be confirmed by others, maybe you find someone who can help you fix it.