[Testing Update] 2020-10-19 - Kernels, Alsa, Haskell, Pamac, Calamares

It’s actually a repo package, that @schinfo added (last packager).

Rebuilding from source fixes that, of course. But it has (relatively recently) became an official repo package.

I can also see that @schinfo bumped the pkgrel version yesterday, so I guess 1.1.1-3 just didn’t make it to the update for some reason…

( 8/37) mise à jour de grub-theme-manjaro                                                          [----------------------------------------------------------] 100%
Création du fichier de configuration GRUB…
Thème trouvé : /usr/share/grub/themes/manjaro/theme.txt
Windows Boot Manager trouvé sur /dev/sdc1@/efi/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for UEFI Firmware Settings ...
==> Installation: Theme is added to your /etc/default/grub: GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"
==> Default resolution "auto"
==> If an OS icon doesn't appear probably not present in /usr/share/grub/themes/manjaro/icons simply add it or merge in
==> https://gitlab.manjaro.org/artwork/branding/grub-theme

Everything seems OK (//EDIT: kernel 5.8, Nvidia 455), but it is the second consecutive update erasing my custom GRUB theme GRUB_THEME="/boot/grub/themes/pacbang/theme.txt", is this something I’ll have to revert regularly now? Maybe if it can be possible, do not override this line if it is not the default Manjaro theme already?


Pamac threw this error (and put up an error window):

Detecting snapshots ...
Info: Separate boot partition not detected 
No snapshots found.
If you think an error has occurred , please file a bug report at " https://github.com/Antynea/grub-btrfs "
Error while configuring 
Nothing to do. Abort.
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

Will send bug report to btrfs at github (IF there is a bug) as it recommends.

I just rebooted, everything seems to be OK, so I guess this error was nothing to worry about.

octopi reacting very slow when pressing Apply
not yet update to freeoffice 978?

Info Center -> SMART still has the non sense French translation saying THE EXACT OPPOSITE of the original English version… It is telling me all my peripherals seem to not work properly, when in the original version it is telling me the opposite, all me peripherals seem to work as intended.

17 posts were merged into an existing topic: Update error - unsure of update cycles/consequences

No issues, I can see so far.: XFCE + linux58 + BTRFS
I can safely turn on Bluetooth again :slight_smile:

A post was split to a new topic: Update error - unsure of update cicles/consequences

Hope I can install Manjaro with linux59 isos…might not happen but hope for the best :grinning::grinning::pensive:

Running Arch with 5.9.1 for a Day without any kind of issue…but really want to use Manjaro with new kernels

A post was merged into an existing topic: Update error - unsure of update cycles/consequences

It happens all the time that there are updates without announcement, Manjaro team doesn’t create a new thread when some packages got updated, and again, you’re twisting the chronology, the information of the issue being about Stable branch was not there at all, when I started trying to figure it out, when a user posted information about an issue in the Testing branch thread. I don’t have a crystal ball.

I lost my audio, probably due to the ALSA update. I just have a “dummy output” that doesn’t play any sound. Ideas?

I temporarily solved by downgrading alsa-ucm-conf as suggested here.

I had an issue with Brave web browser after installing these Testing Updates. All of my estimated earnings for this month vanished and I was kind of alarmed. Eventually corrected on it’s own. Took a few minutes though. Thought I had lost my BAT tokens.

I was expecting at least some minor new issues with the Plasma 5.20 upgrade, but surprisingly, none have appeared on my end so far. I’m loving the new grub theme too because it’s very reminiscent of the dark theme from this forum!

Thanks for the cool updates this past week, Manjaro team!

Basically no problems but the arc-icon-theme claims that it depends on moka-icon-theme which can’t be located.

1 Like

@philm could you please update git files for linux58 so we could see what’s new in 5.8.16-2?

what kernel were you on? I was going to say the same thing. But I solved by switching to kernel 5.9

I’m on 5.8. So you’re saying that I can try to re-update the package and switch to kernel 5.9?