[Testing Update] 2019-08-15 - Nvidia, Firefox, Haskell, LibreOffice, VIM, XFCE

Hello community,

I am happy to announce another Testing Update. Mostly we have XFCE, Nvidia and LibreOffice updates with this one.

Update news

This update holds the following changes:

  • XFCE packages got renewed. We also added some meta-transition packages, which drop our gtk3-builds.
  • LibreOffice is now at 6.3.0 and 6.2.6
  • Nvidia is now at 435.17. For GPU offload instructions, please see here.
  • Haskell and Firefox got updated to their latest releases
  • VIM got newer spell-check packages
  • Latest efforts by KDE can be reviewed via our current KDE-Dev ISO or current KDE-Vanilla ISO
  • Manjaro Juhraya ISOs got updated, including flatpak and snap support pre-activated. Office can be selected during installation between libreoffice-still or freeoffice: XFCE, KDE, Gnome

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.70
  • linux44 4.4.189 (no legacy nvidia-340 module!)
  • linux49 4.9.189
  • linux414 4.14.138
  • linux419 4.19.66
  • linux51 5.1.21 [EOL]
  • linux52 5.2.8 (no catalyst module!)
  • linux53 5.3-rc4 (not all modules build yet!)
  • linux419-rt 4.19.50_rt22
  • linux50-rt 5.0.21_rt16

Package Updates (Thu Aug 15 20:41:53 CEST 2019)

  • testing community x86_64: 337 new and 336 removed package(s)
  • testing core x86_64: 1 new and 1 removed package(s)
  • testing extra x86_64: 446 new and 538 removed package(s)
  • testing multilib x86_64: 7 new and 7 removed package(s)

A more detailed list of all package changes you may find here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

10 Likes

Hello @philm,
I made the testing update from manjaro deepin.
I am using kernel 5.3.0-1-MANJARO #1 SMP Sun Aug 11 22:57:21 UTC 2019 x86_64 GNU/Linux and nvidia propietary.
At first reboot,after grub I got a black screen, then from alt f2 switched to stable and downgrade with sudo pacman Syyuu --force

Some hours ago I made this to circunvent a manjaro deepin long desktop bug:


Not sure If that have something to do... or not at all

I don't know what provoked the graphical stall after upgrade :fearful:

1 Like

Remove those options and update again. That will answer your question.

I don't understand. My LO is already there, since IIRC the previous Testing update... ?

[2019-08-15 18:19] [ALPM] upgraded libreoffice-fresh (6.3.0-0 -> 6.3.0-1)

:grin:

but...but...but...

:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-12           2019-08-15
-------------------------------------------------------------------------------
                            exo-gtk3             0.12.8-1         2019.08.15-1
                         garcon-gtk3              0.6.4-1         2019.08.15-1
                   libreoffice-fresh              6.3.0-0                    -

my laptop updated from 6.3.0-0 to 6.3.0-1 just now plus a few other packages like displayCAL. Even though the desktop has the package list and the same mirror list it's finding nothing yet. I'll do that machine at some point when it wakes up and smells the coffee like me eventually tomorrow :slight_smile:

If I'm not mistaken, 6.3.0-0 was built by jonathon and 6.3.0-1 is directly pulled from the arch repo.

2 Likes

That's crazy zbar and gst-plugins? :roll_eyes:

for some crazy reason it is required by gst-plugins-bad, so the removal of zbar triggers 22 more packages to be removed too. I'm leaving well alone...

2 Likes

I noticed that when I went to remove it.
Mystery solved. :wink:

How is it that for example below, the two packages installed don't conflict?

extra/xfce4-settings                                   4.14.0-1.1      3.65 MiB       0.51 MiB
extra/xfce4-settings-gtk3                4.14.0-2      2019.08.15-1   -3.64 MiB       0.01 MiB
1 Like

Yes , some overlays with Xfce:

$ pacman -Qg xfce4
xfce4 exo
xfce4 garcon
xfce4 thunar
xfce4 thunar-volman
xfce4 tumbler
xfce4 xfce4-appfinder
xfce4 xfce4-panel
xfce4 xfce4-power-manager
xfce4 xfce4-session
xfce4 xfce4-settings
xfce4 xfce4-terminal
xfce4 xfconf
xfce4 xfdesktop
xfce4 xfwm4

$ pacman -Qg xfce4-gtk3
xfce4-gtk3 exo-gtk3
xfce4-gtk3 garcon-gtk3
xfce4-gtk3 libxfce4ui-gtk3
xfce4-gtk3 libxfce4util-gtk3
xfce4-gtk3 thunar-gtk3
xfce4-gtk3 xfce4-appfinder-gtk3
xfce4-gtk3 xfce4-notifyd-gtk3
xfce4-gtk3 xfce4-panel-gtk3
xfce4-gtk3 xfce4-power-manager-gtk3
xfce4-gtk3 xfce4-session-gtk3
xfce4-gtk3 xfce4-settings-gtk3
xfce4-gtk3 xfconf-gtk3
xfce4-gtk3 xfdesktop-gtk3
xfce4-gtk3 xfwm4-gtk3

what is the difference between kde-dev iso and kde-vanilla iso?

It is simple. Our packages are now meta packages depending on the upstream package.

Dev comes with Manjaro branding and additional fixes, vanilla with stock config.

1 Like

i have theses orphans

apparmor 2.13.3-4
egl-wayland 1.1.3-1
libwnck 2.31.0-2

Try running mkinitcpio -p linux if you updated the nvidia drivers.
https://wiki.archlinux.org/index.php/NVIDIA#DRM_kernel_mode_setting

mkinitcpio -p linux that's for archlinux, I don't know if its the same for Manjaro, check the wiki :wink:

1 Like

Updated my LXQT with kernel 5.2.
All good :+1:
Thanks!

@philm
As @korealinux suggested I removed @ant fix then reboot then set testing branch, update and reboot.

During boot it full stops at TLP, I tried 5.3 and 5.2 kernel.

Once again I logged in from console and reverted the 25 packages upgrade, at stable no problem at boot, writing this from stable.

@ant I will do a third attempt trying to run that mkinitcipio once the update is done... But I think something is messing my system and that is at the testing update packages

@philm
As @korealinux suggested I removed @ant fix then reboot then set testing branch, update and reboot.

During boot it full stops at TLP, I tried 5.3 and 5.2 kernel.


Once again I logged in from console and reverted the 25 packages upgrade, at stable no problem at boot, writing this from stable.

@ant I can do a third attempt trying to run that mkinitcipio once the update is done... But I think something is messing my system and that is at the testing update packages.:thinking:

I am using a nvidia gtx 1070 ti graphic card.

Forum kindly sponsored by Bytemark